Page 1 of 2 12 LastLast
Results 1 to 20 of 26

Notice oil pressure higher then normal...

This is a discussion on Notice oil pressure higher then normal... within the General Help forums, part of the LSx Technical Help Section category; Maybe it's always like this and i just noticed, but while driving i notice oil pressure guage reads around 60 ...

  1. #1
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    Notice oil pressure higher then normal...

    Maybe it's always like this and i just noticed, but while driving i notice oil pressure guage reads around 60 psi. been using the same mobil 1 synthetic so no change in oil or anything. is this normal?

    Car is a 99 Camaro SS

  2. #2
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    The higher the RPM...the more pressure it should have.

    So I would guess it is normal.
    The saying is 10PSI for every 1000 RPM.
    2008 Trailblazer SS
    Yank PTB3600, Kooks 1 7/8" LT's, 4" intake, E-fans, Magnaflow, Sonnax kit, tranny cooler, tune.
    Lowered, HID's, tinted.

    1999 Pontiac Trans Am WS.6 #1747 SOLD
    531.1 RWHP 481.3 FT/Pounds all motor.

  3. #3
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Clogging oil filter or passage possible??

    PSI doesnt equal good oil flow..


    What kind of filter do you run?

    If sarge reads this he will recommend AutoRx

    So Ill save him some time...

  4. #4
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    Some oil filters flow better than others, the one you are using MAYBE more restrictive.

    SteveC

  5. #5
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    Same oil?
    Same viscosity?
    Same oil filter?
    Same as what you have been running?

  6. #6
    Member 99WS6MAN's Avatar
    Join Date
    Dec 2005
    Location
    TX
    Posts
    309

    Red
    99 Pontiac WS.6 Trans Am

    Did you maybe out too much oil? I topped my off a couple of weeks ago and put about 1/2 a quart too much and I noticed that my Oil Pressure is high as well. I figured I'm going to change my oil in a couple of weeks so I'll just wont drive the car so much .... could this maybe create a high oil pressure?

  7. #7
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    i don't change my own oil but i told them to use the same that's always been in there... so i can't tell you what kind of filter is in there. I will check oil levels later on today and see whats up.

  8. #8
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    Arrghhh....The Jiffy Lube problem. No telling what is in there/how much nor what filter. All bets are off. Who knows.

  9. #9
    Member 1SSWFO's Avatar
    Join Date
    Aug 2005
    Location
    RIGHT BESIDE THE LEMON TREE IN HELL!!!
    Posts
    280

    LIGHT PEWTER METALIC
    1999 SS CAMARO

    Hell mine is the same year and I noticed that mine was doing that too? Mobil 1, ac delco filter and I change the oil myself nothing has changed other than mileage? mines got 71k on it. IDK either ? I did notice that the Pressure gauge stays on about 40 even if the cars not running ? Cheap Mexican gauge maybe?

  10. #10
    Senior Member 00z28bubba's Avatar
    Join Date
    Dec 2007
    Location
    las vegas, nv
    Age
    29
    Posts
    1,390

    white
    2000 Z28

    Quote Originally Posted by 1SSWFO View Post
    Hell mine is the same year and I noticed that mine was doing that too? Mobil 1, ac delco filter and I change the oil myself nothing has changed other than mileage? mines got 71k on it. IDK either ? I did notice that the Pressure gauge stays on about 40 even if the cars not running ? Cheap Mexican gauge maybe?
    the car is canadian not mexican.

  11. #11
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    Quote Originally Posted by 1SSWFO View Post
    Hell mine is the same year and I noticed that mine was doing that too? Mobil 1, ac delco filter and I change the oil myself nothing has changed other than mileage? mines got 71k on it. IDK either ? I did notice that the Pressure gauge stays on about 40 even if the cars not running ? Cheap Mexican gauge maybe?
    Has Mobil1 cheapened their oil again?

  12. #12
    Member 1SSWFO's Avatar
    Join Date
    Aug 2005
    Location
    RIGHT BESIDE THE LEMON TREE IN HELL!!!
    Posts
    280

    LIGHT PEWTER METALIC
    1999 SS CAMARO

    Thumbs up

    Ok excuse me the gauge is probably made in Taiwan anyways? I really don't know whats up with the oil these days but I'm sure if theres a way to sale something cheaper as a substitute we won't know? Guess in the mean time run the guts out of it ??

  13. #13
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Quote Originally Posted by 99WS6MAN View Post
    I topped my off a couple of weeks ago and put about 1/2 a quart too much
    I intentionally put that into mine.
    I always fill to 6 quarts...not the 5.5 the manual recommends.

  14. #14
    Just a farmboy V8MUSCLE's Avatar
    Join Date
    Jun 2007
    Location
    Montpelier, VA
    Age
    30
    Posts
    518

    Pewter
    2000 Pontiac Trans Am

    i thought too much was supposedly worse than not enough. the crank will "whip" the oil causing it to foam up dropping oil pressure

  15. #15
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Quote Originally Posted by V8MUSCLE View Post
    i thought too much was supposedly worse than not enough. the crank will "whip" the oil causing it to foam up dropping oil pressure
    This happens when you overfill by a bunch!!!

    1/2 quart isn't going to be an issue. It actually keeps me from seeing a dip in pressure at WOT in 1st and 2nd gears. Stupid acceleration.

  16. #16
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    My car runs around at 60psi on the stock gauge also. I think its normal.
    Mobil 1 and AcDelco filter.

  17. #17
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    Quote Originally Posted by 1SSWFO View Post
    Hell mine is the same year and I noticed that mine was doing that too? Mobil 1, ac delco filter and I change the oil myself nothing has changed other than mileage? mines got 71k on it. IDK either ? I did notice that the Pressure gauge stays on about 40 even if the cars not running ? Cheap Mexican gauge maybe?
    mexican????......really??

  18. #18
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    ok so i checked and the oil level is fine, not overfilled. i'm guessing the damn MEXICANS (jk) used a different oil filter then what is normally used that's why i notice the higher pressure.

  19. #19
    Member nillam1's Avatar
    Join Date
    Apr 2009
    Location
    Toronto, Ontario, Canada.
    Posts
    392

    Red
    2002 Camaro Z28

    Thumbs up

    Quote Originally Posted by 00z28bubba View Post
    the car is canadian not mexican.
    UH! The car is AMERICAN, assembled in CANADA and ya, alot of the parts are made in MEXICO, por favor. I think he was just joking though.
    2002 Camaro Z28 Bolt ons, Flowmaster catback w/3" QTP electric cutout, Superchips tuned, Granatelli MAF, SLP cold air induction Lid & filter, ZEX powertune plugs, Taylor 10.4mm wires, 160 T-stat w/fan control, Eibach sportlines & BFG-KDW's on 17" SLP SS rims.

  20. #20
    Senior Member 00z28bubba's Avatar
    Join Date
    Dec 2007
    Location
    las vegas, nv
    Age
    29
    Posts
    1,390

    white
    2000 Z28

    Quote Originally Posted by nillam1 View Post
    UH! The car is AMERICAN, assembled in CANADA and ya, alot of the parts are made in MEXICO, por favor. I think he was just joking though.
    well just for the record i could have been made in america and born in canada if my mom gave birth in canada, and i would still be registered as canadian assuming it was a canadian hospital. i realised the joke too but the joking doesnt get across w/o smilies though. i just forget to use them half the time. ok im done tjing

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel pressure loss normal?
    By Dewman in forum General Help
    Replies: 2
    Last Post: 06-18-2010, 04:49 PM
  2. oil pressure high, normal?
    By Ramairgod84 in forum General Help
    Replies: 17
    Last Post: 11-12-2009, 11:05 PM
  3. THANKS for the NOTICE! :)
    By SexyWS6Mama in forum Almost Anything Goes
    Replies: 21
    Last Post: 08-11-2008, 08:03 PM
  4. Ever notice...
    By jrc1122 in forum Almost Anything Goes
    Replies: 29
    Last Post: 06-01-2008, 11:33 AM
  5. lower tire press. higher ET, higher press lower ET???
    By greatwhiteZ28 in forum Drag Racing
    Replies: 1
    Last Post: 10-20-2007, 06:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •