Results 1 to 1 of 1

Is this Normal?

This is a discussion on Is this Normal? within the General Help forums, part of the LSx Technical Help Section category; Just got a 95 Camaro When i am in Drive and Stompo n it with the ARS OFF it won`t ...

  1. #1
    Junior Member
    Join Date
    Jun 2009
    Location
    Kamloops
    Posts
    2

    Green
    95 Camaro

    Is this Normal?

    Just got a 95 Camaro
    When i am in Drive and Stompo n it with the ARS OFF it won`t Spin the tires even a little bit. When i had my 87 Iroc I could get 3 or 4 feet of posi rubber but not with this one...is this Normal? AlsoI want to put a shift kit into it...how do i find out what Tranny i have?
    Talking about the ARS what does that stand for? Also I was wondering if there is a way to switch it so that the ARS Stays OFF all the time until you turn it on instead of having to shut it off everytime you restrart the car

    Thanks
    Malcom
    Last edited by kushal_22; 06-03-2009 at 12:11 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: is this normal?
    By dav-02ws6-m6 in forum General Help
    Replies: 14
    Last Post: 05-16-2010, 06:53 PM
  2. Is This Normal?
    By bgable in forum General Help
    Replies: 2
    Last Post: 04-29-2008, 06:37 PM
  3. Is it normal...?
    By 1MileCrash in forum Manual Transmission
    Replies: 14
    Last Post: 04-11-2007, 07:02 PM
  4. Is this normal?
    By {FzS}BlacKMagicK in forum General Help
    Replies: 15
    Last Post: 02-23-2007, 02:50 AM
  5. normal?help
    By 01SOMSS! in forum Internal Engine
    Replies: 0
    Last Post: 01-20-2007, 11:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •