Results 1 to 4 of 4

Noise under hard acceleration-auto tranny related

This is a discussion on Noise under hard acceleration-auto tranny related within the General Help forums, part of the LSx Technical Help Section category; Under hard acceleration from a stop, when the car makes its 1-2 shift, it sounds like the trans is loose, ...

  1. #1
    Giant Dicks Car Club Zapper2003's Avatar
    Join Date
    Nov 2006
    Location
    Millerton, PA
    Posts
    5,144

    2005 Ram
    1978 Firebird

    Noise under hard acceleration-auto tranny related

    Under hard acceleration from a stop, when the car makes its 1-2 shift, it sounds like the trans is loose, perhaps the mount has failed. I have a shift kit installed and an aftermarket posi rear, traction isn't really too much of an issue, so I'm wondering if on the 1-2 shift if the trans isn't moving around a bit on me. The car has 104k miles on it, and im sure its an original mount. It makes a pretty serious clunking sound in/around the transmission tunnel/center console area. The Torque Arm is still in tact and in place, it hasn't come loose from its mount either.

    If this sounds like a bad tranny mount, what company sells a good one? Preferably polyurethane. Also, does said company (or any company for that matter) sell a good poly kit to outfit my entire car, or are all pieces sold individually? Thanks.

  2. #2
    My Neighbors Hate Me!!! lvbroham1's Avatar
    Join Date
    Jun 2006
    Location
    Ft. Lee, Virginia
    Posts
    374

    Artic White
    2001 Chevy Camaro SS

    Yea, sounds like your tranny mount took a dump. Replace that ASAP, even if it's not that it'll be good matinence for you car especially if you don't remember ever changing it.

  3. #3
    My Neighbors Hate Me!!! lvbroham1's Avatar
    Join Date
    Jun 2006
    Location
    Ft. Lee, Virginia
    Posts
    374

    Artic White
    2001 Chevy Camaro SS

    Oh yea! forgot about your other question. energy suspension sells a kit for the whole car that's not too pricey.

  4. #4
    Giant Dicks Car Club Zapper2003's Avatar
    Join Date
    Nov 2006
    Location
    Millerton, PA
    Posts
    5,144

    2005 Ram
    1978 Firebird

    I bought the car a little over a year ago with 100k on it, so I know for a fact I've never replaced it I'll look into it though. Who makes a good mount?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. los of acceleration on a hard pull.
    By trnsman in forum Firebird / WS6
    Replies: 5
    Last Post: 09-09-2015, 08:01 PM
  2. Help: Burning oil under hard acceleration/deceleration
    By Blakeman in forum General Help
    Replies: 6
    Last Post: 06-28-2009, 03:45 PM
  3. Help: Acceleration issue and unrelated/related noise.
    By Speed Bump in forum General Help
    Replies: 8
    Last Post: 06-18-2009, 12:27 AM
  4. cracking noise on hard acceleration
    By zetwentyeight in forum Automatic Transmission
    Replies: 1
    Last Post: 12-18-2006, 02:18 PM
  5. Engine Noise Upon Acceleration?
    By thelastz28 in forum Camaro / SS
    Replies: 7
    Last Post: 02-24-2006, 09:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •