Results 1 to 9 of 9

No Cruise Control

This is a discussion on No Cruise Control within the General Help forums, part of the LSx Technical Help Section category; Anyone have any issues with the cruise control? I really have not dug into it, but looking to see if ...

  1. #1
    Junior Member oharam's Avatar
    Join Date
    Feb 2011
    Location
    Tampa Bay
    Posts
    83

    Black
    1999 Z-28 LS1

    No Cruise Control

    Anyone have any issues with the cruise control? I really have not dug into it, but looking to see if anyone else has had issues, and what the fix was. While I am at it, my horn is also non functional. All the fuses under the hood are fine, and the interior fuse panel looks good, but have not pulled each fuse out.

    thanks!
    1999 Camaro Z-28 LS1 M6
    Cam, Heads, Exhaust

  2. #2
    dbl clutch'n like i shld WICKEDLS1's Avatar
    Join Date
    Aug 2010
    Location
    Oklahoma City, Oklahoma
    Posts
    1,807

    sebring silver
    Y2K SS CAMARO

    sub'd my cruise hasnt worked in like 4 months now FML

  3. #3
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,509

    Navy Blue Metallic
    98 T/A w/a little mods...

    Do both of you have M6's?

    You need to check this. You will have 2 switches that are on both the clutch and brake pedals. These are the #1 thing that goes bad and knocks out your cruise control.

    Look at the pic you will see the switches I'm talking about.



    They are about $18 from gmpartsdirect.com, about $35 at local parts store. It takes about 30 mins to fix. If you have the same problem I had The switch was good, but the plastic on the switch that holds it in place broke. I took a zip tie and secured it to where it held the button in all the time. Only do this for the clutch. You also have a similar switch for the break pedal, do not do the zip tie fix on the break pedal. In this case I would get the part because you will want the cruise to turn off if you hit the breaks.

  4. #4
    dbl clutch'n like i shld WICKEDLS1's Avatar
    Join Date
    Aug 2010
    Location
    Oklahoma City, Oklahoma
    Posts
    1,807

    sebring silver
    Y2K SS CAMARO

    mines an a4 so will i just have the switch on the brakes

  5. #5
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,509

    Navy Blue Metallic
    98 T/A w/a little mods...

    correct. these things get brittle over time and break.

  6. #6
    Member
    Join Date
    Aug 2005
    Location
    Pocono Mtns, PA
    Age
    62
    Posts
    103

    White
    '02 Camaro SS

    Quote Originally Posted by oharam View Post
    Anyone have any issues with the cruise control? I really have not dug into it, but looking to see if anyone else has had issues, and what the fix was. While I am at it, my horn is also non functional. All the fuses under the hood are fine, and the interior fuse panel looks good, but have not pulled each fuse out.

    thanks!
    If both are operated from the steering wheel possible cause is the clock spring in the column.

  7. #7
    Junior Member oharam's Avatar
    Join Date
    Feb 2011
    Location
    Tampa Bay
    Posts
    83

    Black
    1999 Z-28 LS1

    Mine was originally an automatic from factory, and the guy I just bought it from had a z28 camaro 6 speed installed in it. Looking at the picture, it would make sense, that they may not have hooked up the cruise control when they did the tranny swap. On a side note, I am EXTREMELY impressed that I just ran it almost out of fuel, filled it up and calculated the fuel mileage, and was at 18 for aroud town driving. I wish I would have bought one ALONG time ago!

    Thanks for the info on the cruise control issue, and will look into it when the weather breaks tomorrow.

  8. #8
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,509

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by oharam View Post
    Mine was originally an automatic from factory, and the guy I just bought it from had a z28 camaro 6 speed installed in it. Looking at the picture, it would make sense, that they may not have hooked up the cruise control when they did the tranny swap. On a side note, I am EXTREMELY impressed that I just ran it almost out of fuel, filled it up and calculated the fuel mileage, and was at 18 for aroud town driving. I wish I would have bought one ALONG time ago!

    Thanks for the info on the cruise control issue, and will look into it when the weather breaks tomorrow.
    Even if they didn't put the switch there the wiring will be there to hook it up.

  9. #9
    Junior Member
    Join Date
    Jan 2011
    Location
    Eureka
    Posts
    34

    White
    2003 GMC Duramax

    Quote Originally Posted by oharam View Post
    Mine was originally an automatic from factory, and the guy I just bought it from had a z28 camaro 6 speed installed in it. Looking at the picture, it would make sense, that they may not have hooked up the cruise control when they did the tranny swap. On a side note, I am EXTREMELY impressed that I just ran it almost out of fuel, filled it up and calculated the fuel mileage, and was at 18 for aroud town driving. I wish I would have bought one ALONG time ago!

    Thanks for the info on the cruise control issue, and will look into it when the weather breaks tomorrow.
    Another option and an easy way to find a problem is, when I had my Camaro, I couldn't get cruise to work either because my clutch wouldn't come up all the way. Not saying yours is like that but maybe try to make sure the clutch is all the way up by pulling it back with your toes. It was my problem, may not be yours though.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: cruise control
    By a70oldscutlass in forum Firebird / WS6
    Replies: 5
    Last Post: 07-08-2015, 03:41 AM
  2. no cruise control
    By 1MileCrash in forum Stereo and Electronics
    Replies: 5
    Last Post: 07-11-2013, 11:54 AM
  3. Cruise Control?
    By FutureWS6 in forum Firebird / WS6
    Replies: 17
    Last Post: 01-13-2011, 09:55 AM
  4. cruise control with traction control
    By basballny2 in forum General Help
    Replies: 12
    Last Post: 06-17-2010, 12:57 AM
  5. Cruise Control on New TB
    By navyLS1 in forum General Help
    Replies: 1
    Last Post: 01-01-2010, 01:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •