Results 1 to 3 of 3

No Brights....

This is a discussion on No Brights.... within the General Help forums, part of the LSx Technical Help Section category; Hey, I've got a 99 Z28 and I can no longer use my brights. When I first got the car ...

  1. #1
    back 'n better than ever Kjz99z28's Avatar
    Join Date
    Aug 2005
    Location
    Norman, Oklahoma
    Age
    28
    Posts
    1,759

    White/Black
    1999 Z28

    Angry No Brights....

    Hey, I've got a 99 Z28 and I can no longer use my brights. When I first got the car in March, the lights all worked fine. Then, the switch to turn my lights to brights started not working so well. Sometimes it wouldn't grab, and you had to move it just the right way to turn them on. Then, it wouldn't grab at all and I had to just hold it back to keep the brights on. Now, I can't get them to come on at all. It's not bulbs or anything, just the switch. What do I need to do, fix or replace? Thanks.

  2. #2
    back 'n better than ever Kjz99z28's Avatar
    Join Date
    Aug 2005
    Location
    Norman, Oklahoma
    Age
    28
    Posts
    1,759

    White/Black
    1999 Z28

    Anybody?

  3. #3
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    37
    Posts
    1,346

    black
    2002 WS6

    You will have to replace the switch. With the air bag you'd best go to a shop to avoid any "accidents".

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •