Page 1 of 2 12 LastLast
Results 1 to 20 of 25

New ignition switch

This is a discussion on New ignition switch within the General Help forums, part of the LSx Technical Help Section category; Hello everyone. My car had replaced the ignition switch, But the security light is on. How can I reset it? ...

  1. #1
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    New ignition switch

    Hello everyone.
    My car had replaced the ignition switch,
    But the security light is on. How can I reset it?
    The mechanic said there's nothing to do.
    But I'm not happy with that answer.
    Any ideas? The car starts and everithing.
    Thanks in advance
    00 ss blk m6 " STOCK" strano springs, slp bilstein shocks, adj LCA, adj panhard bar, relocation brackets, 2 point SFCs welded,OEM zo6 rims black, magnaflow exhaust, CME exhaust,E/cutout, slp grille, custom front plate mount, HIDs, whistler mod, side moldings delete, slp air lid, ported and polished TB, strut tower brace, 3.73s gears, and some other parts to list!
    next to come,4.10s,ls7 clutch, ms3 or 228r cam, ported 243s, ls6 intake, ls6 oil pump. ls2 timing chain, longtube headers no cats, with a tune..
    02 tahoe Z71 blacked out
    00 jeep grand Cherokee limited on 22s.
    07 Dodge Charger R/T Inferno Red, Sold
    98 z28 red m6 sold
    07 zx6r ninja flat/black sold
    08 zx6r ninja sold

  2. #2
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    No one ?

  3. #3
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    replaced mine.....at the dealer.......no problems here

  4. #4
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    I don't know what happened with mine then.
    I hate to see that light on all the time.

    How much did it cost you the new switch?

  5. #5
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    500$ .....parts and labor

  6. #6
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    Mine was $120 parts and labor.

    1 month ago. I paid $380 to fix the VATS problem. And the guy said it was the switch. And I took it to him this time said. It's the ignition switch again.

    I guess the first time he never changed it.
    He said he replaced something else but I dnt belive him.

    What can I do to turn that light off?

  7. #7
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    The ignition switch has NOTHING to do with VATS. The ignition cylinder does...

  8. #8
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    yep........replaced my ignition cylinder

  9. #9
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    I thought the ignition switch and the ignition cylinder. Was the same thing.

    So I guess the the first time he replaced the cylinder.

    But how can I turn that light off?

  10. #10
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    was the light off before they changed the switch? is the car working okay?

  11. #11
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    The light was off, but few days ago I was having problems with the vats, so the guy said the ignition switch cables were cut. So he changed the switch. The car start up right after that.
    But the light stayed on. It starts and everithing is normal. Is just light is there. Shen the switch is open.

  12. #12
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    I wonder if he override it. It will be interesting to find out. Well like cutlass said vats has nothing to do with the ignition switch. I will say you need to replace the ignition cylinder. Have you use the resistors to override VATS?

  13. #13
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    Like 2 months ago. I had a vats issue. I'm sure it was that.
    So he said he replaced something on the steering column. I guess it was the cylinder.

    But few days ago. I had the same problem. And he comes up is the switch. But of u guys say it has nothing to do with the switch. So I wonder what the hell he did.
    But at the end everithing came up to $500 and the light is there.

    I didn't did the by pass cus I wanted to do it right.
    But I'm gonna check if he did the by pass. On the vats.

  14. #14
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    so you don't know if the resistor trick is been used? you can check if the cylinder is good by unpluging the orange cord(it has 2 white wires) that comes from the ignition cylinder. If the car won't start then the cylinder is good. If the car starts then something was altered. Check that 1st. If you don't know where is it you can check the VATS write up.

    How to Bypass your VATS

    If it works the right way maybe you are having issues with the BCM.
    Last edited by JayTA98; 02-18-2011 at 03:54 PM.

  15. #15
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    Ok thanks I will try that.

    I been having issues with the BCM. sometimes the windows and radio stop working.
    I hit the corner on the passenger side and they work again.

    I asked the mechanic if the bcm was related to the vats. He said no.
    Now I see what kind of mechanic he is.

  16. #16
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by 98maro View Post
    Ok thanks I will try that.

    I been having issues with the BCM. sometimes the windows and radio stop working.
    I hit the corner on the passenger side and they work again.

    I asked the mechanic if the bcm was related to the vats. He said no.
    Now I see what kind of mechanic he is.
    If I'm not mistaking the VATS is in the BCM. I'm almost sure of it because I asked Cutlass about it. Have you try to resolder the pins inside the BCM that cause issues? Read this write up:
    http://www.ls1.com/forums/showthread...light=resolder

    I'm not saying that it will fix the issue but you can try. I was having issues with my power locks and I resolder the pins. The problem never happened again.

  17. #17
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    What is getting me is that he said the ignition switch wires were cut. The car was working fine before all this so how did they got cut? I mean the ignition switch can go bad, i had that happen to me in previous cars but the wires don't get cut...

  18. #18
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    Quote Originally Posted by JayTA98 View Post
    What is getting me is that he said the ignition switch wires were cut. The car was working fine before all this so how did they got cut? I mean the ignition switch can go bad, i had that happen to me in previous cars but the wires don't get cut...
    The car was working fine. But the day before I took it the shop, it was acting funny. I only start on the second try to start. On the first one. Nothing happend. Lights were on normal but It didn't start. On the second try to start. That's when the car started. But the day I took it to the shop. It wasn't cranking at all.
    And the "security" light was on. So I went with him for warranty on the vats problem it had before. All he said it was the ignition switch.
    So he replaced it. And now the light is on.
    But the car starts and everything.

  19. #19
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    Quote Originally Posted by JayTA98 View Post
    If I'm not mistaking the VATS is in the BCM. I'm almost sure of it because I asked Cutlass about it. Have you try to resolder the pins inside the BCM that cause issues? Read this write up:
    http://www.ls1.com/forums/showthread...light=resolder

    I'm not saying that it will fix the issue but you can try. I was having issues with my power locks and I resolder the pins. The problem never happened again.
    I heard bout this problm with the bcm. And now I'm gonna have to do something bout it.
    Because the problem on the radio and windows is more comun lately.

    Is that something hard to do?
    What do I need to weld it?

  20. #20
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by 98maro View Post
    I heard bout this problm with the bcm. And now I'm gonna have to do something bout it.
    Because the problem on the radio and windows is more comun lately.

    Is that something hard to do?
    What do I need to weld it?
    If you read the write up it pretty much tell you where is it, how to get it out and where to resolder. I used a pencil solder from radio shack and resin core solder. It shouldn't cost more than $20 bucks.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is this the Ignition Switch?
    By mike171562 in forum General Help
    Replies: 4
    Last Post: 08-16-2012, 03:16 PM
  2. Help: ignition switch
    By txoutlaw69 in forum Firebird / WS6
    Replies: 1
    Last Post: 08-15-2012, 03:51 AM
  3. Need Help On Ignition Switch On 98 Gmc
    By Street Fighter in forum General Help
    Replies: 1
    Last Post: 11-02-2007, 09:36 AM
  4. Ignition Switch
    By silverado777 in forum GM Trucks
    Replies: 0
    Last Post: 10-30-2007, 09:36 PM
  5. ignition switch
    By dczfirst in forum General Help
    Replies: 4
    Last Post: 09-12-2006, 07:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •