Results 1 to 5 of 5

Need help on problem with 1994 Z28.

This is a discussion on Need help on problem with 1994 Z28. within the General Help forums, part of the LSx Technical Help Section category; i have a 94 z28 m6 with 70k on it. it has an issue. when you are accelerating hard, it ...

  1. #1
    Junior Member
    Join Date
    Aug 2005
    Location
    Arkansas
    Age
    31
    Posts
    41

    Red
    2000 Camaro

    Need help on problem with 1994 Z28.

    i have a 94 z28 m6 with 70k on it. it has an issue. when you are accelerating hard, it will pull strong to about 5k, then it starts missing. it is hard to describe, almost a sputtering, it still pulls, but there is a noticeable drop in acceleration. the more you do this (the more it warms up?), the worse it gets, ie, it will atart doing it at 4.5k, 4k, etc. now, you can rev it up as much as you want, as long as you do it somewhat slowly.

    any ideas? i'm thinking fuel pump maybe?

    i have already replaced the optispark and plugs and wires.
    Edit/Delete Message

  2. #2
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,123
    Retired Outlaw Sum Bitch

    Fuel Filter
    Injectors
    Valve Springs
    Coil
    Rent or buy a fuel pressure guage.....hook it up....read your fp from that....should be around 45'ish lbs...I run 62lbs but I got a beast for a pump Eliminate the fuel issue...change the fuel filter....after you have changed the ff and verified fp....and they are good...if it still does it....go after the injectors....I'd have a injector cleaning service done on them first....after that....if all the fuel issues are not the culprit....I'd go after electrical...coils do this....when they get warm...they shit the bed earlier and quicker.....diagnoses is a matter of elimination.....Fuel pump would shit the bed regardless of engine temps ( I'm thinking to myself and typing here )....Slap in a new fuel filter and a new coil....try those first....
    It could also be a clogged catalytic convertor....come to think of it....From the symptoms you described it sounds exactly like a clogged convertor.....have a decent muffler shop check it out...
    This is my signature. It is mine. Nobody else has one like it.

  3. #3
    Junior Member
    Join Date
    Aug 2005
    Location
    Arkansas
    Age
    31
    Posts
    41

    Red
    2000 Camaro

    Quote Originally Posted by Sarge View Post
    Fuel Filter
    Injectors
    Valve Springs
    Coil
    Rent or buy a fuel pressure guage.....hook it up....read your fp from that....should be around 45'ish lbs...I run 62lbs but I got a beast for a pump Eliminate the fuel issue...change the fuel filter....after you have changed the ff and verified fp....and they are good...if it still does it....go after the injectors....I'd have a injector cleaning service done on them first....after that....if all the fuel issues are not the culprit....I'd go after electrical...coils do this....when they get warm...they shit the bed earlier and quicker.....diagnoses is a matter of elimination.....Fuel pump would shit the bed regardless of engine temps ( I'm thinking to myself and typing here )....Slap in a new fuel filter and a new coil....try those first....
    It could also be a clogged catalytic convertor....come to think of it....From the symptoms you described it sounds exactly like a clogged convertor.....have a decent muffler shop check it out...
    hmmm, i've heard that before. is there any disadvantage to me just removing the cat and welding pipe in there? crappy sound, performance, sensors screwing up?

    thanks for the help.

  4. #4
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,123
    Retired Outlaw Sum Bitch

    You'll need some SIMMS I think ( not sure on that year of car)...to fool your ECM or it will throw a SES light....

  5. #5
    Pathelogical Liar BlackLT1Z28's Avatar
    Join Date
    Aug 2006
    Location
    Missouri
    Age
    29
    Posts
    1,476

    Black
    94 Camaro Z28

    No, you don't need sims on a 94. You just need a tune to zap the SES light.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •