Results 1 to 3 of 3

Need Help Please - Car Only Only Idle

This is a discussion on Need Help Please - Car Only Only Idle within the General Help forums, part of the LSx Technical Help Section category; Hi - I have a 2001 LS1 with traction/cruise. The pedal cable and criuse cable go a device with a ...

  1. #1
    terremoto
    Guest

    Need Help Please - Car Only Only Idle

    Hi - I have a 2001 LS1 with traction/cruise. The pedal cable and criuse cable go a device with a black plastic top behind the battery. The cable to the throttle body goes from there. The car will only idle. The cable moves going to the black thing but not from there. I have it out but am not sure how to test it. The dealer will want $$$ for it and it will take a week to get here. Any ideas would be appreciated. Thanks

  2. #2
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    check the throttle cable on the passenger side of the throttle body...it might have slipped off or became disconnected completely....clean the TB while your there to make sure the throttle plate isn't stuck...good luck

  3. #3
    terremoto
    Guest
    Thanks. For some reason the cable was stuck in its guide. Need a new cable.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Members who have read this thread: 0

There are no members to list at the moment.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •