Results 1 to 6 of 6

Need help!!!! Please

This is a discussion on Need help!!!! Please within the General Help forums, part of the LSx Technical Help Section category; My car runs rough from time to time in idle when in drive or park. No check engine light Ever! ...

  1. #1
    -S-howtime -S-teele (SS) showtimesteele99SS's Avatar
    Join Date
    Mar 2007
    Location
    Haddon Heights NJ
    Age
    31
    Posts
    219

    Black
    1999 SS Camaro #4,510

    Need help!!!! Please

    My car runs rough from time to time in idle when in drive or park. No check engine light Ever! other then that the car runs great . When i start to accelerate its a little choppy especially after the car has been running for a good bit and when its either hot or humid. then after i get past 12 1300 rpms then it's back to normal. I think it might be an EGR problem but im not sure at all. Can someone help?

    My Car
    1999 Camaro SS LS-1 346ci ALL STOCK
    67,000 Miles

    I purchased it with 60,500 miles and have owned it for exactly 2 years.

    Thanks in advance!!!

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    Start with the EGR and clean the maf, that maf seems to be a major source for a lot of little and sometime big issues cause it gets dirty.

    Aslo to cover a the bases, check the tranny fluid level and the PCV line for breaks.

  3. #3
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Has it ever had a tuneup? Might want to change the plugs, wires, and fuel filter also.

  4. #4
    -S-howtime -S-teele (SS) showtimesteele99SS's Avatar
    Join Date
    Mar 2007
    Location
    Haddon Heights NJ
    Age
    31
    Posts
    219

    Black
    1999 SS Camaro #4,510

    to be honest i have not had a tune up i have only driven it about 7,000 miles and i am the 2nd owner

  5. #5
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Well it does have 70000 miles on it and the wires are now 10 years old. I would replace them regardless as preventative maintenence.

  6. #6
    -S-howtime -S-teele (SS) showtimesteele99SS's Avatar
    Join Date
    Mar 2007
    Location
    Haddon Heights NJ
    Age
    31
    Posts
    219

    Black
    1999 SS Camaro #4,510

    your right

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •