Results 1 to 6 of 6

Need help with phantom PS leak

This is a discussion on Need help with phantom PS leak within the General Help forums, part of the LSx Technical Help Section category; ok so I posted this up on LS1tech and no one had a clue.. so PS finally fried the alternator, ...

  1. #1
    Member QKSLVR99's Avatar
    Join Date
    Jan 2006
    Location
    Abilene, TX
    Age
    37
    Posts
    278

    Pewter
    1999 Trans Am

    Need help with phantom PS leak

    ok so I posted this up on LS1tech and no one had a clue..

    so PS finally fried the alternator, replaced both only to have the PS that i just put in leak...

    Got a new PS with the res, installed it and it still leaks.

    Jacked the car up let it fully warm up and turn the wheel no leak

    only when the wheels are turned completely left or right does it leak

    or spray i should say. As soon as you let pressure off the steering wheel it stops.

    Have looked at both lines and it doesn't seem to be a line. It looks as though is sprays from the center rear of the pump, where it is bolted to the bracket that holds it on the head.

    can see the back top were the res sits (with a mirror) no leaks from there

    completely stumped

    planning on taking it to a shop tomorrow if I can't figure it out and already got a new pump w/ res on the way just incase...

    If ANYONES got an idea please post

    red arrows indicated where the leak appears to be coming from (shot from the ground up)

  2. #2
    Member Goldcuffs's Avatar
    Join Date
    Aug 2008
    Location
    Florida
    Posts
    411

    Silver
    2000 Trans Am

    Well.....I would have to say it would be the pump from the picture. There are only 4 components to the whole P/S system. P/S pump, P/S rack and pinion, P/S pressure hose, and P/S return hose. If you don't know where it's coming from rule out the components you know are not leaking.

  3. #3
    Member QKSLVR99's Avatar
    Join Date
    Jan 2006
    Location
    Abilene, TX
    Age
    37
    Posts
    278

    Pewter
    1999 Trans Am

    I know it is not the rack or the return hose, so it is either the high pressure hose spraying on the bottom of the PS pump or the pump again for the third time... I have installed 2 brand new pumps in the last three weeks

  4. #4
    We'll be back... GatorSS's Avatar
    Join Date
    Aug 2005
    Location
    THE SWAMP
    Posts
    1,446

    Light Pewter Metallic
    2000 Camaro SS M6

    It leaks just barely enough to get noticed, but more than enough to be irritated.

  5. #5
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Start looking at replacing line's. Might be cheaper than taking it somehwere.

  6. #6
    Member QKSLVR99's Avatar
    Join Date
    Jan 2006
    Location
    Abilene, TX
    Age
    37
    Posts
    278

    Pewter
    1999 Trans Am

    Ok so it's fixed ..


    I tried that UV dye to pin point the leak...

    ended up being the pressure line. Tiny ass hole that was only visable when under pressure. directly below the PS pump and above the alternator. it was spraying up at the pump hitting it and then spraying down from the pump is ok now though

    except for the sqeaking dripped a little PS fluid on the pulley and belt... going to get new belt tomorrow and clean all the pulleys hopfully that will take care of it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The Phantom Tax That Made The Deficit Look Better
    By Ed Blown Vert in forum Political / Debate Forum
    Replies: 0
    Last Post: 01-03-2013, 12:30 PM
  2. Question: I'm baffled. Another phantom knocking
    By Redrokit8 in forum Firebird / WS6
    Replies: 20
    Last Post: 07-21-2012, 01:55 PM
  3. New from MA - Phantom SS (FXGS)
    By Rob D in forum New Member Introductions
    Replies: 5
    Last Post: 07-10-2011, 10:06 AM
  4. ttop leak, hatch leak, and window motor problems
    By ATCharming in forum General Help
    Replies: 41
    Last Post: 07-23-2007, 03:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •