Results 1 to 15 of 15

Need help with lean codes bank 1&2

This is a discussion on Need help with lean codes bank 1&2 within the General Help forums, part of the LSx Technical Help Section category; My 98z28 Is throwing lean codes for bank 1 and 2 I have Mac mids no cats and a bbk ...

  1. #1
    Member Ieatstangs's Avatar
    Join Date
    Feb 2008
    Location
    Bay Area :(
    Posts
    225

    blue
    99z28 a4

    Need help with lean codes bank 1&2

    My 98z28
    Is throwing lean codes for bank 1 and 2

    I have Mac mids no cats and a bbk intake

    Could these code be from the absence of the cats or do I need to look elsewhere

    During the install I demolished my hose from the back of intake to the Pcv valve I replaced it with what I could. Find

    The fuel filter is less than 6 months old
    01 black SS with a few slp options

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Stock MAF? Did you replace the O2 senders? Any exhaust or vacuum leaks? Have you checked you fuel pressure?

  3. #3
    Member Ieatstangs's Avatar
    Join Date
    Feb 2008
    Location
    Bay Area :(
    Posts
    225

    blue
    99z28 a4

    Yeah the maf is stock no exhaust or vacuum leaks that I found so far no I havent check fuel pressure im kinda scared to

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    The O2 senders are tight in the headers? Any other codes being set?

    Unless the engine is ingesting unmetered air, ie. a vacuum leak, or there is air leaking into the exhaust system above the O2 senders, then the problem may very well be fuel pressure. It's easy to check and most chain parts stores now have a "rent-a-tool" service if you do not want to buy a gauge. You should have 58 p.s.i. at the rail.

  5. #5
    Member Ieatstangs's Avatar
    Join Date
    Feb 2008
    Location
    Bay Area :(
    Posts
    225

    blue
    99z28 a4

    Thanks I kno how to do it Im jus scared of the results lol

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    That I understand. Good luck!

  7. #7
    Member Ieatstangs's Avatar
    Join Date
    Feb 2008
    Location
    Bay Area :(
    Posts
    225

    blue
    99z28 a4

    I jus checked for vacuum leaks wit some carb spray but no drop in idle anywhere my air lip wasn't closing properly fixed that I'm gonna clear the codes n go enjoy a day at the beach n deal wit this tonight thanks for the advise

  8. #8
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    The PCV system, especially the rubber fitting at the throttle body, is usually a prime suspect for a vacuum leak.

  9. #9
    Member Ieatstangs's Avatar
    Join Date
    Feb 2008
    Location
    Bay Area :(
    Posts
    225

    blue
    99z28 a4

    If it was leaking and I sprayed it with carb cleaner the idle would drop ?

    I hope the intake isn't cracked but when I sprayed around it no change in idle

  10. #10
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I doubt the intake is cracked. Usually it is a hose, exhaust gasket, or a crack or leak in the exhaust tubing. The PCV hose runs behind the engine and over to the back of the driver side rocker cover. A couple of members have had them fail in the back where the problem can not be easily discovered. Did you reset the code and drive the car?

  11. #11
    Member Ieatstangs's Avatar
    Join Date
    Feb 2008
    Location
    Bay Area :(
    Posts
    225

    blue
    99z28 a4

    Yeah I reset the codes they came back .... Do u mean the hose from the brake booster ? I tried spraying in the back the hose was wet and eventually dried ....

  12. #12
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    The PCV hose assembly looks like this (left side goes to throttle body, right side to vent hole on driver side rocker cover):


  13. #13
    Member Ieatstangs's Avatar
    Join Date
    Feb 2008
    Location
    Bay Area :(
    Posts
    225

    blue
    99z28 a4

    How much do these run in the event that this is my issue

  14. #14
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    You don't want to know... around $150 if I recall. Better to make your own as you really can't see any of it.

  15. #15
    Member Ieatstangs's Avatar
    Join Date
    Feb 2008
    Location
    Bay Area :(
    Posts
    225

    blue
    99z28 a4

    $150 isn't horrible if it'll make my car run better and I have a buddy at gm who gives me wholesale price

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The Never Ending Lean Bank 2 Saga........
    By jfl330 in forum General Help
    Replies: 73
    Last Post: 08-14-2013, 09:24 AM
  2. P0174 Lean Bank 2 Code (forever...........)
    By jfl330 in forum General Help
    Replies: 22
    Last Post: 11-20-2012, 05:49 AM
  3. Help: Lean Air bank 1 and 2 codes (P0171, P0151)
    By MeanGreen98 in forum General Help
    Replies: 36
    Last Post: 01-24-2012, 05:17 AM
  4. Throwing codes for bank 1 and 2 being lean.
    By !!!FAST!!! in forum External Engine
    Replies: 2
    Last Post: 08-14-2010, 07:06 AM
  5. Problem with one cylinder bank going lean.
    By Sam-SS in forum Computer & Tuning
    Replies: 4
    Last Post: 11-01-2007, 07:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •