Results 1 to 5 of 5

need help diagnosing the cause of this sound

This is a discussion on need help diagnosing the cause of this sound within the General Help forums, part of the LSx Technical Help Section category; Been trying to fix my car that has been broken down for a while and need some help figuring what ...

  1. #1
    Junior Member ZeroXploit's Avatar
    Join Date
    Mar 2015
    Location
    Dallas
    Posts
    3

    red
    1999 camaro 3.8L

    Smile need help diagnosing the cause of this sound




    Been trying to fix my car that has been broken down for a while and need some help figuring what could be causing this sound.
    1999 3.8 L V6
    Also has a bad oil leak.

  2. #2
    Member RONS98TA's Avatar
    Join Date
    Jan 2009
    Location
    MARYLAND
    Age
    44
    Posts
    803

    BLACK
    1998 PONTIAC TA

    Rod knock? Spark plug loose in the head?
    1998 Pontiac TA, stock heads, FAST 90, FAST 90 TB, FLP LT, off road y-pipe with cat delete, flow master muffler, comp cams 54-457-11 223/231-610/617-112 LSA, Pro charger D1SC with FMIC @ 8psi, FROST tune, VIG 3200 stall, built 4l60e, snow meth kit, MOSER 12 bolt 373 gears, Derale 13900 trans cooler.

  3. #3
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    One sound, sounds like a Rap video noise and the other sounds like you have a spun rod. Like the rod has no bearing left.



    Drain oil and cut the oil filter open. Look for bearing material or metal flakes.

  4. #4
    Junior Member chuckstop00's Avatar
    Join Date
    May 2007
    Location
    Milford, MA
    Posts
    68

    Black
    2000 Firebird Formula

    Wow, that's nasty. If it were my car, I would take a look all around just to rule out any moving external parts, alternator, a/c, power steering, hitting on something.
    Then I would try to narrow down if it's on top or bottom of engine, on top, I would take off valve covers and look for broke/bent pushrods/rocker arms. Down below,
    would look for new motor :P

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    That sounds incredibly bad. Do you have oil pressure?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help diagnosing noise
    By ZeroXploit in forum General Help
    Replies: 1
    Last Post: 03-27-2015, 06:43 PM
  2. Need help diagnosing my LT1 (San Diego)
    By Omega Supmeme in forum Western Members
    Replies: 5
    Last Post: 05-30-2011, 05:31 PM
  3. Need Help Diagnosing a code.. Please....
    By rcorte3001 in forum General Help
    Replies: 5
    Last Post: 03-17-2011, 07:47 PM
  4. Need Help Diagnosing Problem Please
    By breakking in forum General Help
    Replies: 10
    Last Post: 02-21-2008, 03:44 PM
  5. help diagnosing ses?
    By gary26154 in forum General Help
    Replies: 1
    Last Post: 04-04-2006, 03:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •