Results 1 to 14 of 14

Need help with the check engine light.

This is a discussion on Need help with the check engine light. within the General Help forums, part of the LSx Technical Help Section category; I bought my 99 Z about 8 months ago, it has some stuff done to it, but I'm not too ...

  1. #1
    nothing to prove LOCKDOWN's Avatar
    Join Date
    Mar 2006
    Location
    Ohio - West of Cleveland
    Age
    32
    Posts
    131

    Light Metallic Pewter
    1999 Camaro Z28

    Need help with the check engine light.

    I bought my 99 Z about 8 months ago, it has some stuff done to it, but I'm not too sure exactly what has been done. The guy I bought it from isn't the one who did the mods, and he doesn't know what all it has in it either. Ever since I got the car everything runs near perfect, but the check engine light has always been on, so I took it to auto zone and had them read the code from it. There were actually several codes but as far as I can remember they were all the O2 sensors. The guy erased them, the light went away for about five minutes and then came back on, so I don't know what to think. I know that my car has had a tune put on it since all the mods were installed. So my question is, is there anything I can do to get the check engine light off? Or do you guys suggest not worrying about it or what? Thanks in advance for any help.

  2. #2
    Member mikeaford's Avatar
    Join Date
    Nov 2005
    Location
    Fredericksburg Va
    Age
    41
    Posts
    151

    Pewter
    01 Trans Am

    I would say if your codes where all for the O2 sensors either replace them or get o2 simultators to put in there. Just my 2 cents, I bought the Bosch o2 sensors didn't last me 10K miles - pretty weak in my opinion stock have been good to me I average about 65-75K miles for them. I do have 1 Bosch still in there which has seemed to last about 30K but I'm waiting for that one to go out... Good luck

  3. #3
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    go back to az and find out what the codes are and post them so we can help you further.
    Take a look at the exhaust manifolds, are they manifolds "rusty color with cats connected to them" or are the longtubes"shiney metal witout cats connected to them".
    Just curious
    also if they are headers then take a look at how many 02 sensors you have and if the wires are spliced together or he used a wire harness extension.
    with cats= 4 sensors
    with out cats=2 sensors
    J
    2001 SS, Its not the car its the Driver that matters....

  4. #4
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    post the codes

  5. #5
    nothing to prove LOCKDOWN's Avatar
    Join Date
    Mar 2006
    Location
    Ohio - West of Cleveland
    Age
    32
    Posts
    131

    Light Metallic Pewter
    1999 Camaro Z28

    Ok, I took it to the guy at Auto zone, and the guy said there were four codes on it. He said that it was an "air system valve malfunction". The Jack didn't sound like he really knew what he was talking about, he was like "that's pretty much it" he said it showed up four times.... If needed tomorrow I will hook my Diablosport Predator programmer up to it, and get the error codes myself. It's gonna take me a little bit to find it though. Any help is appreciated.

  6. #6
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    You've got a Predator and going to AZ to get your codes read? Shame on you! J/K. Post the code, sounds like it might just be P1415 or P1416.

  7. #7
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    The best way to get something done is too do it yourself, I'm a firm beleiver in that, Just post your codes and someone will hook u up
    J

  8. #8
    nothing to prove LOCKDOWN's Avatar
    Join Date
    Mar 2006
    Location
    Ohio - West of Cleveland
    Age
    32
    Posts
    131

    Light Metallic Pewter
    1999 Camaro Z28

    Alright... I knew I was gonna get it for going to AZ when I had my own. lol. I'm always paranoid to use it cuz of all the warnings on no static electricity, don't close your doors while it's on, don't get out of the car while it's on or you will completely F*** your car up. Anyway I got the codes off and there were only three, the guy didn't know what he was talking about as I suspected.

    P0412 Air system switching valve A Circuit, Malfunction

    P0418 Air system Relay A circuit malfunction

    P1637 Generator-L-Terminal Circuit

  9. #9
    Member keliente's Avatar
    Join Date
    Aug 2005
    Location
    Charlotte, NC
    Age
    31
    Posts
    723
    99 Firebird Formula

    You won't damage the computer by pulling codes off the car. On the other hand if you were flashing it and happened to open a door/hit the brake pedal/etc the voltage difference may do some damage.

  10. #10
    nothing to prove LOCKDOWN's Avatar
    Join Date
    Mar 2006
    Location
    Ohio - West of Cleveland
    Age
    32
    Posts
    131

    Light Metallic Pewter
    1999 Camaro Z28

    Alright. I know nothing, and I mean nothing about the programmer that I have. The guy I bought it from gave it to me with my baby.

  11. #11
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    Check to make sure a prior owner didn't take the A.I.R. system out of your car...it's a very common thing to do in states that aren't strict on emissions...like Ohio If it's gone...you'll have to have the codes tuned out, not just deleted...there's a difference.

    You should have a little air pump under your driverside headlight, 2 black check valves kind of over the intake manifold(they're identical, you'll know it when you see them) attached to some metal tubing that goes to the exhaust manifolds.

  12. #12
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    For the AIR codes make sure it's there - if it is, check to make sure the AIR PUMP fuse isn't blown. For 1637 check the wiring/connections to the alternator - is the volt gauge acting funny?

  13. #13
    nothing to prove LOCKDOWN's Avatar
    Join Date
    Mar 2006
    Location
    Ohio - West of Cleveland
    Age
    32
    Posts
    131

    Light Metallic Pewter
    1999 Camaro Z28

    Quote Originally Posted by 2001NBMZ28
    For the AIR codes make sure it's there - if it is, check to make sure the AIR PUMP fuse isn't blown. For 1637 check the wiring/connections to the alternator - is the volt gauge acting funny?
    The volt gauge doesn't seem to be acting up, but my battery does keep dying on me. I'm going out right now to get a new one.

  14. #14
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Have them load test the battery to make sure...alternator could also be going out - see if they'll check both, lots of places do it free.

    Edit: FWIW I'm on my third battery at 23K, never threw a code.
    Last edited by 2001NBMZ28; 03-31-2006 at 12:09 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •