Page 2 of 2 FirstFirst 12
Results 21 to 26 of 26

need help asap!!!

This is a discussion on need help asap!!! within the General Help forums, part of the LSx Technical Help Section category; Mine didn't break. I was at a stoplight last year and my "SVS" light came on with the chime. Threw ...

  1. #21
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Mine didn't break. I was at a stoplight last year and my "SVS" light came on with the chime. Threw the Solus on it and got a code for low voltage. Ordered mine and got it the next day.

  2. #22
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    yea im not gonna complain too much about this....yes this sensor is 11 years old and has 122k on it, so it would need replaced eventually anyways...sucks i broke it trying to fix another problem(knock sensors) so if anything its a litle bit of preventative maintenance just in different areas

  3. #23
    Senior Member 00z28bubba's Avatar
    Join Date
    Dec 2007
    Location
    las vegas, nv
    Age
    29
    Posts
    1,390

    white
    2000 Z28

    Quote Originally Posted by SteveCZ28 View Post
    Click for full size
    Click for full size

    damn you guys are good....atleast it was this. and i have it figured out...i know this thing was still standing when i took the intake off the first time, and was standing when i put it back in, so my guess is i hit it somehow on the way back in and snapped her off...02z28bubba, im thinking u can have the junior whopper. haha

    and im with you spaz, only i was thinking something along the lines of a little capuchian monkey haha. that would be bad ass
    Click for full size
    i'll stick with the dbl cheeseburger lol. luckily the car was already set aside for repairs. nothing worse than a car going out of commission while driving back to back.

  4. #24
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    well i have been driving the camaro as a d.d here for the past 2 weeks, cuz my yukon was acting up (electrical issues resulted from a crappy remote starter install from last owner) but now that my yukon is up i can drive it while the camaro is down for the couple of days

  5. #25
    Member jb3golf's Avatar
    Join Date
    Jan 2007
    Location
    Zona
    Posts
    600

    Red
    1998 Camaro Z28 Conv. M6

    Good job bro I'm glad you found your issue. It's kinda funny though, your pictures bring flashbacks of when I broke my OSU!!! I think at least 50% of us on here have made this mistake at some point! Take care.....

  6. #26
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    well im just glad i got it figured out too...when i started it, and saw the high oil pressure, and my car was ALOT LOUDER than normal i was freaking out. i felt lie crying. i even went as far as pulling the gauge cluster out and putting it back in in hopes it would reset the gauge (me thinking randomly after hooking battery back up) so yea, now ill just have to watch this damn sensor getting the intake back in there now.....i did find out i can have an intake out in 5 minutes now, lol

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help asap
    By clg82 in forum Drivetrain
    Replies: 5
    Last Post: 08-03-2008, 12:22 AM
  2. ls1.com plz hlp me asap thx
    By DanWS6 in forum Almost Anything Goes
    Replies: 101
    Last Post: 04-14-2008, 10:10 PM
  3. Need Help Asap!!!
    By clg82 in forum Firebird / WS6
    Replies: 8
    Last Post: 08-04-2007, 09:57 AM
  4. Help Asap!!!
    By Ripper415 in forum External Engine
    Replies: 1
    Last Post: 08-13-2006, 06:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •