Results 1 to 12 of 12

Need Help With Alternator!!

This is a discussion on Need Help With Alternator!! within the General Help forums, part of the LSx Technical Help Section category; hey,i was driving my camaro and out of no where all my sensor lights went on and it started idling ...

  1. #1
    Junior Member camarossf650's Avatar
    Join Date
    Jun 2007
    Location
    South San Francisco
    Posts
    50

    White
    1998 Camaro Z28

    Need Help With Alternator!!

    hey,i was driving my camaro and out of no where all my sensor lights went on and it started idling low,and after that it just died,i dont know if it is my alternator,after i try to turn my car on and all my lights and stereo works,but it cranks like once and then the starter starts clicking and doesnt turn on,i jump start it and it works,i think its the alternator,i hope u guys give me some feedback,and also some tips on how to take the alterator off cause it looks kinda hard to take off,thanx

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Sounds like your alt took a poo on you. While your at it, you might wanna pick up a battery as well. Local parts stores, ie autozone will do a chargin system check, free of charge. just to confirm.
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    down with the lot lizards blackhawk01's Avatar
    Join Date
    Dec 2006
    Location
    Pensacola
    Age
    28
    Posts
    1,565

    Red
    2001 Camaro SS A4

    Its your Alternator..mine just did it a week ago...sucked..i replaced it myself. I wasnt going to pay someone $200 to replace it.

    But yeah its your Alternator man trust me i just had this problem.

  4. #4
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    howmuch $$$ are alternators ?

  5. #5
    down with the lot lizards blackhawk01's Avatar
    Join Date
    Dec 2006
    Location
    Pensacola
    Age
    28
    Posts
    1,565

    Red
    2001 Camaro SS A4

    I got a new one from O Rieleys for 160

  6. #6
    Junior Member camarossf650's Avatar
    Join Date
    Jun 2007
    Location
    South San Francisco
    Posts
    50

    White
    1998 Camaro Z28

    yea it is my alternator,it sucks,i had to get it towed and it sucked balls.ya autozone has it for 150,is it hard to install?

  7. #7
    down with the lot lizards blackhawk01's Avatar
    Join Date
    Dec 2006
    Location
    Pensacola
    Age
    28
    Posts
    1,565

    Red
    2001 Camaro SS A4

    its kind of a bitch....your gong to have to get someone up top with some kind of breaker bar to knock it out incase it comes loose..PM me and ill give you instructions

  8. #8
    Miss Pennsylvania ls1blackbeauty98's Avatar
    Join Date
    Aug 2005
    Location
    West Cheter, PA
    Posts
    2,851

    '98 Black Gone :(
    01 WS6 Midnight Blue

    Quote Originally Posted by camarossf650 View Post
    yea it is my alternator,it sucks,i had to get it towed and it sucked balls.ya autozone has it for 150,is it hard to install?
    i feel cheated, last time i needed an alternator i paid about 230 for it..
    anyway good luck with ur instal! i think u will find it easy enough that u can do it urself.

  9. #9
    Member 6sw00's Avatar
    Join Date
    May 2006
    Location
    N.Y
    Age
    31
    Posts
    282

    black
    2000 trans am ws6

    just got one on ebay, remanufactured for 90 shipped

  10. #10
    Member bertt23's Avatar
    Join Date
    Jun 2006
    Location
    east houston
    Posts
    325

    pewter
    2002 camaro

    its not that hard, put mine on, and took it off like 6x.

  11. #11
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Quote Originally Posted by 6sw00 View Post
    just got one on ebay, remanufactured for 90 shipped
    Thats one of the parts i wouldnt buy reman, nor would i buy off of ebay. Just my opinion thou.
    J

  12. #12
    Member stephen02ws6's Avatar
    Join Date
    Jun 2007
    Location
    Dalzell, Illinois
    Age
    29
    Posts
    899

    red with black stripes
    2002 Trans Am WS6

    Quote Originally Posted by sunsetorangess View Post
    Thats one of the parts i wouldnt buy reman, nor would i buy off of ebay. Just my opinion thou.
    J
    i used to rebuild them at my last job at a local shop. the parts we put in were better than original. certain parts arent too good, i believe its the rectifier if i remember right.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Alternator help
    By GOHOME! in forum General Help
    Replies: 3
    Last Post: 06-06-2009, 12:18 PM
  2. Alternator
    By smkeater911 in forum External Engine
    Replies: 3
    Last Post: 11-29-2008, 01:19 PM
  3. Alternator Help
    By Chamelion WS6 in forum General Help
    Replies: 4
    Last Post: 12-16-2006, 09:13 AM
  4. alternator
    By a10beav in forum GTO
    Replies: 2
    Last Post: 09-26-2006, 09:39 AM
  5. lt1 ALTERNATOR
    By drb131s in forum Parts For Sale / Trade
    Replies: 0
    Last Post: 09-17-2006, 05:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •