Results 1 to 8 of 8

Need help with 4.3 in Jimmy

This is a discussion on Need help with 4.3 in Jimmy within the General Help forums, part of the LSx Technical Help Section category; I have a 93 Jimmy that will not idle smooth. I have changed the spark plugs, and one side s ...

  1. #1
    Member
    Join Date
    Oct 2005
    Location
    Vicksburg. Ms.
    Posts
    424

    pewter
    99 Trans Am

    Question Need help with 4.3 in Jimmy

    I have a 93 Jimmy that will not idle smooth. I have changed the spark plugs, and one side s plugs were soothy black.when you speed up the engine black smoke comes out of the tail pipe.I have checked the EGR valve,changed the Dist. cap and rotor.checked the fast idle seniod,and changed the wires 2 months ago.What does the oxgen sencor do and could it be my problem. Need help this is my wife's work truck and she will need it tomorrow. The truck runs good, but it just have a bad idle. Help me please.

  2. #2
    Member
    Join Date
    Apr 2007
    Location
    San Diego
    Posts
    177

    Red
    2002 T/A

    Those engines are plagued with bad fuel injector distributors. I've replaced dozens of them.

  3. #3
    Member
    Join Date
    Apr 2007
    Location
    San Diego
    Posts
    177

    Red
    2002 T/A

    Here's what it looks like.

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    Open up the throttle body and look inside and see if one side of the intake is washed down with gas. It could also be an O2. I don't remember off hand how the obd1's were set up as far as O2's go. If the front O2 on that side is bad it will cause very similar symptoms.

  5. #5
    Member
    Join Date
    Oct 2005
    Location
    Vicksburg. Ms.
    Posts
    424

    pewter
    99 Trans Am

    Quote Originally Posted by 0rion View Post
    Open up the throttle body and look inside and see if one side of the intake is washed down with gas. It could also be an O2. I don't remember off hand how the obd1's were set up as far as O2's go. If the front O2 on that side is bad it will cause very similar symptoms.
    Thanks to all of you that took out the time to give me some ideals.I believe that it may be the 02 also,because there is no gas smell on the plugs or any sign of them being fouled from gas.It's as if there is not enough air in the engine to make a clean burn.I forgot to add that I also did a compression test to make sure that it didn't have a burnt valve.All showed between 145 & 150.
    Last edited by Street Fighter; 05-13-2007 at 06:18 PM.

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    just out of curiousity do you have the infamous 4.3L intake leak? I've had 2 vehicles with 4.3's and both had the lower intake leak on them. Very common for that motor.

  7. #7
    Member
    Join Date
    Apr 2007
    Location
    San Diego
    Posts
    177

    Red
    2002 T/A

    Yep, could be that also I just figured it was running rich versus misfiring. Due to black plugs and black smoke.

  8. #8
    Member
    Join Date
    Oct 2005
    Location
    Vicksburg. Ms.
    Posts
    424

    pewter
    99 Trans Am

    Quote Originally Posted by 0rion View Post
    just out of curiousity do you have the infamous 4.3L intake leak? I've had 2 vehicles with 4.3's and both had the lower intake leak on them. Very common for that motor.
    I thought of that so I did the old hand over the carb.thing and there was no sign of any improvement in the idle.The engine died out if I placed the hand all the way over the thottle opening or tried to if I just did it slowly. This may not be the best way to check for intake leaks but it have always worked for me with carburated engines.I felt that there was no leak.I will try spraying around the intake to day once my wife return from work. thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help with 4.3 engine.
    By Street Fighter in forum General Help
    Replies: 0
    Last Post: 05-13-2007, 01:20 PM
  2. 4.3 V6 question :)
    By blackhawk01 in forum V6
    Replies: 19
    Last Post: 05-05-2007, 08:19 PM
  3. Jimmy Jams ashtray switch
    By 97vetteman in forum Parts For Sale / Trade
    Replies: 2
    Last Post: 02-10-2007, 11:58 AM
  4. 95 4.3 Blazer DD need help!
    By RidinDirty in forum General Help
    Replies: 11
    Last Post: 01-23-2007, 10:46 PM
  5. Jimmy Blue, Help
    By Andy Lappin in forum Computer & Tuning
    Replies: 4
    Last Post: 06-11-2006, 05:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •