Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Need advice / contacts

This is a discussion on Need advice / contacts within the General Help forums, part of the LSx Technical Help Section category; Okay - just bought a 99 Z28 that I probably got screwed on - but I won't whine too much ...

  1. #1
    Junior Member 97txaggie's Avatar
    Join Date
    Apr 2010
    Location
    SW Iowa
    Age
    43
    Posts
    34

    Black
    1999 Z28

    Question Need advice / contacts

    Okay - just bought a 99 Z28 that I probably got screwed on - but I won't whine too much Fact is, I need some one in the SW Iowa area that knows what the heck they are doing. NO shade tree mechanics. The car revs fine w/ no load, but under WOT, it will spit and sputter pretty bad. Still gets up and goes, but it just isn't as responsive as it should be. I owned a 95 Z for years and w/ little or no mods, it would blow the doors off this car. Current car has long tube headers, ory-pipe, magnaflow 3" exhaust, and SLP lid. It should scoot I would think. I had the codes ran - one misfire, one fuel/air mixture, and about 20 or so O2 sensors for obvious reasons.

    Soooo...where would you start? My local shadetree mechanic thinks it could be a valve spring..speed shop in KC thinks maybe a pushrod...both said could be as simple as a plug or plugwire too. I recently wet everything down to look for errant sparks, but got nothing there (not my idea, but a recommendation). Any thoughts would be GREATLY appreciated!!!

    Thanks
    TxAg

  2. #2
    Junior Member 97txaggie's Avatar
    Join Date
    Apr 2010
    Location
    SW Iowa
    Age
    43
    Posts
    34

    Black
    1999 Z28

    Oh yeah -- it has LS6 intake too...or so I'm told - haven't found a good way to verify that w/out taking things apart though.

  3. #3
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by 97txaggie View Post
    Okay - just bought a 99 Z28 that I probably got screwed on - but I won't whine too much Fact is, I need some one in the SW Iowa area that knows what the heck they are doing. NO shade tree mechanics. The car revs fine w/ no load, but under WOT, it will spit and sputter pretty bad. Still gets up and goes, but it just isn't as responsive as it should be. I owned a 95 Z for years and w/ little or no mods, it would blow the doors off this car. Current car has long tube headers, ory-pipe, magnaflow 3" exhaust, and SLP lid. It should scoot I would think. I had the codes ran - one misfire, one fuel/air mixture, and about 20 or so O2 sensors for obvious reasons.

    Soooo...where would you start? My local shadetree mechanic thinks it could be a valve spring..speed shop in KC thinks maybe a pushrod...both said could be as simple as a plug or plugwire too. I recently wet everything down to look for errant sparks, but got nothing there (not my idea, but a recommendation). Any thoughts would be GREATLY appreciated!!!

    Thanks
    TxAg
    Get the actual codes pulled, write them down and post them here.


    I bolded what I*think* could be your problem. You shouldn't be getting any codes for the o2 sensors. The post cat o2's may be throwing a code, but the front should not. Find out the actual codes numbers, its very hard to help without them.

  4. #4
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Also, check this link out on LS6/LS1 intakes and how to tell them apart.

    How do you identify an LS6 from an LS1 intake?
    370 CI - Twin 6766 Turbo - Jakes stage 5 4L80E - MWC 9" - Holley Dominator

    Build in progress...

  5. #5
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    Quote Originally Posted by Hi-Po View Post
    Get the actual codes pulled, write them down and post them here.


    I bolded what I *think* could be your problem. You shouldn't be getting any codes for the o2 sensors. The post cat o2's may be throwing a code, but the front should not. Find out the actual codes numbers, its very hard to help without them.
    ^ what he said...i think you have a few things to take care of ..not just one problem ....with the new intake it is very possible you have a vacuum leak ..if it got got over torqued and cracked or not torqued down enough... but as hi-po said..get the codes ran and give us the numbers so we can go from there.

  6. #6
    Junior Member 97txaggie's Avatar
    Join Date
    Apr 2010
    Location
    SW Iowa
    Age
    43
    Posts
    34

    Black
    1999 Z28

    Will do --- I am pretty sure they cleared them, but I have new ones already, so I will get it scanned again and post as soon as I can!
    TxAg

  7. #7
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    Quote Originally Posted by 97txaggie View Post
    Will do --- I am pretty sure they cleared them, but I have new ones already, so I will get it scanned again and post as soon as I can!
    TxAg
    if the problem exists ...the same codes will come right back

  8. #8
    Junior Member 97txaggie's Avatar
    Join Date
    Apr 2010
    Location
    SW Iowa
    Age
    43
    Posts
    34

    Black
    1999 Z28

    0134
    0140
    0155
    0160
    0327
    0507
    1133
    that is what i got!

  9. #9
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by 97txaggie View Post
    0134
    0140
    0155
    0160
    0327
    0507
    1133
    that is what i got!
    Codes!

    P0134 - HO2S Circuit Insufficient Activity Bank 1 Sensor 1
    P0140 - HO2S Circuit Insufficient Activity Bank 1 Sensor 2
    P0155 - Heated Oxygen Sensor Heater Circuit (bank 2, sensor 1)
    P0160 - HO2S Circuit Insufficient Activity Bank 2 Sensor 2
    P0327 - Knock Sensor 1 Circuit Low Input (Bank1)
    P0507 - Idle Control System RPM Higher Than Expected
    P1133 - Heated Oxygen Sensor (HO2S) insufficient switching Bank 1 sensor 1
    Last edited by KMdef9; 04-13-2010 at 04:15 PM. Reason: I am THAT bored in class today...

  10. #10
    Junior Member 97txaggie's Avatar
    Join Date
    Apr 2010
    Location
    SW Iowa
    Age
    43
    Posts
    34

    Black
    1999 Z28

    ok - so what the heck should i do?? any advice appreciated. Would these things cause a bad miss under load???

  11. #11
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by 97txaggie View Post
    Okay - just bought a 99 Z28 that I probably got screwed on - but I won't whine too much Fact is, I need some one in the SW Iowa area that knows what the heck they are doing. NO shade tree mechanics. The car revs fine w/ no load, but under WOT, it will spit and sputter pretty bad. Still gets up and goes, but it just isn't as responsive as it should be. I owned a 95 Z for years and w/ little or no mods, it would blow the doors off this car. Current car has long tube headers, ory-pipe, magnaflow 3" exhaust, and SLP lid. It should scoot I would think. I had the codes ran - one misfire, one fuel/air mixture, and about 20 or so O2 sensors for obvious reasons.

    Soooo...where would you start? My local shadetree mechanic thinks it could be a valve spring..speed shop in KC thinks maybe a pushrod...both said could be as simple as a plug or plugwire too. I recently wet everything down to look for errant sparks, but got nothing there (not my idea, but a recommendation). Any thoughts would be GREATLY appreciated!!!

    Thanks
    TxAg
    Here's somewhere to start.

    When someone puts long tube headers and ORY-pipe on their car, it is suggested they have there car tuned for the modifications. During a tune, the tuner will delete the rear O2 sensor and cat converter codes and adjust the air/fuel ratio to match the engine's mods. When done properly, the car will run flawlessly with no SES lights.

    Another area to address with headers and ory is the front O2 sensors. The stock ones won't reach the connectors any more. The solutions for this are
    1. Install two new Corvette rear O2 sensors. The wiring on these sensors are longer and plug right into harness. (Best option)
    2. O2 sensor harness extensions. Allow you to keep your stock O2 sensors (works ok sometimes but have been known to be problematic)
    3. cut and splice your own wiring extensions (not at all recommended)

  12. #12
    Junior Member 97txaggie's Avatar
    Join Date
    Apr 2010
    Location
    SW Iowa
    Age
    43
    Posts
    34

    Black
    1999 Z28

    Thanks for the advice Cutlass -- now for an even more stupid question - how much should I expect to spend to have someone tune it? Anyone live close to Omaha or KC and could offer up a suggestion on who to use?

    Thanks for all the comments.
    TxAg

  13. #13
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by 97txaggie View Post
    Thanks for the advice Cutlass -- now for an even more stupid question - how much should I expect to spend to have someone tune it? Anyone live close to Omaha or KC and could offer up a suggestion on who to use?

    Thanks for all the comments.
    TxAg
    For tuning, contact our fellow member/sponsor Frost.

  14. #14
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    yep you can mail your PCM to Frost and he can tune it and send it back to you for about $125 plus shipping, I think

  15. #15
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    Quote Originally Posted by 97txaggie View Post
    Thanks for the advice Cutlass -- now for an even more stupid question - how much should I expect to spend to have someone tune it? Anyone live close to Omaha or KC and could offer up a suggestion on who to use?

    Thanks for all the comments.
    TxAg
    Quote Originally Posted by KMdef9 View Post
    For tuning, contact our fellow member/sponsor Frost.
    Quote Originally Posted by Cutlass View Post
    yep you can mail your PCM to Frost and he can tune it and send it back to you for about $125 plus shipping, I think
    ^ with them..however look for a local tuner ..the price will be about the same.

  16. #16
    Junior Member 97txaggie's Avatar
    Join Date
    Apr 2010
    Location
    SW Iowa
    Age
    43
    Posts
    34

    Black
    1999 Z28

    I just checked w/ MC Racing in KC and they want $400 -- seems a little steep compared to the $125, but I would rather have the actual car tested rather than just a bench test.

  17. #17
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by 97txaggie View Post
    I just checked w/ MC Racing in KC and they want $400 -- seems a little steep compared to the $125, but I would rather have the actual car tested rather than just a bench test.
    I could be wrong with this, but given you have a small number of mods, a bench tune will benfit you just as much as road tuning. Frost can answer that question better than I can, can't hurt to ask him. Plus, I'm sure he's tuned more F-body's than most local shops have.

  18. #18
    Junior Member 97txaggie's Avatar
    Join Date
    Apr 2010
    Location
    SW Iowa
    Age
    43
    Posts
    34

    Black
    1999 Z28

    Very good point - I will shoot him a message on here!

    I do have another question for you experts too - if there were issues w/ the transmission, do they have scans for that, or would it show codes through the OBD2 connection as well? Just curious - I think things are fine, but it is honestly hard to tell as bad as the thing runs now
    Thanks again for all the help!
    Jay

  19. #19
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by 97txaggie View Post
    Very good point - I will shoot him a message on here!

    I do have another question for you experts too - if there were issues w/ the transmission, do they have scans for that, or would it show codes through the OBD2 connection as well? Just curious - I think things are fine, but it is honestly hard to tell as bad as the thing runs now
    Thanks again for all the help!
    Jay
    A4?

    If it isn't throwing a code, I don't think so. Check the fluid color, that's usually a good start. Does it feel like it's slipping? Shifting hard when driving easy?

  20. #20
    Junior Member 97txaggie's Avatar
    Join Date
    Apr 2010
    Location
    SW Iowa
    Age
    43
    Posts
    34

    Black
    1999 Z28

    Yep - auto. It does kinda feel like it is slipping to me, but it could be just the fact that it doesn't rev smoothly. I'll get it tuned here shortly - I think I have a lead and I have an email off to Frost already as well. I'll post more details about the tranny in the next week or two hopefully!
    J

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Before and after pics of me with my contacts!
    By blackSS01 in forum Almost Anything Goes
    Replies: 15
    Last Post: 11-15-2009, 10:56 PM
  2. Contacts.........YAY!!
    By blackSS01 in forum Almost Anything Goes
    Replies: 21
    Last Post: 11-14-2009, 11:34 PM
  3. Got Contacts...
    By Smkn_TA in forum Almost Anything Goes
    Replies: 12
    Last Post: 10-26-2008, 06:57 PM
  4. Need serious advice...alot of advice. Long.
    By !!!FAST!!! in forum Almost Anything Goes
    Replies: 0
    Last Post: 10-31-2007, 08:49 PM
  5. Contacts....cheap.......$125.00 Years Supply....
    By supercharged-Z in forum General Classifieds
    Replies: 0
    Last Post: 03-19-2006, 08:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •