Results 1 to 10 of 10

Name This Weeks Problem!!!!

This is a discussion on Name This Weeks Problem!!!! within the General Help forums, part of the LSx Technical Help Section category; Just had a Racetronix fuel pump installed 2 weeks ago. Was driving home tonight and it suddenly lost power and ...

  1. #1
    I flame retards CamaroFan71's Avatar
    Join Date
    Aug 2006
    Location
    Baton Rouge, La.
    Posts
    1,068

    QuickSilverMetallic
    2005 GTO M6

    Name This Weeks Problem!!!!

    Just had a Racetronix fuel pump installed 2 weeks ago. Was driving home tonight and it suddenly lost power and died while on the highway. Guages all went down and the "check guages" light came on. Tried to start it again and it turns over fine but wont start. Let it sit for a bit and it will start and die immediately. I took the cap off the fuel rail and pushed in the schrader valve and no fuel came out at all, even with my fiance cranking. Fuel pump again or what? Was told it could be a sensor...

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    Did you change the fuel filter? Checked all fuses and relays? is there voltage at the pump harness?

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    damn bro.....when it rains it pours. Like Orcus said, check for power at the harness and go from there. You could try just swapping that pump relay with your air relay or something but I'd first check to see if you have power back there at the pump so you know where you stand. I'd have to look it up to be 100% certain but I'm fairly certain going off memory that the grey wire is your hot wire and the black is your ground back there.

  4. #4
    I flame retards CamaroFan71's Avatar
    Join Date
    Aug 2006
    Location
    Baton Rouge, La.
    Posts
    1,068

    QuickSilverMetallic
    2005 GTO M6

    Quote Originally Posted by 0rion View Post
    damn bro.....when it rains it pours. Like Orcus said, check for power at the harness and go from there. You could try just swapping that pump relay with your air relay or something but I'd first check to see if you have power back there at the pump so you know where you stand. I'd have to look it up to be 100% certain but I'm fairly certain going off memory that the grey wire is your hot wire and the black is your ground back there.

    Yeah man it sucks Its about to get a match thrown to it. I switched the fuel pump relay and the a/c relay while on the side of the road hoping it was that, but of course it wasnt. I had it towed back to the shop that did the install..... We'll see.

  5. #5
    Member
    Join Date
    Mar 2007
    Location
    NC
    Posts
    421

    NBM
    1998Z28

    Gas hose popped off the pump?
    TSP 347 SB, TSP Stage 2.5 PRC LS6, TSP MS4, Performabuilt Stage 2 4L60E, Yank PT4000, 4.11s, Fast 90/90, FTRA Cold air intake+all the free mods, Dynatech Supermaxx Exaust System, DMH Cutouts, Hooker Catback/FTRA Tips. Tuned by RPM/Garner NC. 11.28@119

  6. #6
    I flame retards CamaroFan71's Avatar
    Join Date
    Aug 2006
    Location
    Baton Rouge, La.
    Posts
    1,068

    QuickSilverMetallic
    2005 GTO M6

    Quote Originally Posted by PFM View Post
    Gas hose popped off the pump?

    Just talked to the shop. Apparently the hose for the pump that comes in the kit, ruptured inside the tank. They said they put a new hose on it for fuel injection and should have it fixed in about an hour. Im glad it wasnt the pump, but to pay to have the tank dropped again for a damn hose sucks!!

  7. #7
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    I bet it didn't rupture but simply came off like PFM said.....

  8. #8
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    how many sets of tools could you have bought with this money??

  9. #9
    I flame retards CamaroFan71's Avatar
    Join Date
    Aug 2006
    Location
    Baton Rouge, La.
    Posts
    1,068

    QuickSilverMetallic
    2005 GTO M6

    Quote Originally Posted by 0rion View Post
    how many sets of tools could you have bought with this money??
    My own lift??? Haha. Thats what truly sucks. While im not the best at electrical problems I am very mechanically inclined. But its having the "place" to do all this work that I dont have.

  10. #10
    Yo Da Lin The Valley..... astyles's Avatar
    Join Date
    Mar 2006
    Location
    here
    Posts
    3,693
    2001

    Quote Originally Posted by 0rion View Post
    I bet it didn't rupture but simply came off like PFM said.....
    i had that happen with my pump too...... then recently i belive that the fuel filter got clogged and the same symptoms were happening that are happening with your car.......it is still running rough so i may drop the tank and see whats up

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Its been 3 weeks without an Fbody.....
    By BadBlueBird* in forum Almost Anything Goes
    Replies: 39
    Last Post: 03-29-2011, 04:03 PM
  2. Picking up my v6 in 2 weeks!
    By mroby in forum V6
    Replies: 36
    Last Post: 08-03-2010, 09:47 AM
  3. 2 weeks notice
    By third_shift|studios in forum Almost Anything Goes
    Replies: 34
    Last Post: 05-08-2010, 05:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •