Page 3 of 3 FirstFirst 123
Results 41 to 48 of 48

Mystery MAF?

This is a discussion on Mystery MAF? within the General Help forums, part of the LSx Technical Help Section category; so thats the num on the new maf...........or the num on the old maf that cross references the new maf..........me ...

  1. #41
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    so thats the num on the new maf...........or the num on the old maf that cross references the new maf..........me cornfused

  2. #42
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    That's the P/N for the LS1 replacement MAF per GM Parts Direct. Its calibrations closely match the stock piece, hence tuning is probably not required. Although it has an integral IAT sensor, there is a harness adapter that comes with it (I believe there is a picture of this in the thread). I have no idea if they have changed the part number or anything since I ordered this one last year.

  3. #43
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    Thumbs up

    Quote Originally Posted by Hi-Po View Post
    If I had a guess, yes. I bet in attempt to cut costs they are building one MAF, and selling it with or without an extension.
    I agree, it is probably a generic MAF that is made to fit several GM vehicles, you may be the first to have a MAF that installs directly into a Chevy Volt (jk).

    SteveC

  4. #44
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    I noticed it has the defuser screen like the 3800 85mm fly by wire has in the TB. Wierd that it would be behind the sensor rather than in front like mine was.. I really can't see it flowing as good as just a stock unit with that defuser inplace..
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  5. #45
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    By the way.... Holy old thread revival Batman! I think I saw some name/s no longer with us back there..

  6. #46
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by Cutlass View Post
    Yep you know what up with these then. The plastic isn't as rigid as the stock one. The rear tabs flex. A SLP smooth bellows trimmed short kinda helps pull the rear of the lid in and down. But I still ended up ramming everything together, holding it in, and running screws through the tabs and the filter housing base. Seals great now...pain in the ass when I wanna work on the damn thing though
    Put small cable ties to hold the clips down. It works like a charm

  7. #47
    Junior Member RCH33's Avatar
    Join Date
    Jun 2015
    Location
    Greenwood, IN
    Posts
    23

    Yellow
    2002 Trans Am CE

    image.jpg[

    image.jpg

    I just replaced an after market MAF with the exact same MAF that Jeff started this thread with. I also was able to get a y-adapter that allowed me to use the built in IAT. My tuner said he would rather use the built in one than the one that was in my SLP lid. After some time on eBay, I could not find one that would work, but I did find a vendor willing to make up a proper one for me. Here is the eBay listing number. 291541440721
    The name of the company is auto wiring solutions and the gentlemans name is Bill. Here is a photo.
    Attached Images Attached Images
    Last edited by RCH33; 08-26-2015 at 02:38 PM.

  8. #48
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    ^^ Good info - glad you got it all to work.

Page 3 of 3 FirstFirst 123

LinkBacks (?)

  1. 04-20-2014, 08:43 PM
  2. 10-02-2011, 03:48 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: LS1 Mystery: Need solving
    By GTMRACR in forum General Help
    Replies: 12
    Last Post: 05-25-2011, 09:45 AM
  2. Help: Mystery Part
    By duweller in forum Firebird / WS6
    Replies: 7
    Last Post: 06-14-2010, 07:07 AM
  3. Question: Marvel Mystery Oil in Gas/Oil in the LS1
    By camaroluvr447 in forum Internal Engine
    Replies: 7
    Last Post: 10-07-2009, 09:27 AM
  4. marvel mystery oil...
    By jray0305usa in forum Internal Engine
    Replies: 0
    Last Post: 03-05-2009, 07:26 PM
  5. 99 Z-28 Electrical Mystery
    By jterhar in forum General Help
    Replies: 3
    Last Post: 09-21-2006, 07:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •