Page 1 of 2 12 LastLast
Results 1 to 20 of 21

mysterious light?!

This is a discussion on mysterious light?! within the General Help forums, part of the LSx Technical Help Section category; I am having a problem with this light that comes on after my car has been running for a while ...

  1. #1
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674

    mysterious light?!

    I am having a problem with this light that comes on after my car has been running for a while it looks kinda like

  2. #2
    Sold: LS1 '85 El Camino ls1camino's Avatar
    Join Date
    Dec 2005
    Location
    Laurel, Maryland
    Posts
    4,977

    2000 Grand Prix GTP
    2000 Trans Am WS6 M6

    Low Coolant.

  3. #3
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    lol sweet pic, but like said above its your low coolant light..
    J
    2001 SS, Its not the car its the Driver that matters....

  4. #4
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674
    Yeahhh I think there is something wrong with the sensor because my radiator is full so I think it is just messin up
    It needs to go to the dealer anyway lol

  5. #5
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674
    Quote Originally Posted by ls1camino View Post
    Low Coolant.
    Where did you get those rims??

  6. #6
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    did you check the radiator itself or the overflow container? just curious

  7. #7
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674
    Both aha
    they both were full

  8. #8
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    if u want you can try and reset your computer.........if it still does it then i would say sensor

  9. #9
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    If the radiator and reservior are topped off, and the light is still on, then the sensor is bad.

    Very common problem, they get gummed up and give false readings.

    You can try cleaning the sensor, if that doesn't work you can get a new one from the auto parts store. You also have the option to just unplug it, then you won't have to worry about it, just check the coolant level periodically as routine maintenance.

  10. #10
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674
    I am taking it to the dealer haha

  11. #11
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Quote Originally Posted by 99TransAmSLP View Post
    I am taking it to the dealer haha
    Why?? Its easy as hell to disable/fix/replace. They will probably charge you $100 just to look at it, then plan on paying whatever ridiculous list price the sensor goes for plus the labor to install it. I try to avoid the dealer at all costs.

  12. #12
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674
    me too but I have to do other stuff too ahha

  13. #13
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    GM list for the sensor is about $65 + tax now, diagnostic fee (guessing) $85, labor cost who knows, probably recommend you to replace coolant....glad my car didn't even come with one.

  14. #14
    Junior Member blackls's Avatar
    Join Date
    Jul 2008
    Location
    san juan, texas
    Posts
    55

    black
    1998 trans am

    Quote Originally Posted by TransAm11973 View Post
    if u want you can try and reset your computer.........if it still does it then i would say sensor


    how do i do that man???reset the computer..i have that problem too..thankzz

  15. #15
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674
    I am going to get a programmer hahaha
    And get my sensor fixed along with my window and my exhaust is making noise!!

  16. #16
    Member
    Join Date
    Nov 2005
    Location
    allenhurst GA
    Age
    41
    Posts
    369

    onyx black
    1999 formula firebird

    youd would be stupid to pay the money to go to the STEALERSHIP when you can do it your damn self for the cost of parts alone...just my opinion...

  17. #17
    Member
    Join Date
    Nov 2005
    Location
    allenhurst GA
    Age
    41
    Posts
    369

    onyx black
    1999 formula firebird

    ooh yea and the dealerships mechanics make $85+ an HOUR for LABOR....on TOP of Stealership mark up costs on parts...save your money , do some work yourself and mod more...

  18. #18
    COTM July '09
    Join Date
    Jun 2008
    Location
    Annapolis, MD
    Posts
    1,111

    BLK/BLK w/CGM Stripes
    2010 Camaro 2SS/M6

    Dealership?

  19. #19
    Impounded
    Join Date
    Jul 2008
    Location
    ...
    Age
    29
    Posts
    674
    well I dnt Have anyway to get my car high enough to do the stuff I need to fix lol

  20. #20
    Trigger Puller Trainer KC&97TA's Avatar
    Join Date
    Jul 2000
    Location
    Dirty J'ville
    Posts
    502

    NBM
    2000 FRC Camaro SS

    this seems to be a pretty common irritation... after 9 years of owning my same F-Body the stupid light came on last night... think I'll just unplug it and zip tie it out of the way

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mysterious object found in the Baltic Sea
    By SiggyZ in forum Almost Anything Goes
    Replies: 44
    Last Post: 02-02-2012, 01:01 PM
  2. Mysterious Missile Lights Up Sky
    By doberman 152 in forum Almost Anything Goes
    Replies: 29
    Last Post: 11-11-2010, 08:27 PM
  3. mysterious hose
    By slpdablueZ28 in forum General Help
    Replies: 24
    Last Post: 02-08-2010, 08:10 PM
  4. mysterious white Z in the neighborhood
    By myk02k in forum Almost Anything Goes
    Replies: 1
    Last Post: 07-15-2006, 12:11 AM
  5. The Mysterious LS1 tapping solved!!!!!!
    By CamaroCrazyChris in forum General Help
    Replies: 16
    Last Post: 11-05-2005, 07:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •