Results 1 to 10 of 10

my stuck turnin signal help 2001 ws6

This is a discussion on my stuck turnin signal help 2001 ws6 within the General Help forums, part of the LSx Technical Help Section category; Hey bros,first of all love my 2001 trans am ws6,candy red hood induction..Have a problem with my rite turnin signal ...

  1. #1
    Junior Member
    Join Date
    Feb 2010
    Location
    canada
    Posts
    19

    candy red
    2001 ws6 trans am

    my stuck turnin signal help 2001 ws6

    Hey bros,first of all love my 2001 trans am ws6,candy red hood induction..Have a problem with my rite turnin signal it sticks when turning,but flashes with my 4 ways,im thinkin its the flasher itself,now were is it??under the columm i heard but there is a plastic cover cant see it.would it be the flasher and how do i get at it to replace it??thanxs

  2. #2
    Senior Member GULLETT17's Avatar
    Join Date
    Oct 2007
    Location
    Muncie, IN
    Posts
    2,554

    00 TA PWTR, 98 VertTA NBM
    80 TA BLK, 80 Formula NBM

    probably one of your bulbs

  3. #3
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    Its a bulb I had the same thing happen to me a week ago. Turn ur signals on get out the car and see which isn't flashing

  4. #4
    Junior Member
    Join Date
    Feb 2010
    Location
    canada
    Posts
    19

    candy red
    2001 ws6 trans am

    its not the bulbs like i said the 4 ways flash so its not the bulbs!! it gt to be the flasher how do i get at replacing the flasher??

  5. #5
    Senior Member GULLETT17's Avatar
    Join Date
    Oct 2007
    Location
    Muncie, IN
    Posts
    2,554

    00 TA PWTR, 98 VertTA NBM
    80 TA BLK, 80 Formula NBM

    i believe the four ways can flash even if the bulbs are burnt out. . . check out this thread:
    turning signal problem
    if it is the flasher, however, it is located under the steering column, attached beside the radio. . .

  6. #6
    Member
    Join Date
    Apr 2009
    Location
    Palm Desert, CA
    Age
    26
    Posts
    121

    White
    97 3.8L Firebird 5 Speed

    the flash lights are different than the signals I believe, on my car they are (previous body)

  7. #7
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    Quote Originally Posted by mannie View Post
    its not the bulbs like i said the 4 ways flash so its not the bulbs!! it gt to be the flasher how do i get at replacing the flasher??
    Trust me its the bulb I had the same exact thing happen mine was the right front that was out. Put the blinker on the the side where it stays steady walk out the car and check both the front and the back

  8. #8
    Member blk99ws6ta's Avatar
    Join Date
    Jul 2007
    Location
    Palestine,Il
    Posts
    164

    Black
    1999 WS6 Ram Air Trans-Am

    Mine was the flasher. It's behind the panel under the steering wheel. It was melted. When my bulb went out, nothing changed other than the bulb didn't work. I thought they were crazy telling me the flasher is bad when the flasher 4-way worked. I would go with the flasher. Good luck

  9. #9
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by blk99ws6ta View Post
    Mine was the flasher. It's behind the panel under the steering wheel. It was melted. When my bulb went out, nothing changed other than the bulb didn't work.
    Someone must have replaced your OEM T/signal flasher with a heavy duty flasher than because the OEM one is designed to stop flashing with a bulb out.

  10. #10
    Junior Member
    Join Date
    Feb 2010
    Location
    canada
    Posts
    19

    candy red
    2001 ws6 trans am

    well bros first off i took the plastic panel under steerin there was no fuses under there put it back on jacked the car up took the socket out looked at the socket seemed clean enough put it back in took the rear lense off one small runnin light and the big bulb were burnt out and not on,replaced both walllaaaaaa turnin signal came back,thankss

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Stuck
    By mastertairium in forum External Engine
    Replies: 1
    Last Post: 03-22-2012, 11:50 AM
  2. Stuck!
    By Mieux97 in forum Firebird / WS6
    Replies: 2
    Last Post: 03-09-2010, 02:10 PM
  3. stuck
    By EasyEp in forum GTO
    Replies: 11
    Last Post: 04-23-2009, 08:34 AM
  4. my fan is stuck on
    By transamdude99 in forum General Help
    Replies: 8
    Last Post: 03-07-2009, 10:31 AM
  5. I'm stuck in between
    By cobrakiller99 in forum Firebird / WS6
    Replies: 33
    Last Post: 02-20-2009, 05:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •