Page 1 of 2 12 LastLast
Results 1 to 20 of 24

my blinker is not working??

This is a discussion on my blinker is not working?? within the General Help forums, part of the LSx Technical Help Section category; ive checked all the fuses;lights;turn signals everything is working except for my left turning blinker? anybody had this problem? thanks ...

  1. #1
    Junior Member
    Join Date
    Oct 2005
    Location
    Ontario, CA.
    Age
    36
    Posts
    50

    Hugger Orange
    1999 CAMARO SS

    my blinker is not working??

    ive checked all the fuses;lights;turn signals everything is working except for my left turning blinker?

    anybody had this problem?

    thanks in advance.

    Hector

  2. #2
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    28
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    maybe a ground wire?
    1999 Camaro SS/ Pewter/ #1775 - LS1 6-speed - Predator 3 Custom Tune - Pro 5.0 - LS7 Clutch - 3.90's - Koni's - Strano Springs and Sway Bars - SFC's - Full UMI Chassis and Suspension - LS6 Intake PnP TB - ARH LT's and Kitty Ran Away - Magnaflow.

    12.6 at 112

    http://www.fquick.com/Tyler_LS1

  3. #3
    I went to Playboy Mansion FantaZGuy28's Avatar
    Join Date
    Sep 2005
    Location
    Bakersfield/Long Beach Ca
    Age
    30
    Posts
    888

    YJ
    04 GTO M6

    Light bulb burnt out?

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    does it not blink or not light up? Is it the front or back or both? Does it look like moisture is getting into the lense?

  5. #5
    Junior Member
    Join Date
    Nov 2006
    Location
    Baytown
    Posts
    5

    blue
    1998 transam ram air

    Thumbs up

    That used to happen to my 98 ram air (fog lights)....I had to replace the whole assembly.....now no problems.... between moisture and loose wiring it was a

  6. #6
    Junior Member ls1vert's Avatar
    Join Date
    Aug 2005
    Location
    arizona
    Age
    44
    Posts
    27

    white
    1998 z28 vert

    if your day time running light burns out then the blinker will not work

  7. #7
    Junior Member
    Join Date
    Nov 2006
    Location
    Baytown
    Posts
    5

    blue
    1998 transam ram air

    the bulbs kept burning out in my trucks running lights so we just didn't put them back in and the blinkers work.....Is there a difference?......

  8. #8
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    53
    Posts
    5,167

    Black
    2000 WS6 6spd Hooker LT

    Wendy,Your trucks running lights are most likely not the same as the turn signals.

    Hector, double check the brightness of all your lights. Put your hazards on and check the lights. Your hazards use the same bulb/filament as the turn signal. All lights need to work, and be bright. I have seen people install thier own lights and jam them in the wrong way and cause all kinds of problems.

  9. #9
    Member 02WS6dream's Avatar
    Join Date
    Jun 2006
    Location
    Charlotte, NC
    Age
    33
    Posts
    668

    08 Mustang GT/CS Blue
    2002 Trans Am WS6 traded

    If you've checked all the bulbs, including rear, and they are good I would check the socket that isn't working next. It seems commom for moisture to get in there and corrode it. Do a search...several posts in the last couple months with similar problems.

  10. #10
    Member Fedge's Avatar
    Join Date
    Feb 2006
    Location
    New Jersey
    Age
    46
    Posts
    383

    Black
    1998 Trans Am M6

    the sockets are known for going bad. check it to see if it is burned up or corroded...
    95 Exploder

    01 R1 coming?

  11. #11
    whs
    Guest
    Quote Originally Posted by Fedge View Post
    the sockets are known for going bad. check it to see if it is burned up or corroded...

    What is the easiest fix? Have any of you noticed the housing filling with water?

  12. #12
    Member 02WS6dream's Avatar
    Join Date
    Jun 2006
    Location
    Charlotte, NC
    Age
    33
    Posts
    668

    08 Mustang GT/CS Blue
    2002 Trans Am WS6 traded

    Quote Originally Posted by whs View Post
    What is the easiest fix? Have any of you noticed the housing filling with water?
    Look here... Also should note that I went back and heeded the advice of 'Orcus' (sp?) in this thread concerning butt connector vs. solder; would rather go through a little trouble now than have a headache later.

    Turn Signal Pig Tail Install Help

  13. #13
    detail king 2001somws6's Avatar
    Join Date
    Aug 2005
    Location
    ORLANDO,FL
    Age
    44
    Posts
    444

    SUNSET ORANGE
    2001 PONTIAC TRANS AM WS6

    Quote Originally Posted by Fedge View Post
    the sockets are known for going bad. check it to see if it is burned up or corroded...
    I had a corroed socket from some mositure and all i did was clean it out with a Q-tip and now its fine. This was the front drivers side blinker.

  14. #14
    38 of 139 PontiacFan's Avatar
    Join Date
    Jul 2005
    Location
    Kearney, NE
    Posts
    931

    Black
    2001 Pontiac

    Simply re-fill yer blinker fluid?
    http://kalecoauto.com/index.php?main...&products_id=6

  15. #15
    Junior Member cheviz28's Avatar
    Join Date
    Nov 2006
    Location
    Cologne, Germany
    Age
    55
    Posts
    96

    Navy Blue Pearl
    2000 Camaro Z28

    Sorry i can't help, but Blinker is the German word for Turnlight.

    He the blinker fluid is cool, i need it

  16. #16
    Member
    Join Date
    Aug 2006
    Location
    Michigan
    Age
    46
    Posts
    178

    Black
    98 T/A

    If your connectors are corroded bad, I used non chlorinated brake cleaner or electrical cleaner to clean out the old bulb grease. I then took a syringe full of muriatic acid and let it sit in the connector for about 20-30 seconds. dump it out and respray the cleaner to flush out the acid residue. Allow to dry, replace bulb grease and bulb. Works great for the headlight/motor connectors as well. Ensure you replace the headlight plug female side up with the attachment prong and hole on the fenderwell to prevent water from sitting in the plug.

  17. #17
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    33
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    get a replacement socket if after replacing the bulb doesnt work.

  18. #18
    car enthusiast djvaly's Avatar
    Join Date
    Nov 2005
    Location
    Philly area
    Posts
    9,863
    Quote Originally Posted by PontiacFan View Post
    I never heard of blinker fluid. where exactly does this fluid need to be refilled?
    it's a joke, right?
    Last edited by djvaly; 11-27-2006 at 09:09 AM.

  19. #19
    Junior Member cheviz28's Avatar
    Join Date
    Nov 2006
    Location
    Cologne, Germany
    Age
    55
    Posts
    96

    Navy Blue Pearl
    2000 Camaro Z28

    I think???? Nobody !!!!!!!!!

  20. #20
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    blinker fluid should only be added every 50k miles or when you re-torque the muffler bearings.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •