Results 1 to 7 of 7

Is my 2000 LS1 MAF OKAY

This is a discussion on Is my 2000 LS1 MAF OKAY within the General Help forums, part of the LSx Technical Help Section category; So I got to looking around at the MAF due to a hesitation problem...(posted a few Threads but haven't solved ...

  1. #1
    Junior Member
    Join Date
    Jul 2009
    Location
    columbus
    Posts
    13

    red
    2000 WS6 TRANS AM

    Is my 2000 LS1 MAF OKAY

    So I got to looking around at the MAF due to a hesitation problem...(posted a few Threads but haven't solved it yet) and found that I was not getting the same voltage readings on my 2000 LS1 MAF as what was described in the Haynes Manual that I picked up at an auto parts store???. From ground to the referance back to the PCM i measured like 4 volts and when I moved the throttle i saw the voltage increased a bit. the Haynes Manual said to expect .2 VDC to 2.0VDC and if I felt that I had a problem with the MAF to unplug the connection and measure the resistance of the maf to insure that it was not Wide open with no resistance.????

    I checked and my Maf and it is open and has no resistance between gnd and ref or ref and battery voltage or GND to Battery voltage pins???? I thought I should have some resistance? I went to the local parts store and had them bring down a rebuilt MAF and I measured the resistance on that sensor and it appeared the same open and no resistance? can anyone explain this? The only thing that I can think of now is I may have had the Meter set to the wrong resistance level???? I will have to check tomorrow if I see any resistance? does anyone know what the resistance should be???

  2. #2
    I can tell you this...if yer not using a high impedance meter you can't measure things like that. It will fry the sensor.

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I have the '02 factory service manuals and can PM you the diagnostic procedure for the MAF as it is probably the same for an '00. Only problem is we are going away for 4 days and I'm not sure if I will have time tonight to locate the info. Send me a PM on Sunday if you can not find an answer by then and I'll see what I can do. I also have a hacked up MAF that came with our car. I would gladly mail it to you as a "test piece". The car ran fine with it, but had a very slight off idle stumble that you only noticed pressing on the throttle while in park.

  4. #4
    Junior Member
    Join Date
    Jul 2009
    Location
    columbus
    Posts
    13

    red
    2000 WS6 TRANS AM

    Voltage check

    Since the voltage across the MAF sensor ( ground and ref.) is 4 volts instead of 2 volts is my maf bad?????

  5. #5
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    You are supposed to check that with the sensor unplugged. Are you?

  6. #6
    Junior Member
    Join Date
    Jul 2009
    Location
    columbus
    Posts
    13

    red
    2000 WS6 TRANS AM

    resistance check / voltage check

    I was trying to check the resistance when the sensor was unplugged, and the car was off. The probes were placed directly on the ground and signal pins on the MAF 3 pin connection.


    The voltage was checked with the car running. the connector was on and I placed two pins in the back of the connector so i could "back-probe" the connector and measure the Voltage across gnd and the signal pins.

  7. #7
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    San Jose
    Age
    36
    Posts
    1,897

    Red
    1998 Pontiac Trans Am

    Are you throwing any kind of MAF codes at all? If you're throwing a maf ckt high code, check the ground for the MAF. It's behind the drivers side cylinder head. Make sure the MAF has everything it needs. Here's a few tests that you can run using frequency. Gnd lead to Ground and Red Lead to 5V ref wire. Do this with the MAF connected. KOEO initial you should see a high frequency then a drop to 300 hz. KOER warm idle about 2.3khz. 2500 rpms no load 4.2 khz. You should not see any glitches in the test.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Pontiac Pirahna - Department X: The 2000 Piranha Concep
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 10-05-2012, 05:20 PM
  2. 2000 auto z28 VS 2000 m6 formula
    By silverz28camaro in forum Kill Stories
    Replies: 5
    Last Post: 06-24-2007, 08:59 PM
  3. 2000 Mustang GT Vs. 2000 SS Camaro
    By OnEbAdReDSS in forum Kill Stories
    Replies: 34
    Last Post: 04-23-2007, 08:49 PM
  4. 2000 camaro ss vs 2000 corvette
    By 99-SS-Conv in forum General Help
    Replies: 11
    Last Post: 04-03-2007, 09:17 AM
  5. WTB slp or other lid for 2000 ws6
    By derrinx in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 03-31-2007, 02:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •