Results 1 to 2 of 2

More Trouble out of the RS

This is a discussion on More Trouble out of the RS within the General Help forums, part of the LSx Technical Help Section category; Ok i bet you guys are getting sick of me or my car, or both. Anyways tonight while riding around ...

  1. #1
    Bomb Technician Krazy351w's Avatar
    Join Date
    Nov 2006
    Location
    In A Jesus Christ pose.... on the banks of the Thames with Ratty and Mole.
    Posts
    208

    hunter Green
    92 Camaro RS 350 Special

    More Trouble out of the RS

    Ok i bet you guys are getting sick of me or my car, or both. Anyways tonight while riding around i noticed my temp gauge was almost in the red. well i didnt think much about it cuz there are alot of stop lights in my town and i had been idling most of the night. well i started crusing and kept my speed up around 50-60mph and noticed it was climbing further into the red. after this my check engine light came on. well in a panic i went out onto a county road and just cruised the open road at about 70. this Cooled the car back down but the check engine light refuses to shut off. I just installed a new fan. which obviously isnt worth crap. So i am curious as to what could cause such massive over heating plus why the check engine light came on in the first place.

  2. #2
    Bomb Technician Krazy351w's Avatar
    Join Date
    Nov 2006
    Location
    In A Jesus Christ pose.... on the banks of the Thames with Ratty and Mole.
    Posts
    208

    hunter Green
    92 Camaro RS 350 Special

    Anyone?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Traction Trouble
    By bucman1 in forum General Help
    Replies: 24
    Last Post: 09-19-2007, 03:27 PM
  2. Trouble Codes?
    By ssxcytmnt in forum General Help
    Replies: 8
    Last Post: 03-08-2007, 04:52 PM
  3. wiper trouble
    By Arkansa Dave in forum General Help
    Replies: 0
    Last Post: 02-28-2007, 09:41 AM
  4. trouble trouble plz help
    By z28jerad in forum Automatic Transmission
    Replies: 2
    Last Post: 10-09-2006, 08:08 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •