Results 1 to 4 of 4

More power window trouble. New one installed, still acting up

This is a discussion on More power window trouble. New one installed, still acting up within the General Help forums, part of the LSx Technical Help Section category; So.. had my car in to the dealer to get the power window fixed. LONG story short, my extended warrantee ...

  1. #1
    I Think, Therefore Z-28 Corvettekid82's Avatar
    Join Date
    Aug 2005
    Location
    Deland FL
    Posts
    390

    Triple Black
    2001 Z-28 Vert

    Angry More power window trouble. New one installed, still acting up

    So.. had my car in to the dealer to get the power window fixed. LONG story short, my extended warrantee company screwed me and will not cover it. Chevy charged me a "electrical diagnosis fee" of 42 dollars and told me the motor is bad and would cost 350 parts and labor to fix. Of course I said hell no and went to autozone and got a lifetime warrantee motor for 50 bucks. Well, I installed the motor and heres the funky thing: Drivers side window switch does nothing. Passengers side window switch only gives me "Up" no "Down". Any ideas on what exactly might be bad in the circuit?? Drivers side switch blown? Passengers side gone? BOTH??? What do I need to replace??

    This is the 8th time this window motor has gone out. And I have no coverage for it. You can understand my agrivation. On top of all that.. come to find out the AC Delco motor that was in there before works with the same issues as the new autozone one. Motor wasnt even bad. Its probably the switches... and the extended warrantee would have covered those with a 100 dollar deductable and saved me all of this agrivation.

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Not the same problem but had something similiar. My passenger side did the classic move a couple inches at a time thing...kept putting it off until it finally died...wouldn't work with either side door switch. Installed new motor and only the passenger side switch would work, was fine before it died? Bought a new switch module for the drivers side PN 10402842, plugged it in and works fine now. Switches are a piece of cake to replace and not very expensive. I'd try that first.

  3. #3
    I Think, Therefore Z-28 Corvettekid82's Avatar
    Join Date
    Aug 2005
    Location
    Deland FL
    Posts
    390

    Triple Black
    2001 Z-28 Vert

    Yeah, thats what I ended up doing, ordered new pass and driver side window switches. Ended up being the drivers side that is bad! All fixed now!! Sad thing.. I went to go drive with the top down (its been too long because I refused to put the top down and have a window stuck up) and before I even got out of the driveway a tire blew. So, she'll be sitting there for a bit until I can get her fixed.

  4. #4
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    I can relate - didn't want to run around with my t-tops off with the passenger window up either...sorry about your tire. My car only has 24K on it and always used the drivers side switches to raise/lower the passenger side (very rarely even put it down) - somewhere in the back of my mind I suspect my drivers side switch had something to do with killing the motor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •