Results 1 to 4 of 4

Malfunction indicator light

This is a discussion on Malfunction indicator light within the General Help forums, part of the LSx Technical Help Section category; The battery died on my car a few weeks ago. The malfunction indicator light and the asr light came on ...

  1. #1
    Junior Member
    Join Date
    May 2011
    Location
    england
    Posts
    16

    navy blue
    1999 camaro

    Malfunction indicator light

    The battery died on my car a few weeks ago. The malfunction indicator light and the asr light came on when driving.

    I put on another battery (not new but good) today and it started first time no problem. It run a bit rough. I left it for five minutes running then went for a drive. Within a minute the asr light had come on. Then after about five minutes the malfunction indicator light had come on. I drive home and on the drive it run rough. I turned it off. I re-started it but it was hard to start and I had to give it some throttle to get it to start and it was still running rough with the malfunction light on. The only thing I have done is the free ram air mod and a k+n filter. Could this extra air be affecting the sensors?

    Any help is very appreciated.

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    It's normal for the PCM to have to relearn the idle after a dead battery, but shouldn't take long. Since the SES/MIL is still on you need to get the code(s) read. FRA and K&N probably isn't the issue. Don't know about England, but here in the states most auto parts stores will read codes for free.

  3. #3
    Junior Member
    Join Date
    May 2011
    Location
    england
    Posts
    16

    navy blue
    1999 camaro

    It was the EGR valve. The EGR pipework was very hot. We took the valve off and it was jammed open. We poked it with a driver and a bit of metal fell out and the valve closed. Put the valve back on, started it up, it run perfect and no warning lights!

  4. #4
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Glad to hear you got it going again.

    As for the EGR pipe, they get hot all the time as the EGR is fed by hot exhaust..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. floor center console (automatic) indicator light
    By ViperSniper in forum Parts Wanted / Trade
    Replies: 4
    Last Post: 06-16-2011, 06:32 PM
  2. Question: Oil life indicator?
    By TheJudge05 in forum GTO
    Replies: 8
    Last Post: 03-23-2010, 08:15 AM
  3. need Camaro A4 shift indicator...
    By Bad30th in forum Western Members
    Replies: 18
    Last Post: 09-13-2008, 07:14 PM
  4. Head light cover malfunction
    By chucknlv in forum Firebird / WS6
    Replies: 3
    Last Post: 06-16-2006, 06:46 PM
  5. BCM ,not VATS indicator problem
    By sic2001 in forum General Help
    Replies: 4
    Last Post: 03-03-2006, 07:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •