Page 4 of 5 FirstFirst 12345 LastLast
Results 61 to 80 of 82

MAF going bad?

This is a discussion on MAF going bad? within the General Help forums, part of the LSx Technical Help Section category; did this just start or is it something that's been going on a long time? Without cats and that cam ...

  1. #61
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    did this just start or is it something that's been going on a long time? Without cats and that cam with the 112lsa it's gonna smell like shit all the time.....nothing you can do about that. It almost looks like you have some cam surge or something going by that data sheet. Do the rpm's pulse as you're cruising holding steady state throttle?

  2. #62
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    its been going on for a month or two. Its just more noticeable now. It depends really what RPM im at when im cruising, if im under 1500 and i let off the gas itll surge but if im pretty consistent on the gas then its not bad.

  3. #63
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    I'm not there with the car in front of me and I'm just going by that sheet you posted but to me it almost looks like you need a good tune. It looks like the car is surging or something when you're just cruising. That's why I wanted to see TPS % and stuff like that....to see what state the car is in when it's surging. If you do log that stuff go out and get a little driving log just cruising and then open it up and run it through a couple gears. I did see the rich trims but i don't know what trim cell you were in or what state the car was in when it was going rich...whether it's steady throttle, accelerating, or coasting down. My gut tells me you just need a good tune though.

  4. #64
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    Is it possible that tunes go bad after awhile? Sounds kind of dumb. But i had it dynoed about a year ago

  5. #65
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    no....your tune wouldn't change. Have you changed anything other than that filter since the tune? Any other parts added like an LS6 intake or something like that?

  6. #66
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    no nothing major like that.. Just spark plugs and wires and basically thats it. I think my passanger side O2 might be bad.. I have fuel trim gauges on my phone and its reads directly from the PCM. My Long Term Fuel Trim sensor 2 gauge is constantly at +18 while idle while the other ones are around 0. And it stays around 18

  7. #67
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    Here is a picture. I sat here and watched this for about 5 minutes of idling and all the other gauages were in between -3 and +3. Except the LTFT2. Notice the LTFT1 is at 0 and stays at 0. I changed the Driver 02 a year ago but i have never changed the passenger 02 sensor and who knows if the previous owner did, I doubt it. In march it will be 2 years ive had the car. Im kind of leaning towards the passenger 02 being bad.

  8. #68
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Replace 02's as pairs. Thats always been my motto anyway, they both see the same amount of usage. They should be changed at regular service intervals. Some tuners (like Frost) suggest every 40-50,000 miles. I usually change at 60-70,000 unless one of them is giving me issues sooner, then I change them all.
    They are wear items just like spark plugs. Over time they get lazy.

  9. #69
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    it certainly wouldn't hurt to swap those sensors out......good idea really. Put a set of bosch 13111 sensors in there and call it done. If that doesn't fix you're issue it's no big deal because you're due up for them to be changed anyhow. The only time I've ever had one fail that I was able to observe was a few years ago on a buddies vette.....I was watching the O2 voltages and every now and then it would flatline at 450mv's.

  10. #70
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    welp i guess i will change out the 02's and see what happens next!

  11. #71
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I agree on swapping them out. Double check to be certain that there are no other potential air leaks upstream of the passenger side sender.

  12. #72
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    i will do that tomorrow. Hopefully, i find one lol. So i wont have to replace to O2's

  13. #73
    Import Ambassador nomolos1's Avatar
    Join Date
    Jul 2010
    Location
    Georgia
    Posts
    166

    black, black Twins
    93 Supra , 94 Supra Turbo

    If you need BNIB O2s, I have 2 Bosch #13444. I purchased them for $80 a peace. I ll let them go for $120 for both. PM me your number and I'll send you a text/picture of them.

  14. #74
    Import Ambassador nomolos1's Avatar
    Join Date
    Jul 2010
    Location
    Georgia
    Posts
    166

    black, black Twins
    93 Supra , 94 Supra Turbo

    I read through the post. I had a problem like that. So I checked the simple things first. It turns out that I had a bad plug wire that had a brake in the connection area at the plug. It would arc enough to seem fine at times. At other times it would smell like gas and skip. So I changed all the plugs and wires. That fixed the problem. That's way I have the extra O2s. I was going to install them but sold the car before I could get around to it.
    It's gotta be fast and sexy.
    93 Supra T 6spd,(1 of 197) 1K WHP build under way. Streetable!!!!!
    94 Supra Turbo(1 of 549) 600 rwhp on pump gas. 700+ rwhp on race fuel.
    http://i902.photobucket.com/albums/a...foronemore.jpg

  15. #75
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Quote Originally Posted by nomolos1 View Post
    I read through the post. I had a problem like that. So I checked the simple things first. It turns out that I had a bad plug wire that had a brake in the connection area at the plug. It would arc enough to seem fine at times. At other times it would smell like gas and skip. So I changed all the plugs and wires. That fixed the problem. That's way I have the extra O2s. I was going to install them but sold the car before I could get around to it.
    sorry....but you overpaid. 13111 and 13444 sensors can be bought on ebay for $45-$50 shipped. I would run the 13111 sensor myself ( and do) because they have the longer harness so if you get or have headers you don't need extensions. They also cured my car of throwing heater and switching codes after the header swap.

  16. #76
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by 0rion View Post
    sorry....but you overpaid. 13111 and 13444 sensors can be bought on ebay for $45-$50 shipped. I would run the 13111 sensor myself ( and do) because they have the longer harness so if you get or have headers you don't need extensions. They also cured my car of throwing heater and switching codes after the header swap.
    Agreed. It was Orion who got me onto the 13111's a few years ago and I've never looked back. They work great and also eliminated my heater code issues with the long tube headers. They are cheap to buy online if you look around, like Orion said.

  17. #77
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by Lunatikgixxer View Post
    i will do that tomorrow. Hopefully, i find one lol. So i wont have to replace to O2's
    Buy the 13111's online, for about $50 each shipped they are cheap enough, just buy a pair and be done with it. Then you'll have the longer 02's on the car for when (or if) you ever install long tube. If you don't have them already. Eliminates those pesky extension harnesses.

  18. #78
    Import Ambassador nomolos1's Avatar
    Join Date
    Jul 2010
    Location
    Georgia
    Posts
    166

    black, black Twins
    93 Supra , 94 Supra Turbo

    I guess AutoZone is not to be trusted anymore. Well, life will go on. Sorry.

  19. #79
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I remember when I went to my local Autozone for an O2. They wanted $160 for ONE. I came back home and checked online and bought a sensor from RockAuto. Denso for a little over $50.

  20. #80
    Import Ambassador nomolos1's Avatar
    Join Date
    Jul 2010
    Location
    Georgia
    Posts
    166

    black, black Twins
    93 Supra , 94 Supra Turbo

    I agree. How can we support American venders, when we get ripped off like that? I guess buy online.

Page 4 of 5 FirstFirst 12345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •