Results 1 to 2 of 2

LS1 wont fire

This is a discussion on LS1 wont fire within the General Help forums, part of the LSx Technical Help Section category; Have an LS1 Firehawk. A couple of months ago, the battery went dead. Jumped it and it ran but not ...

  1. #1
    Junior Member
    Join Date
    Apr 2008

    2002 Firehawk

    Angry LS1 wont fire

    Have an LS1 Firehawk. A couple of months ago, the battery went dead. Jumped it and it ran but not well. The alternator was not charging. I got a new battery. About 2 weeks ago, I was backing my car into the garage and my son told me something was coming out of the exhaust. I took a look and it was paper and stuff that a mouse had in there. Thought I got it all out. I attempted to take it for a drive, the Service Engine light stated flashing and it was idling bad. Put the scanner on it and it threw a misfire on cylinder 8. Cleared it, it then ran better. Few days later pulled it out of the garage and the car was running bad again. Threw codes: misfire on 3 and o2 sensor. Cleared it. Took the muffler off thinking it was clogged. Ran better a couple of times when I pulled it out of the garage. Now wont fire. Am at a loss. Any help would be very much appreciated.
    Cars is immaculate and only 19,000 miles on it. All original

  2. #2
    old timer blue02Z's Avatar
    Join Date
    Sep 2005

    Navy Blue Metallic
    2002 Z28

    hmmm... is your fuel pump running. it coulda been taken a dump and was not supplying enough fuel, hince the misfires and o2 code for running lean. i'd verify that you have fuel pressure, you can do that on the end of the fuel rails. if the fuel pump is working but no pressure, check the fuel filter. also check for spark on all plugs with a spark tester

    also welcome here!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 345hp option
    By RT KS SS in forum Camaro / SS
    Replies: 12
    Last Post: 01-26-2008, 12:19 PM
    By 1badchicken in forum Parts For Sale / Trade
    Replies: 5
    Last Post: 12-01-2006, 06:52 AM
  3. LS1 differences through the years
    By third_shift|studios in forum Firebird / WS6
    Replies: 18
    Last Post: 01-29-2006, 12:55 AM
  4. SLP "ZL402" LS1 and LS2 short block assemblies on sale!
    By tbyrne in forum Sales and Group Purchases from our Great Sponsors!
    Replies: 1
    Last Post: 10-19-2005, 06:22 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts