Results 1 to 7 of 7

ls1 swap problems

This is a discussion on ls1 swap problems within the General Help forums, part of the LSx Technical Help Section category; i have a 97 camaro was an lt1 car. bought it off a guy who swapped an ls1 into it.. ...

  1. #1
    Junior Member
    Join Date
    Feb 2011
    Location
    new jersey
    Posts
    4

    white
    97 camaro ls1

    Exclamation ls1 swap problems

    i have a 97 camaro was an lt1 car. bought it off a guy who swapped an ls1 into it.. has heads cam intake injectors high compression pistons long tube headers 3 inch exhaust built trans and suspension. the car runs really strong. very very fast. but sometimes my check engine light comes on, occasionally when it does i have only 2nd and 3rd gear. it wont go into first or overdrive. the tack dosent work when the car is running..but when i crank the car over to start it it works until the car fires up...and sometimes the car is hard to start after an hour or two of running..you crank it and if it dont fire up i have to turn the key off and try again and then it fires right up.. has a 98ls1 computer...this is my first ls1 car does anybody have an idea of what can be going on? when i plugged a scanner it said unable to read codes..the car was tuned before and ran fine until this problem started. i bought the car with this problem..any ideas?

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    What codes does it set?

  3. #3
    Junior Member
    Join Date
    Feb 2011
    Location
    new jersey
    Posts
    4

    white
    97 camaro ls1

    It wont let me pull any from the ecu. When I plug in it says unable to read

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Have you tried with a different scanner?

  5. #5
    Junior Member
    Join Date
    Feb 2011
    Location
    new jersey
    Posts
    4

    white
    97 camaro ls1

    not yet. i tried with a normal hand held. my stap father has a shop tomorrow im going to bring the car over there and hook it up to the modis and see if that will give me anything. and its weird because if it has the check engine light and i shut the car down and start it back up sometimes it clears on its own. other times it wont. and the tach works when i crank the car but stops working the moment it fires up its a factory tach..what sends the signal for the tach on these cars?
    i havent done much research yet.. just seein if anyone else had a issue like this so i can get this thing running the right way asap

  6. #6
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    is there anyone you could swap PCM's with and see if you can pull the codes off that pcm???

  7. #7
    Junior Member
    Join Date
    Feb 2011
    Location
    new jersey
    Posts
    4

    white
    97 camaro ls1

    i can try but i dont know how well the car will run without the tune. its got a big cam in it high compression pistons and injectors as well. so i know without the tune its going to be extremely lean i dont want to do any damage to it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 93 rx7 ls1 swap! Idiling and shut off problems
    By Jere0213 in forum LSx Retrofit and Swap
    Replies: 1
    Last Post: 01-11-2014, 05:08 PM
  2. Replies: 2
    Last Post: 01-26-2012, 03:16 PM
  3. cam swap problems
    By Lando99T/A in forum Firebird / WS6
    Replies: 3
    Last Post: 09-03-2010, 06:20 PM
  4. Two problems after my H/C/I Swap
    By ls1camino in forum Internal Engine
    Replies: 17
    Last Post: 06-01-2009, 09:53 AM
  5. Engine swap tranny problems
    By 94suburban in forum Automatic Transmission
    Replies: 0
    Last Post: 05-22-2006, 02:08 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •