Page 2 of 2 FirstFirst 12
Results 21 to 25 of 25

Ls1 running bad..HELP

This is a discussion on Ls1 running bad..HELP within the General Help forums, part of the LSx Technical Help Section category; Originally Posted by 0rion unless he gets lucky it's tough to find them cheaper than on ebay...even after shipping. By ...

  1. #21
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by 0rion View Post
    unless he gets lucky it's tough to find them cheaper than on ebay...even after shipping.

    By all means check a parts store but mine were ~$75 a piece when I bought mine. These are $51 shipped.
    Bosch 13111
    These will work with stock manifolds or only LT headers? Thanks.

  2. #22
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by JayTA98 View Post
    These will work with stock manifolds or only LT headers? Thanks.
    They will work with both but there is no need for 13111 with stock manifolds. The harness is just WAY too long and a stock replacement O2 sensor would better suited a stock manifold

  3. #23
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    if you plan on headers down the road though I would get the 13111 sensors and just zip the extra harness up out of the way.

  4. #24
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by 0rion View Post
    if you plan on headers down the road though I would get the 13111 sensors and just zip the extra harness up out of the way.
    Quote Originally Posted by Cutlass View Post
    They will work with both but there is no need for 13111 with stock manifolds. The harness is just WAY too long and a stock replacement O2 sensor would better suited a stock manifold
    Thanks guys. I'm planning to do headers in the future.

  5. #25
    Junior Member Nates98ta's Avatar
    Join Date
    May 2010
    Location
    Mtn. Grove, MO
    Posts
    25

    Marina Blue
    1998 Pontiac Trans am

    ok, im ordering the o2's but I never could find the Bosch 13111, the only upstream ones they are showing for my car are 15732,13029 and 13444.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Running rough if running at all help
    By ichliebecamaro in forum LT1
    Replies: 3
    Last Post: 01-25-2010, 11:54 AM
  2. Car is Running
    By Ed Blown Vert in forum Almost Anything Goes
    Replies: 106
    Last Post: 11-11-2009, 02:21 PM
  3. Question: running 12`s
    By SSMOKEshow in forum Drag Racing
    Replies: 41
    Last Post: 03-15-2008, 06:42 AM
  4. Got The Car Running Again But
    By theslow00 in forum Western Members
    Replies: 8
    Last Post: 03-05-2008, 01:08 PM
  5. Need help, car not running right?
    By blackSS01 in forum General Help
    Replies: 5
    Last Post: 10-15-2006, 09:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •