Results 1 to 2 of 2

LS1 Lighting problem??? Help!!

This is a discussion on LS1 Lighting problem??? Help!! within the General Help forums, part of the LSx Technical Help Section category; My brother has a 98 Z28, and for some reason his lights flicker by getting dim then to their normal ...

  1. #1
    Member Blue_01_Z28's Avatar
    Join Date
    Mar 2008
    Location
    Midland, TX
    Posts
    349

    Metallic Blue
    2001 Chevrolet Camaro Z28

    LS1 Lighting problem??? Help!!

    My brother has a 98 Z28, and for some reason his lights flicker by getting dim then to their normal brightness. What could be causing this? His head lights and dash lights do it, and I noticed the Alternator/Batt guage bounces around too. Has anyone had this problem or know how to fix it? Thanks

  2. #2
    Member ultra_badass's Avatar
    Join Date
    Mar 2007
    Location
    Corpus Christi
    Posts
    257

    navy blue matallic
    2000 WS6 trans am M6

    i would have to say it may be a possible ground problem...or a losse connection on the batt itself

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lighting?
    By 2kbluws6 in forum Firebird / WS6
    Replies: 7
    Last Post: 08-29-2008, 12:39 PM
  2. lighting problem
    By bmwmteam in forum General Help
    Replies: 2
    Last Post: 09-04-2007, 08:10 PM
  3. Lighting
    By bigdom10 in forum Firebird / WS6
    Replies: 3
    Last Post: 08-15-2007, 12:30 PM
  4. lt1 Lighting
    By zbizkit in forum Appearance Section
    Replies: 1
    Last Post: 02-21-2007, 08:20 AM
  5. lighting problem
    By badazta in forum General Help
    Replies: 1
    Last Post: 10-01-2006, 06:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •