Results 1 to 9 of 9

Low Oil light won't go off

This is a discussion on Low Oil light won't go off within the General Help forums, part of the LSx Technical Help Section category; It was low in oil, I filled it up, and the oil light won't go off now. Do I need ...

  1. #1
    Evr sena bdgr killa snak? Roastem's Avatar
    Join Date
    Dec 2005
    Location
    Research Triangle Park, NC
    Age
    38
    Posts
    1,812

    Pewter
    '99 Z28 M6

    Low Oil light won't go off

    It was low in oil, I filled it up, and the oil light won't go off now. Do I need to disconnect the battery or something?
    Heads 'n Cammed, Moser 12, 3.73's, Weight Reduction, 13" Brembo Kit
    BMR track suspension, full exhaust, the works...
    412whp/394wtq 1/4 mile slip coming soon!
    Gone: '01 Laser Red Cobra 3.73's/Full Bolt-ons

  2. #2
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    35
    Posts
    914

    Quick Silver
    2002 Z06

    Any experience I have with those lights tells me no.. It should just go right off. It is possible there is some cycle or something you have to do before the computer resets them but i've never heard of that. I have never had my light go on personally though. Unplugging the battery a bit and letting the power run out may fix it. Are you sure you were low on oil? The sensor could just be bad and is stuck on.

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    After filling to the proper level the light should turn itself off after the PCM sees 194 degrees, and the ignition remains off for a minimum of 1 hour, then it checks it on startup. How low was it? Always wondered how low it has to get before it illuminates.

  4. #4
    Evr sena bdgr killa snak? Roastem's Avatar
    Join Date
    Dec 2005
    Location
    Research Triangle Park, NC
    Age
    38
    Posts
    1,812

    Pewter
    '99 Z28 M6

    It was two quarts! I just changed the oil about two months ago, but I drive the crap out of it too.

  5. #5
    Awaiting Activation NeeD4SpeeD's Avatar
    Join Date
    Sep 2005
    Location
    New York, NY
    Posts
    1,720

    Collectors Edition Yellow
    2002 Pontiac Trans AM WS6

    Quote Originally Posted by Roastem
    It was two quarts! I just changed the oil about two months ago, but I drive the crap out of it too.
    Well that will explain it.... The harder you push the internals the more friction there is causing heat and evaporation..... Which grade oil do you use...5w 30??? Remember the thinner the oil the less of a lifespand it will have but remember that if you go thicker in winter when it is very cold that thick oil will be sludge...

  6. #6
    Evr sena bdgr killa snak? Roastem's Avatar
    Join Date
    Dec 2005
    Location
    Research Triangle Park, NC
    Age
    38
    Posts
    1,812

    Pewter
    '99 Z28 M6

    It went off later that afternoon by itself. I thought after a couple startups it would have went off, that's why I was a little worried. Apparently, it just had to think about it a little.

  7. #7
    lee1rbc
    Guest
    2 qts in 2 months. Would converting to a LS6 pcv sys. help?

  8. #8
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    33
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    2 quarts in two months sounds bad, but he said he drives the heck out of it. We have low tension rings and when you drive it hard it should use some oil, it contributes to engine life. you should drive it soft for a while and check it to see if it's consuming oil, if it is then you have a problem, but depending on just how hard you drive it can use a substantial amount of oil

  9. #9
    Senior Member 02z28ls1's Avatar
    Join Date
    Sep 2005
    Location
    near St. Louis
    Posts
    1,205

    navy blue
    2002 Z-28 Camaro M6

    2 months = how many miles.Start writing this stuff down and it will make alot more sense.Some people put 2,000 miles a month on their cars and think nothing of it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. *** Choo Choo TRAIN ***
    By Ed Blown Vert in forum AAG Archives
    Replies: 14042
    Last Post: 01-31-2006, 09:44 PM
  2. Oil runs low before oil change is close to do
    By hatws6 in forum General Help
    Replies: 6
    Last Post: 12-06-2005, 10:50 AM
  3. Low Oil Light?
    By Cerwin Vega Fan in forum LT1
    Replies: 2
    Last Post: 10-11-2005, 11:48 AM
  4. Low coolant light
    By fredg369 in forum LT1
    Replies: 3
    Last Post: 09-29-2005, 05:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •