Results 1 to 16 of 16

Low Oil Light & Springs Questions

This is a discussion on Low Oil Light & Springs Questions within the General Help forums, part of the LSx Technical Help Section category; Q1) Low Oil Light - mine comes on every once in a while. I go and check on level ground ...

  1. #1
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Low Oil Light & Springs Questions

    Q1) Low Oil Light - mine comes on every once in a while. I go and check on level ground and dip stick shows within proper levels. Oil Pressure is always between 40 - 60 on gauge. Before you ask I have a 98' and it is a brand new oil pressure sender. I see no leaks on drive way, no smoke from pipes, or signs of a head gasket leak. I did have a few PCV line leaks that where fixed last week, but again no oil leaks. The drive way is on a 25 to 30 degree incline. My fear is oil pump is going to go soon? Or is it because of the incline?



    Q2) Rear springs - (part 1) how do you know when these need to be replaced? I have new OEM shocks and I still bottom out, by this I don't just mean ORY rub on the road, I mean I feel my axle hits hard against the body.
    Are these that weak?


    (part 2) I know that the Jounce Bumper stops are long gone. But to me it seems that it is just too far of a distance for the axle travel and hit like that when there are shocks and springs there. I plan on getting 17" wheels and already have the 17" wheel extenders, just need to order the Jounce stops. Does these stops really keep the axle that far away?

  2. #2
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Well...my GTO sits on an incline as well. Maybe a soft 40 degree incline. My low oil light never comes on. So my guess is the pump may be on the way out. Is it the factory unit in your car?

    As for the rear springs, there are multiple variables i.e. staggered/larger wheels, rearend work(adj. panhard bar, torque arm, etc) but if the car has high miles, then I would look into replacing the rear springs to maybe level the car or give the car a menacing raked look.

  3. #3
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Also, didn't the 4th gens come with an oil level sensor? That could be going out.

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by cammed goat View Post
    Well...my GTO sits on an incline as well. Maybe a soft 40 degree incline. My low oil light never comes on. So my guess is the pump may be on the way out. Is it the factory unit in your car?

    As for the rear springs, there are multiple variables i.e. staggered/larger wheels, rearend work(adj. panhard bar, torque arm, etc) but if the car has high miles, then I would look into replacing the rear springs to maybe level the car or give the car a menacing raked look.
    Yes it is the infamous 98 LS1 oil Pump.



    Quote Originally Posted by cammed goat View Post
    Also, didn't the 4th gens come with an oil level sensor? That could be going out.
    Not sure?

  5. #5
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Yah. Cant remember either. I think it bolted into the side of the oil pan.

  6. #6
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Then I think I got one. If I'm right it is on the passenger side of the pan and the clip is a PITA to get off because it has a casing around it. You need a very short flat head to get it to come off.

  7. #7
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Then that could be on the way out if it has never been replaced.

  8. #8
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    now if I get new springs I see that most lower then an 1 to 1.5" Will that effect 17" wheels? not sure if I really want to lower...

  9. #9
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Not lower...lift the rear.

  10. #10
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    I would like that. Give it some attitude. What springs would you recommend?

  11. #11
    Join the PHK @ thephk.org Sommer86@6LE's Avatar
    Join Date
    Nov 2007
    Location
    Studio City, CA
    Posts
    1,054

    Red
    2001 Camaro SS

    Quote Originally Posted by SMWS6TA View Post
    Then I think I got one. If I'm right it is on the passenger side of the pan and the clip is a PITA to get off because it has a casing around it. You need a very short flat head to get it to come off.
    Correct.

    It's on the side of the oil pan. I just replaced mine and it cost about $23 from GM. My oil level light was staying on all the time (and I think i'm hearing lifter tick) so i thought I might need a thicker oil after 96K miles. I bumped up to 10W-40 and the light stayed on even when full. I then swapped the oil level sensor and it STILL stayed on. I then started noticing that if my car was parked on a decline at work that when I started it the light would NOT go on. Id park my car level, then start it and move to the decline and shut it off, then immediately start it again. It would somehhow trigger the light to go off. After that, the light stopped coming on....until last night when I was getting ready to go home, lol. But now I think I'm actually low.....or getting close.....since the light wasn't on this morn on the way to work.

    Join the PHK
    2009 LS1.com Calendar Car

  12. #12
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    I'm starting to think that our engines consume oil when they get into the higher miles. Mines got 129k on it as of lunch. I went to parts store and grab some oil. Yeah I was low, but this is like one time out of 20.

  13. #13
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by Sommer86@6LE View Post
    Correct.

    It's on the side of the oil pan. I just replaced mine and it cost about $23 from GM. My oil level light was staying on all the time (and I think i'm hearing lifter tick) so i thought I might need a thicker oil after 96K miles. I bumped up to 10W-40 and the light stayed on even when full. I then swapped the oil level sensor and it STILL stayed on. I then started noticing that if my car was parked on a decline at work that when I started it the light would NOT go on. Id park my car level, then start it and move to the decline and shut it off, then immediately start it again. It would somehhow trigger the light to go off. After that, the light stopped coming on....until last night when I was getting ready to go home, lol. But now I think I'm actually low.....or getting close.....since the light wasn't on this morn on the way to work.

    Are you with 6LE Designs?

  14. #14
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Yup. I checked mine and I am low. I have 81k on mine but I think my rear main seal might be on its way out.

  15. #15
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by cammed goat View Post
    Yup. I checked mine and I am low. I have 81k on mine but I think my rear main seal might be on its way out.
    Rear main in mine I know is good. Just checked it a few weeks ago while installing new bell housing. that was the first thing I checked when it was off.

  16. #16
    Join the PHK @ thephk.org Sommer86@6LE's Avatar
    Join Date
    Nov 2007
    Location
    Studio City, CA
    Posts
    1,054

    Red
    2001 Camaro SS

    Quote Originally Posted by SMWS6TA View Post
    Are you with 6LE Designs?
    I sure am!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3rd brake light: fitment questions
    By knightryda01 in forum General Help
    Replies: 1
    Last Post: 07-26-2011, 06:52 PM
  2. Tail Light, Head Light Lens Cleanup, Body Work Questions
    By MAXX2 in forum Appearance Section
    Replies: 3
    Last Post: 12-15-2010, 09:15 AM
  3. two light questions ...
    By tep98ws6 in forum Appearance Section
    Replies: 7
    Last Post: 10-18-2009, 10:26 PM
  4. LS1 parts cheap- hypertech, ss brake light, springs
    By sscamaro1384 in forum Parts For Sale / Trade
    Replies: 3
    Last Post: 06-02-2007, 04:28 PM
  5. SES Light...Code Delete...Have Questions?
    By HiLL99SS in forum Computer & Tuning
    Replies: 1
    Last Post: 10-19-2005, 04:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •