Results 1 to 8 of 8

Loose steering after header install?

This is a discussion on Loose steering after header install? within the General Help forums, part of the LSx Technical Help Section category; My steering has a wee bit of play or slop it in since I did my header install.. The stealership ...

  1. #1
    Junior Member
    Join Date
    Aug 2005
    Location
    Florence, AL
    Age
    37
    Posts
    9

    Loose steering after header install?

    My steering has a wee bit of play or slop it in since I did my header install.. The stealership says it's a toasted rack and pinion, however, it only started after the header install when I took the steering shaft off to allow for the header to slip in..

    Is there a way to tighten this back up?

  2. #2
    "Lucky" Luciano
    Join Date
    Aug 2005
    Location
    Northampton, PA
    Age
    56
    Posts
    46
    Try removing the shaft and reinstalling it. That worked for me.

  3. #3
    The Immortal Wulfe13's Avatar
    Join Date
    Aug 2005
    Location
    St. Louis, MO.
    Age
    44
    Posts
    912

    Cayenne Red Metallic
    98 Pontiac Trans Am WS7

    Hmmmm..... I never messed with the steering shaft when I did my headers.... either time.... LT's first time and Mac Mids the 2nd time....

  4. #4
    Junior Member
    Join Date
    Aug 2005
    Location
    Florence, AL
    Age
    37
    Posts
    9
    Yeh, I need to try and reinstall the shaft.. I must be doing something wrong...

    Wulfe13, yeh, mine had to be removed, or so I thought.

  5. #5
    Junior Member
    Join Date
    Aug 2005
    Location
    Florence, AL
    Age
    37
    Posts
    9
    Blackdog - was there any special trick to removing the shaft? It's been a while since I did my headers and I just tried to get the beast off and can't..

  6. #6
    don't hate MysticBowtie's Avatar
    Join Date
    May 2006
    Location
    Plano
    Age
    36
    Posts
    57

    "bone stock....."
    1994 Camaro Z28

    It helps to drop the steering wheel inside the car. Just pull the part of the dash that is under the steering wheel and there should be two bolts that hold it up. That'll give you a lot more play in the engine copartment.

  7. #7
    Member keliente's Avatar
    Join Date
    Aug 2005
    Location
    Charlotte, NC
    Age
    31
    Posts
    723
    99 Firebird Formula

    It's just the shaft. Your dealership is retarded. Remove and re-install it tightly.

  8. #8
    Member Pete Rock98's Avatar
    Join Date
    Aug 2005
    Location
    Bronx NY
    Age
    46
    Posts
    177

    Black
    1998 z28

    When I installed my Qtp headers the drivers side header was rubbing the steering linkage,check too see if this is the problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •