Results 1 to 5 of 5

A little help from my friends

This is a discussion on A little help from my friends within the General Help forums, part of the LSx Technical Help Section category; Okay guys I know that this may seem to be a really dumb question but I am looking for better ...

  1. #1
    Junior Member
    Join Date
    Sep 2008
    Location
    Columbiana, Ohio
    Posts
    22

    Used to be dark green
    Used to be 96 Firebird

    A little help from my friends

    Okay guys I know that this may seem to be a really dumb question but I am looking for better answers than yahoo is giving me. Okay my girlfriends car wont start up, at first we thought it was the battery because it is a pretty old battery. We got a new battery, cleaned off the terminals, and jumped the car. It ran for a while then we turned it off and tried turning it back on. Nothing. Its not even trying to turn over, there is just a single click. The car will only start if we jump it. Would this be a bad starter. I would like to know before she go dropping $150 on something not needed.

  2. #2
    Member
    Join Date
    Feb 2008
    Location
    NEW JERSEY
    Posts
    814

    PEWTER
    2001 TRANS AM WS6

    I would pull the starter and have it tested it might be a silonoid

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    If you bought a new battery you shouldn't have to jump start the car if that was the problem. What's the battery voltage?

  4. #4
    Member
    Join Date
    Mar 2007
    Location
    NC
    Posts
    421

    NBM
    1998Z28

    Probally a bad Alternator not charging the battery while the cars running or you've got a bad connection between the battery and the starter.
    TSP 347 SB, TSP Stage 2.5 PRC LS6, TSP MS4, Performabuilt Stage 2 4L60E, Yank PT4000, 4.11s, Fast 90/90, FTRA Cold air intake+all the free mods, Dynatech Supermaxx Exaust System, DMH Cutouts, Hooker Catback/FTRA Tips. Tuned by RPM/Garner NC. 11.28@119

  5. #5
    Junior Member
    Join Date
    Sep 2008
    Location
    Columbiana, Ohio
    Posts
    22

    Used to be dark green
    Used to be 96 Firebird

    Well I got some time to look at the problem a little bit more, and it was a bad connection between the battery and starter. Thanks for your input

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Friends working for friends.... high bids
    By knightryda01 in forum Almost Anything Goes
    Replies: 8
    Last Post: 06-15-2014, 08:33 AM
  2. My friends mom's T/A
    By cobrakiller99 in forum Firebird / WS6
    Replies: 21
    Last Post: 12-10-2008, 03:28 PM
  3. hello car friends
    By lt1steve in forum New Member Introductions
    Replies: 3
    Last Post: 09-01-2008, 05:04 PM
  4. Friends
    By superchargedblackgto in forum Almost Anything Goes
    Replies: 27
    Last Post: 08-20-2008, 04:30 PM
  5. Hello new friends!
    By nomorefords in forum New Member Introductions
    Replies: 3
    Last Post: 04-05-2007, 08:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •