Results 1 to 4 of 4

little help here please

This is a discussion on little help here please within the General Help forums, part of the LSx Technical Help Section category; I am having a problem with the charging system on my 99 vert. The car charges fine as long as ...

  1. #1
    retired racer not 4 long chevy1966's Avatar
    Join Date
    Sep 2006

    red white
    1999 z28 vert 1998 z28 ht

    little help here please

    I am having a problem with the charging system on my 99 vert. The car charges fine as long as the a/c is not on, but when you switch the a/c on, the voltage drops consideribly. The a/c works excellent, no squeals, and blow ice cold. The only problem is the voltage drop, if you leave it on for a very long time, it will diminish battery power. Any suggestions is greatly appreciated.

  2. #2
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Roseville, CA

    05 Wrangler
    00 Z28 sold :-(

    Have you verified any of this with a multimeter? The gauge will naturally drop as you run more accessories...especially with the a/c. When you turn the a/c on not only does it engage the compressor clutch but it also turns the high speed fan on...along with everything else on that's a good load.

    If it is actually draining the batt then you might want to check out the alternator...or the batt cables for corrosion.

  3. #3
    Senior Member ss~zoso~ss's Avatar
    Join Date
    Dec 2004

    SS: NBM, tan top
    1998-SS, 2010 Jetta TDI

    your alternator is going i'd say with 95% certainty

  4. #4
    Senior Member
    Join Date
    Jul 2005
    Jacksonville, FL
    I'd bring the battery in somewhere for a free load test too - if for no other reason just to eliminate it as the problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts