Results 1 to 8 of 8

light problem please help!

This is a discussion on light problem please help! within the General Help forums, part of the LSx Technical Help Section category; I have a 98 trans am and none of my guage lights or air conditioner backlights are working when i ...

  1. #1
    Junior Member 98silver t/a's Avatar
    Join Date
    Feb 2008
    Location
    San Antonio Tx
    Age
    27
    Posts
    12

    Silver
    1998 Trans Am

    Unhappy light problem please help!

    I have a 98 trans am and none of my guage lights or air conditioner backlights are working when i turn on my headlights. the fog lights arent working either. I checked the fuse in the interior fuse box and its ok. is there another one somewhere else? or a relay or something that turns all that stuff on? the headlights are still working just not all the other lights. But when i unlock my car with my alarm the guage lights and fogs still work, they just dont turn on with the light knob anymore. any help would be much appreciated
    Last edited by 98silver t/a; 08-16-2008 at 08:56 PM.

  2. #2
    Member WS-6's Avatar
    Join Date
    Feb 2008
    Location
    NW Indiana
    Posts
    418

    Pewter
    2000 T/A WS-6

    Quote Originally Posted by 98silver t/a View Post
    I have a 98 trans am and none of my guage lights or air conditioner backlights are working when i turn on my headlights. the fog lights arent working either. I checked the fuse in the interior fuse box and its ok. is there another one somewhere else? or a relay or something that turns all that stuff on? the headlights are still working just not all the other lights. But when i unlock my car with my alarm the guage lights and fogs still work, they just dont turn on with the light knob anymore. any help would be much appreciated
    Fog lights have a relay under the hood but it sounds like you have a bad switch. When you press the button on the key fob the security module sends power to the the lights (obviously) with out the switch being turned on and off. That is my two cents, good luck.

  3. #3
    Junior Member 98silver t/a's Avatar
    Join Date
    Feb 2008
    Location
    San Antonio Tx
    Age
    27
    Posts
    12

    Silver
    1998 Trans Am

    thanks for the help, but could the switch be broken and still work for the headlights?

  4. #4
    Member WS-6's Avatar
    Join Date
    Feb 2008
    Location
    NW Indiana
    Posts
    418

    Pewter
    2000 T/A WS-6

    Quote Originally Posted by 98silver t/a View Post
    thanks for the help, but could the switch be broken and still work for the headlights?
    Yes, because there are two contacts inside the switch one for parks an one for headlights. You can get a nice used one on ebay for 15 shipped, maybe some one on here has one for sale as well.

  5. #5
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    +1 for: Headlight switch is probably bad...

  6. #6
    Junior Member 98silver t/a's Avatar
    Join Date
    Feb 2008
    Location
    San Antonio Tx
    Age
    27
    Posts
    12

    Silver
    1998 Trans Am

    ok thanks for the help guys I'll find one on ebay and give it a try

  7. #7
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    Pull the switch and jumper to the interior lamps. Do the side marker and tail lights work?

  8. #8
    Member edbird's Avatar
    Join Date
    Apr 2006
    Location
    hammond Ind
    Posts
    270

    red
    1999 trans am convert

    Could be a bad dimmer switch!Could be it got bumped all the way off?Check before buying parts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. light problem
    By b&dsta in forum General Help
    Replies: 8
    Last Post: 02-06-2009, 11:04 PM
  2. SES light and problem
    By insane4fbodys in forum General Help
    Replies: 2
    Last Post: 12-08-2007, 09:27 PM
  3. Coolant light problem
    By cobrahunter in forum External Engine
    Replies: 3
    Last Post: 08-06-2007, 12:51 AM
  4. interior light problem
    By u69038 in forum Stereo and Electronics
    Replies: 2
    Last Post: 06-15-2007, 07:36 PM
  5. SES Light Problem
    By DiPeRRi 99 in forum Computer & Tuning
    Replies: 16
    Last Post: 07-25-2006, 02:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •