Results 1 to 11 of 11

Left blinker

This is a discussion on Left blinker within the General Help forums, part of the LSx Technical Help Section category; i need help i dont know whats wrong with my left blinker. all the lights works but when ever i ...

  1. #1
    Member whiteLS1TA's Avatar
    Join Date
    May 2007
    Location
    California
    Posts
    399

    Artic white
    2001 Trans am

    Left blinker

    i need help i dont know whats wrong with my left blinker. all the lights works but when ever i hit the left blinker the front doesnt work but the back does, but the thing is it blinks hella slow sometimes it might even just stay lit and not blink at all. what should i do?

  2. #2
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by whiteLS1TA View Post
    i need help i dont know whats wrong with my left blinker. all the lights works but when ever i hit the left blinker the front doesnt work but the back does, but the thing is it blinks hella slow sometimes it might even just stay lit and not blink at all. what should i do?

    change the bulb

  3. #3
    Double Tap Heartbreak1's Avatar
    Join Date
    Oct 2006
    Location
    Castle Rock, CO
    Age
    27
    Posts
    1,616

    Montego Blue
    '07 BMW 328Xi Coupe

    check the blinker fluid.

  4. #4
    Member whiteLS1TA's Avatar
    Join Date
    May 2007
    Location
    California
    Posts
    399

    Artic white
    2001 Trans am

    Quote Originally Posted by Heartbreak1 View Post
    check the blinker fluid.
    haha yea i just picked some up. lol it was low

  5. #5
    Member
    Join Date
    Oct 2006
    Location
    Florida
    Age
    42
    Posts
    262

    Navy Blue Metallic
    2002 Trans Am WS6

    Quote Originally Posted by Heartbreak1 View Post
    check the blinker fluid.
    SOB! You stole my line! LMAO

  6. #6
    Member 02WS6dream's Avatar
    Join Date
    Jun 2006
    Location
    Charlotte, NC
    Age
    34
    Posts
    668

    08 Mustang GT/CS Blue
    2002 Trans Am WS6 traded

    looks in your avatar that neither one of your running lights are on...is that intentional? If not i bet i know why your signal is acting funny...

  7. #7
    SlamminGears
    Join Date
    Apr 2007
    Location
    Tennessee
    Age
    38
    Posts
    39

    Black
    01 TransAm WS6

    Yea just change the bulb. My left front goes out pretty frequently. I think its a water problem for mine.

  8. #8
    Member 02WS6dream's Avatar
    Join Date
    Jun 2006
    Location
    Charlotte, NC
    Age
    34
    Posts
    668

    08 Mustang GT/CS Blue
    2002 Trans Am WS6 traded

    if that's the case, the bulb isn't burning out-just not able to make contact through the corrosion caused by the water. Clean the socket if salvageable and seal your housing if possible or buy new one.

  9. #9
    SlamminGears
    Join Date
    Apr 2007
    Location
    Tennessee
    Age
    38
    Posts
    39

    Black
    01 TransAm WS6

    thanks for the info. I'll check it out

  10. #10
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    another vote for a corroded socket. Make sure to find the source of the moisture and seal it up or you'll be doing this again at some point. Just look at the socket and see if it's corroded or if there's any sign that moisture is getting to it.

  11. #11
    SlamminGears
    Join Date
    Apr 2007
    Location
    Tennessee
    Age
    38
    Posts
    39

    Black
    01 TransAm WS6

    Its getting in through the lens. I'm getting ready to seal it up. thanks again for ya'lls help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: blinker?
    By reaper ws6 in forum General Help
    Replies: 7
    Last Post: 04-01-2011, 10:44 PM
  2. GM Blinker
    By travs98ls1 in forum Almost Anything Goes
    Replies: 7
    Last Post: 05-13-2010, 06:50 PM
  3. Did the blinker mod
    By blindxeyed in forum Appearance Section
    Replies: 13
    Last Post: 01-25-2009, 06:31 PM
  4. Blinker
    By tingo99 in forum General Help
    Replies: 9
    Last Post: 06-13-2008, 12:21 AM
  5. left front blinker bulb
    By myss in forum General Help
    Replies: 10
    Last Post: 02-28-2006, 11:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •