Results 1 to 8 of 8

led light problems

This is a discussion on led light problems within the General Help forums, part of the LSx Technical Help Section category; need help I cant figure out why when I install led bulbs for my tail lights when I turn on ...

  1. #1
    Junior Member
    Join Date
    Mar 2014
    Location
    vallejo
    Posts
    34

    black
    1998 ws6 trans am

    led light problems

    need help I cant figure out why when I install led bulbs for my tail lights when I turn on the turn signals or press on the brake my headlights open I replace the two flashers with a bigger one and it still does it they only work fine if I turn on the headlights everything works fine but when the headlights are off I press on the break or turn on a turn signal headlights pop open and close with the turn signal motion

  2. #2
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    The leds you are using might not have resistors in them and not drawing enough current causing the body control module to go haywire. Are the leds you're using the "error free" ones?

  3. #3
    Member
    Join Date
    Aug 2005
    Location
    Pocono Mtns, PA
    Age
    62
    Posts
    103

    White
    '02 Camaro SS

    LED lights are diodes and need to observe electrical polarity.

  4. #4
    Junior Member
    Join Date
    Mar 2014
    Location
    vallejo
    Posts
    34

    black
    1998 ws6 trans am

    Quote Originally Posted by cammed goat View Post
    The leds you are using might not have resistors in them and not drawing enough current causing the body control module to go haywire. Are the leds you're using the "error free" ones?
    im not sure I bought them at autozone so are there error free ones?is there any way to fix the current going to them

  5. #5
    Junior Member
    Join Date
    Feb 2015
    Location
    Richard
    Posts
    3
    Be care of the electrical

  6. #6
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    If I recall, error free LEDs have a circuit board soldered into them and will not cause any electrical issues. Do your turn signals flash quickly?

  7. #7
    Member RONS98TA's Avatar
    Join Date
    Jan 2009
    Location
    MARYLAND
    Age
    44
    Posts
    803

    BLACK
    1998 PONTIAC TA

    Not sure if this is your problem, but try rotating the bulb 180 degrees, then placing it back in the socket. Couldn't hurt. If that doesn't work, I would pull all of them out except 1 bulb, and retry the turn signal. If everything works as it should, then replace 1 bulb at a time and retest. If the problem pops back up, then rotate the last inserted bulb 180 degrees again. I replaced the tail light bulbs on my 2009 cobalt with LED bulbs from Walmart and had an issue where the bulb wouldn't even work. Rotating the bulb fixed my problem.
    Last edited by RONS98TA; 02-14-2015 at 06:14 AM.

  8. #8
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I did some reading as I had a turn signal blow out and was considering swapping in LEDs and read either a resistor had to be soldered into the wiring or installing an electronic signal flasher to correct "hyper flashing" issues. I don't know if this applies to fourth-gen F-bodies, however.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: tail light problems!
    By Mickyboyd in forum General Help
    Replies: 3
    Last Post: 02-05-2015, 12:16 PM
  2. Fog Light Moisture Problems
    By stockwellsm in forum Stereo and Electronics
    Replies: 0
    Last Post: 05-16-2008, 10:45 PM
  3. light problems on 99 z28
    By Z28onTHErun in forum Stereo and Electronics
    Replies: 7
    Last Post: 04-04-2008, 08:57 AM
  4. xenon light problems?
    By scorpiansniper in forum General Help
    Replies: 1
    Last Post: 06-05-2007, 05:09 PM
  5. Warning Light Problems
    By skeeter5386 in forum General Help
    Replies: 1
    Last Post: 03-14-2007, 12:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •