Results 1 to 7 of 7

leaking antifreeze, answer not found in search..help

This is a discussion on leaking antifreeze, answer not found in search..help within the General Help forums, part of the LSx Technical Help Section category; I'm having a problem with a leaking waterpump. This is a 2002 Z28 with 134,000 miles. I did some searching ...

  1. #1
    Junior Member
    Join Date
    Nov 2010
    Location
    O'fallon, IL
    Posts
    10

    pewter
    2002 Camaro Z28

    leaking antifreeze, answer not found in search..help

    I'm having a problem with a leaking waterpump. This is a 2002 Z28 with 134,000 miles. I did some searching on here, and found a few common things people talk about.

    A. could be weep hole leaking

    B. could be seal leaking

    C. could be gasket leaking

    MY QUESTIONS:

    1. I know what the gasket is, but when people say "the seal" are they in fact talking about the gasket or is it something totally different? (are the gasket and seal the same thing?)

    2. Can anyone post a pic of this "weep hole" and/or tell exactly where it is? All I can tell by looking is that the water pump is leaking at the bottom.

    3. If it's coming out of the weep hole, does that mean a new water pump is what's required to fix it?

    I figured it was the gasket, but everyone keeps talking about this "weep hole"

    Thanks in advance for all the help, Cory

  2. #2
    Junior Member
    Join Date
    Dec 2011
    Location
    mi
    Posts
    1

    black
    95 camaro

    Just replace water pump

  3. #3
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Most every belt driven water pump has both seals and gaskets..

    The seals are around the prop shaft and keep anti-freeze from leaking along the prop shaft.

    When those go bad coolant will leak from the pump body weep hole indicating a bad water pump.

    If the gasket is bad, coolant can leak from between the pump body and it's mateing surface on the engine.

    If the gasket ONLY is what is leaking you can usually replace it with a new gasket and reuse the pump.
    Last edited by Smittro; 01-08-2012 at 12:00 PM.
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  4. #4
    Junior Member
    Join Date
    Nov 2010
    Location
    O'fallon, IL
    Posts
    10

    pewter
    2002 Camaro Z28

    Quote Originally Posted by Smittro View Post
    Most every belt driven water pump has both seals and gaskets..

    The seals are around the prop shaft and keep anti-freeze from leaking along the prop shaft.

    When those go bad coolant will leak from the pump body weep hole indicating a bad water pump.

    If the gasket is bad, coolant can leak from between the pump body and it's mateing surface on the engine.

    If the gasket ONLY is what is leaking you can usually replace it with a new gasket and reuse the pump.
    Thanks, that helps quite a bit actually.

    I guess my remaining question is.....where exactly is this weep hole?

    It LOOKS like it might just be leaking out from the bottom of the pump at the gasket, however I'm not sure and I don't even know where this weep hole is. If by some chance it was just the gasket, I would be thrilled. I don't have much extra $ for a new water pump.

  5. #5
    Junior Member
    Join Date
    Nov 2010
    Location
    O'fallon, IL
    Posts
    10

    pewter
    2002 Camaro Z28

    Quote Originally Posted by Smittro View Post
    Most every belt driven water pump has both seals and gaskets..

    The seals are around the prop shaft and keep anti-freeze from leaking along the prop shaft.

    When those go bad coolant will leak from the pump body weep hole indicating a bad water pump.

    If the gasket is bad, coolant can leak from between the pump body and it's mateing surface on the engine.

    If the gasket ONLY is what is leaking you can usually replace it with a new gasket and reuse the pump.
    Thanks, that helps quite a bit actually.

    I guess my remaining question is.....where exactly is this weep hole?

    It LOOKS like it might just be leaking out from the bottom of the pump at the gasket, however I'm not sure and I don't even know where this weep hole is. If by some chance it was just the gasket, I would be thrilled. I don't have much extra $ for a new water pump.

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    It sounds like the pump simply needs replaced. If you are not sure where it is leaking from and just have to know, rinse off the front of the engine and blow it dry before starting the car and watching for the leak. Unfortunately, the air moving through the engine compartment as you drive the car and/or from the fans running will blow leaking fluid all over the place and often makes it difficult to locate the source. After the engine comes up to temp shut it down and keep watching for the leak as the residual pressure in the cooling system may continue to push fluid out. A small mirror and flashlight will assist you in locating the leak. Just stay away from the belts while the engine is running.

  7. #7
    Junior Member
    Join Date
    Nov 2010
    Location
    O'fallon, IL
    Posts
    10

    pewter
    2002 Camaro Z28

    Thanks, will do.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 233/239 did a search found very little. need feedback
    By 00redta88 in forum Internal Engine
    Replies: 15
    Last Post: 01-12-2012, 02:04 PM
  2. Leaking antifreeze
    By BlackbirdRamAir in forum External Engine
    Replies: 2
    Last Post: 02-10-2010, 04:08 AM
  3. Searched...but no answer found...
    By cammed goat in forum GTO
    Replies: 8
    Last Post: 01-03-2009, 07:54 PM
  4. Question: Did a search and can't find the answer?
    By blackSS01 in forum General Help
    Replies: 3
    Last Post: 02-29-2008, 04:17 PM
  5. 1999 Camaro SS Leaking Antifreeze into Oil
    By buford in forum Camaro / SS
    Replies: 0
    Last Post: 07-23-2007, 10:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •