Results 1 to 16 of 16

Lacking of Power

This is a discussion on Lacking of Power within the General Help forums, part of the LSx Technical Help Section category; When I put it to the floor...the Car acts like it has NO power?! When I'm on the HIghway..it feels ...

  1. #1
    Junior Member red98ta's Avatar
    Join Date
    May 2008
    Location
    Ohio
    Posts
    18

    RED
    1998 Trans Am

    Lacking of Power

    When I put it to the floor...the Car acts like it has NO power?! When I'm on the HIghway..it feels like a V-6 instead of a V-8?! Any Suggestions??!!

  2. #2
    Give me a place to stand. levityinc3's Avatar
    Join Date
    Jul 2008
    Location
    Jacksonville, FL
    Posts
    1,449

    Red
    2000 SS '89 IROC-Z

    Quote Originally Posted by red98ta View Post
    When I put it to the floor...the Car acts like it has NO power?! When I'm on the HIghway..it feels like a V-6 instead of a V-8?! Any Suggestions??!!
    Is your check engine light on? I'd say do a complete tune up. Plugs, wires, clean the maf, change the fuel filter, check belts, air filter, etc. And make sure you change your oil regularly.

  3. #3
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Check the TB cable

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    any mods to the car? Tune up and clean your MAF sensor. Where at in Ohio?

  5. #5
    Junior Member red98ta's Avatar
    Join Date
    May 2008
    Location
    Ohio
    Posts
    18

    RED
    1998 Trans Am

    just repalced fuel filter, had tune up about 1yr ago. the ses light is on but it goes out at least once a week. what should i be looking for at the throttle cable? thanks

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    what's the code it's throwing? That may point you in a direction. Autozone and advanced auto will both pull the code for free.
    It could very well be plugged cats if you're getting a cat code. Those will have the symptoms you're describing.

  7. #7
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Make sure there is little to no slack.

    Scan the codes...go to an auto parts store and ask for their code reader (scanner)

  8. #8
    Give me a place to stand. levityinc3's Avatar
    Join Date
    Jul 2008
    Location
    Jacksonville, FL
    Posts
    1,449

    Red
    2000 SS '89 IROC-Z

    Quote Originally Posted by 0rion View Post
    any mods to the car? Tune up and clean your MAF sensor. Where at in Ohio?
    Plugged cat does seem like the culprit.

  9. #9
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    I've read about these plugged cats a few times as well, seems like a real nuisance

  10. #10
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    I had the cat on my truck completely fail last year. It came apart internally. With the truck floored I could get it up to about 25mph pullling a boat and that was all she had. I watched the temp gauge and as soon as I saw it start to climb I pulled over and called the wife to bring me a hack saw. Cut it pre-cat and drove home.

  11. #11
    Junior Member red98ta's Avatar
    Join Date
    May 2008
    Location
    Ohio
    Posts
    18

    RED
    1998 Trans Am

    is there anybody around newark ohio that can work on these cars good? i been going to goodyear and they seem like they really dont know anything about these cars or the way they should run. but i will get the code checked out today and look into the throttle cable. thanks

  12. #12
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    look into the code first and see what that is. I'm about 30 minutes from Newark. I can log the car for you and help you diagnose it. I also know a guy out there ( he's on this site) that will work on it for you also.

  13. #13
    Junior Member red98ta's Avatar
    Join Date
    May 2008
    Location
    Ohio
    Posts
    18

    RED
    1998 Trans Am

    cool, funny thing is i started the car up yesterday to go to auto zone and the ses light was out? so im not sure what is up with the car.

  14. #14
    my ws6 eats rice gokillyourself's Avatar
    Join Date
    Apr 2009
    Location
    virginia
    Posts
    177

    sexy
    1999 trans am ws6

    Quote Originally Posted by red98ta View Post
    cool, funny thing is i started the car up yesterday to go to auto zone and the ses light was out? so im not sure what is up with the car.
    even if the light goes out, the computer still stores the code for you, so you should still go get it checked out

  15. #15
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    Quote Originally Posted by gokillyourself View Post
    even if the light goes out, the computer still stores the code for you, so you should still go get it checked out
    that really depends on what scanner they're using. Some won't pull history codes.....only current.

  16. #16
    Junior Member red98ta's Avatar
    Join Date
    May 2008
    Location
    Ohio
    Posts
    18

    RED
    1998 Trans Am

    car seems fine now, no ses light. new fuel filter and fuel injector cleaner.the cars performance seem fine now. when i put i to the foor it really picks up and goes maybe it just was a dirty filter, but i still should get the code pulled.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is Obama's Second-Term Agenda Lacking Issues?
    By Ed Blown Vert in forum Political / Debate Forum
    Replies: 0
    Last Post: 01-18-2013, 04:20 AM
  2. Help: Stereo and power windows losing power randomly
    By Woodles in forum Stereo and Electronics
    Replies: 5
    Last Post: 10-11-2010, 01:00 PM
  3. Question: 99 z28 lacking power
    By mingo99z in forum General Help
    Replies: 13
    Last Post: 02-02-2010, 03:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •