Results 1 to 12 of 12

knocking from underneath??

This is a discussion on knocking from underneath?? within the General Help forums, part of the LSx Technical Help Section category; i've got this knocking from underneath my car and i cant figure it out . everything is tight as far ...

  1. #1
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    30
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    knocking from underneath??

    i've got this knocking from underneath my car and i cant figure it out . everything is tight as far as i can tell. it only happens on off-camber situations like driveways and such. my exhaust hits but that is not it. it sounds like if you were standing on a dock in lake with a piece of wood floating and hitting the dock underneath. thanks everybody

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    does it do it on hard acceleration? Have you checked the tranny mount?

  3. #3
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    30
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    na, its on slow manuevers. i did change the tranny mount a few months ago tho.

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    37
    Posts
    1,346

    black
    2002 WS6

    Is it as you go over or stop on? IF ita as you go ever check that all your shocks are tight on the mounts, then move to the rest of the suspension. coul also be aloose body panel flexing and popping as well. The top on my Jimmy (fullsize with fiberglass top) pops when I go off camber somtimes, mind you i'm crawling out of ditch too when it does.

  5. #5
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    30
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    i dunno. i'm gonna put it on a drive on lift at work this week. thanks you guys

  6. #6
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    47
    Posts
    416

    navy blue metallic
    2001 trans am

    so what happened/ What was the culprit..cause I have the exact same thing going on!

  7. #7
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    30
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    Quote Originally Posted by sic2001 View Post
    so what happened/ What was the culprit..cause I have the exact same thing going on!
    i'm going to try to check it out tomorrow. i'll post if i figure anything out

  8. #8
    Member Jon7I2's Avatar
    Join Date
    May 2006
    Location
    Chicago
    Age
    29
    Posts
    307

    Navy Blue Metallic
    99 Formula M6

    Yeah, i have a similar problem, and would like to know what u found out too

  9. #9
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    30
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    hey, sorry for the delay. i could not figure it out. everything is tight and nothing seems to be rubbing. i got under hit and grabbed and hung on everything. it all acted the way it should. i'm stumped. maybe when i put on the sfc it'll go away

  10. #10
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    30
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    i've been reading on bmr's website and i think the rear control arms are not tight enough. i'll find out and let ya'll know

  11. #11
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    30
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    it was the control arms in the back. i anchored those bitches down and it went away. hope this helps

  12. #12
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    47
    Posts
    416

    navy blue metallic
    2001 trans am

    I had mine welded a few months ago so it SHOULDNT be that but Im gonna take a long ass rachet-bar to em and tighten em up..without breaking them, since Ive got a little experience on thart score as well hahah
    Good looking out on the reply post too!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •