Results 1 to 10 of 10

Knocking sound & burning a little oil

This is a discussion on Knocking sound & burning a little oil within the General Help forums, part of the LSx Technical Help Section category; I have an 01' WS6 Trans Am. She runs great, but I've noticed a knock or tapping sound. Its not ...

  1. #1
    Junior Member
    Join Date
    Apr 2007
    Location
    Florida
    Posts
    40

    Pewter
    2001 Trans Am WS-6

    Knocking sound & burning a little oil

    I have an 01' WS6 Trans Am. She runs great, but I've noticed a knock or tapping sound. Its not there really when the car is started from cold, but rather say when I'm idling after the engine has been running for a while. Its hard to say where the sound is coming from, but my best guess is under the engine.

    Not sure if its related, but I've also noted that she drinks a little oil (low oil light comes on abut every 2500-3000 miles). I've heard some guesses, but wanted to hear what the forum's opinion might be on these two issues.

    *Also, limited # of mods: Flowmaster exhaust, K&N air filter, new lid (guessing whisper, but its not labeled or stock), & b&m shifter that I know of (i'm 2nd owner).

  2. #2
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    What kind of oil pressure do you have at idle and at cruising?
    What kind of oil/viscosity you running?
    What kind of oil filter you have on there?
    How often have you been changing oil?
    Is there any smoke at cold idle/start up/cruising after warm up?

  3. #3
    Junior Member
    Join Date
    Apr 2007
    Location
    Florida
    Posts
    40

    Pewter
    2001 Trans Am WS-6

    What kind of oil pressure do you have at idle and at cruising? Between 40 & a little past 60 on dash gauge
    What kind of oil/viscosity you running? 5w30 Havoline (in FL)
    What kind of oil filter you have on there? Not sure, usually have it done a a local firestone
    How often have you been changing oil? Initially every 3K, then tried using the change oil light, but have gone back to 3K (bought the car w/ 25K miles two years ago, 63K now)
    Is there any smoke at cold idle/start up/cruising after warm up? I haven't noticed any, but a buddy said it puffed smoke when i revved it (in neutral to get someone else's attention) the other day

    Thanks for the quick reply, keep 'em coming!

  4. #4
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    Sounds like you have some issues with varnish/sludge. Run a decent oil filter like AC Delco/NAPA/WIX and run a good synthetic and let it clean some crap out.

  5. #5
    Member
    Join Date
    Jul 2006
    Location
    Glen Carbon, IL
    Age
    39
    Posts
    397

    Silver
    2000 Camaro SS

    Quote Originally Posted by Sarge View Post
    Sounds like you have some issues with varnish/sludge. Run a decent oil filter like AC Delco/NAPA/WIX and run a good synthetic and let it clean some crap out.
    I agree and before you change over to a synthetic. Put a 1/2 a can of seafoam in the oil and 1/2 a can in the gas tank. Run that tank down and change oil over to a good synthetic like Amsoil and use a Amsoil filter, K&N, or a Wix.

  6. #6
    Junior Member
    Join Date
    Apr 2007
    Location
    Florida
    Posts
    40

    Pewter
    2001 Trans Am WS-6

    Oil change is planned for Monday. These have been somthing of the on-going type problems and I was wondering if there was something that might solve the problem. I had read somewhere that a bad oil pump might be the cause of the knock and thought it would also explain the burning of oil.

    -Oh and she's had synthetic since I bought her 2 years ago.

  7. #7
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    Bad oil pump would show very low oil pressure or erratic oil pressure.
    I would autoRX it for sure.
    http://www.auto-rx.com/

  8. #8
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    That low oil light should never have a chance to come on. What are you at least 2 quarts low when that light comes on? Crazy. If its taking that much oil down you need to check it daily. All it will take is a few 6000 RPM rips while being low 2 qts of oil to spin a crank/rod bearing.

  9. #9
    Junior Member
    Join Date
    Apr 2007
    Location
    Florida
    Posts
    40

    Pewter
    2001 Trans Am WS-6

    Good to know its not likely to be the oil pump (i looked up how to get to it and that looks like a pretty big project). I will definately try the auto rx.

    I usually just get the oil changed when the low oil light comes on, but next time I'll add oil and see how many quarts its down. I agree, if its down 2 or more, definately a problem!

  10. #10
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by bull1112 View Post
    Good to know its not likely to be the oil pump (i looked up how to get to it and that looks like a pretty big project). I will definately try the auto rx.

    I usually just get the oil changed when the low oil light comes on, but next time I'll add oil and see how many quarts its down. I agree, if its down 2 or more, definately a problem!
    Please, please stop relying on that Low Oil light. Just check your oil! Its not that hard.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Slight knocking sound
    By silverWS6 in forum General Help
    Replies: 1
    Last Post: 04-30-2011, 07:30 PM
  2. Help: Knocking sound from rear end
    By PatrizioD in forum GTO
    Replies: 16
    Last Post: 04-10-2011, 11:31 AM
  3. Tapping/Knocking sound when cold.
    By TA98 in forum General Help
    Replies: 0
    Last Post: 05-02-2010, 07:33 PM
  4. Knocking sound with VID.
    By casperss in forum General Help
    Replies: 11
    Last Post: 09-10-2008, 05:26 PM
  5. wierd knocking sound in the back
    By notfastenuff in forum General Help
    Replies: 21
    Last Post: 10-19-2007, 02:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •