Results 1 to 5 of 5

Knock sensor went bad.. How to replace?

This is a discussion on Knock sensor went bad.. How to replace? within the General Help forums, part of the LSx Technical Help Section category; Hey I found out that my SES light was due to a bad knock sensor... any idea where this thing ...

  1. #1
    Member
    Join Date
    Jan 2006
    Location
    houston
    Posts
    205

    Navy Blue
    ls1 trans am

    Cool Knock sensor went bad.. How to replace?

    Hey I found out that my SES light was due to a bad knock sensor... any idea where this thing is and how to change it out. Also it is 42 bucks at auto zone... know any cheaper places to buy it. thnaks guys

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Well, it's under the intake manifold - not an easy replacement. Maybe it's a wiring/harness problem? Does the code keep coming on after resetting? What code did you throw? I'd exhaust all other possibilities before pulling the intake.

  3. #3
    Junior Member
    Join Date
    Feb 2006
    Location
    Alabama
    Age
    49
    Posts
    35

    Pewter
    2001 Z 28

    Yea I just put a motor in my car had same code coming up and to come to find out the plug was not making a good connection repluged it in and solved the issue the plug is on the back of the intake closer to the driver side.
    You Snooze You Looze!!

  4. #4
    Member
    Join Date
    Jan 2006
    Location
    houston
    Posts
    205

    Navy Blue
    ls1 trans am

    Ok well I was washing my engine the day the light came on... So can I reach back there and mess with it or do I have to pull the manifold.... I havent recet it yet... for got exaclty how.. any tips on that? Also how important is this to fix... can I drive on it for a while... and is it possible for me to do it on my own... I do small thingslike brake pads.. plugs... window motor... not too much other than that.. thanks guys

  5. #5
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Washing the engine got something wet. Should be dry by now - first thing I'd do is reset the light and see if it comes back. There are two knock sensors under the intake, look at www.ls1howto.com/index.php?article=5 it's for an intake swap and also has pictures of the sensors/wiring with the intake removed. To reset the PCM turn the key on, don't start car. Pull PCM BATT and PCM IGN fuses in the engine compartment. Wait 5-10 min. Turn ignition off. Replace fuses. As far as driving with the code on look up the DTC at www.gearchatter.com to see how it affects the car with the light on.
    Last edited by 2001NBMZ28; 03-29-2006 at 10:24 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •