Results 1 to 13 of 13

knock sensor engine light

This is a discussion on knock sensor engine light within the General Help forums, part of the LSx Technical Help Section category; I had a check engine light come on recently so i took my 01 SS to the dealer and they ...

  1. #1
    Junior Member
    Join Date
    Dec 2005
    Location
    Austin, TX
    Posts
    20

    pewter
    2001 Camaro SS

    Angry knock sensor engine light

    I had a check engine light come on recently so i took my 01 SS to the dealer and they said it was a misc. code. Found out i had a small coolant leak from the water pump and the water pump seal was bad. Fixed the leak. Cleared the code and now its on again claiming its the engine knock sensor. Mechanic stated it might be caused by coolant leaking on the dristributor prior to leak fix. I've noticed some slight knocked but it seems random. Some days good some days a little rough. At idle its smooth.

    Any suggestions? Or keep going around in circles with this code.

    Thanks

  2. #2
    The Rookie
    Guest
    Do you have an after market filter?? Have you cleaned and oiled it lately?

  3. #3
    Junior Member
    Join Date
    Aug 2005
    Location
    San Jose CA
    Age
    41
    Posts
    11

    White
    99 Z28

    Replace the knock sensor. If any water gets under your intake manifold they will get water in them and rust. This can happen from washing your engine.

  4. #4
    Junior Member
    Join Date
    Dec 2005
    Location
    Austin, TX
    Posts
    20

    pewter
    2001 Camaro SS

    I do have a K&N filter which prob needs cleaning. I will try that.

  5. #5
    Senior Member MadSeason's Avatar
    Join Date
    Aug 2005
    Location
    Indiana
    Age
    34
    Posts
    2,000
    1994 POS

    Quote Originally Posted by IRACE2
    Replace the knock sensor. If any water gets under your intake manifold they will get water in them and rust. This can happen from washing your engine.
    They fixed that issue with different sensors in 2001, same year as his car. It's not false knock from that

  6. #6
    Senior Member MadSeason's Avatar
    Join Date
    Aug 2005
    Location
    Indiana
    Age
    34
    Posts
    2,000
    1994 POS

    When is the last time you changed the fuel filter? Ran any crappy Gas Lately?

  7. #7
    Junior Member
    Join Date
    Dec 2005
    Location
    Austin, TX
    Posts
    20

    pewter
    2001 Camaro SS

    fuel filter was changed 15k ago.......running shell 93 octane

  8. #8
    Junior Member
    Join Date
    Dec 2005
    Location
    Austin, TX
    Posts
    20

    pewter
    2001 Camaro SS

    I don't think its a false knock....it does knock but not all the time. I'm trying to figure out why its inconsistent. One trip and its great then the next its knocking up a hill in 3rd gear......

  9. #9
    masterblaster
    Guest
    I had a similar prob with mine, replaced nasty old K&N with stock filter, changed fuel filter, and ONLY run shell 93 and no more knocking/pinging for awhile. It has started pinging a bit lately, maybe got a bad tank of gas. Are these f'ing cars gas sensitive or what???

  10. #10
    Junior Member
    Join Date
    Dec 2005
    Location
    Austin, TX
    Posts
    20

    pewter
    2001 Camaro SS

    Put a stock filter in and going to clean and oil the K&N. Going back to have the code read tomorrow and then reset. I'll check to make sure when i had my last fuel filter...just to make sure i didn't skip it at the 30k(well 35k) maintenence. I have 50k on it now.

  11. #11
    Junior Member
    Join Date
    Dec 2005
    Location
    Austin, TX
    Posts
    20

    pewter
    2001 Camaro SS

    fuel filter done 17k ago......i could replace that but i don't see it solving the problem.

  12. #12
    The Rookie
    Guest
    Quote Originally Posted by kodiak120
    Put a stock filter in and going to clean and oil the K&N. Going back to have the code read tomorrow and then reset. I'll check to make sure when i had my last fuel filter...just to make sure i didn't skip it at the 30k(well 35k) maintenence. I have 50k on it now.
    Kodiac, What I was trying to say is if you recently cleaned your filter, the oil may have contaminated your MAF. I had a knock sensor go off a while back, I heard abunch of different things from different folks. But I was planning on replacing my knock sensors until Sarge asked if I had recently cleaned my K&N. Which I had. What happened is I put too much oil on it and it contaminated the small electrical wires on my MAF. Once I recleaned the Filter (to get the excess oil off of it), Cleaned my MAF with electrical cleaner, killed the battery by leaving the key on with the lights and radio on for 2 hours to completely kill it. I then charged the baterry and ran it through 3 heat cycles. The light went out and it started running fine again. no problems sense, and man it saved a lot of work. THANKS SARGE!
    Last edited by The Rookie; 01-10-2006 at 10:02 PM.

  13. #13
    Junior Member
    Join Date
    Dec 2005
    Location
    Austin, TX
    Posts
    20

    pewter
    2001 Camaro SS

    I see.....no i hadn't cleaned it yet. Thanks
    Every other time i drive it seems as though when in low gear ie 3rd going 40 or skip shifting which i don't normally use in makes a gum ball like knocking sound (not sure of the universal knocking definition). I noticed it some before having the coolant leak fixed....should i be concerned for something major here? Or is it most likely a fuel/air/tuning problem?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 Trans Am Knock Sensors
    By racer383 in forum Internal Engine
    Replies: 1
    Last Post: 01-02-2006, 06:40 AM
  2. Unexplained knock retard.
    By Cerwin Vega Fan in forum LT1
    Replies: 2
    Last Post: 11-11-2005, 12:48 PM
  3. help! bad knock
    By bpm in forum Computer & Tuning
    Replies: 6
    Last Post: 11-06-2005, 07:37 PM
  4. Low coolant light
    By fredg369 in forum LT1
    Replies: 3
    Last Post: 09-29-2005, 05:00 PM
  5. Engine light
    By 01ssls1 in forum General Help
    Replies: 5
    Last Post: 09-26-2005, 11:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •