Results 1 to 14 of 14

knock sensor

This is a discussion on knock sensor within the General Help forums, part of the LSx Technical Help Section category; Good day everyone, need a little help on my 99z, ls1. SES (P0327, knock sensor circuit low output) light comes ...

  1. #1
    Junior Member alkaydenz-28's Avatar
    Join Date
    Jun 2006
    Location
    meridian, ms
    Posts
    23

    pewter
    1999 z-28

    knock sensor

    Good day everyone, need a little help on my 99z, ls1. SES (P0327, knock sensor circuit low output) light comes on everytime I go 75+ MPH. I use 93octane, fuel system cleaner every 3rd refill, hypertech power programmer, about 75000 mileage.
    Any help is much appreciated.

  2. #2
    Junior Member slp1122's Avatar
    Join Date
    Nov 2008
    Location
    oc/las vegas
    Posts
    79

    pewter
    2000 camaro ss

    time for a new knock sensor

  3. #3
    Member SteelmanLS1's Avatar
    Join Date
    Apr 2007
    Location
    LSX, Oklahoma
    Age
    28
    Posts
    311

    Black
    2000 WS6 Trans Am M6

    Quote Originally Posted by slp1122 View Post
    time for a new knock sensor
    +1

  4. #4
    Junior Member alkaydenz-28's Avatar
    Join Date
    Jun 2006
    Location
    meridian, ms
    Posts
    23

    pewter
    1999 z-28

    Thumbs up

    Quote Originally Posted by slp1122 View Post
    time for a new knock sensor
    I removed the hypertech power program earlier today and I drove 80+ MPH, I made 3 runs doing the same thing and the SES alarm never came on.
    Filled the tank to full, drove back home doing about 85+ MPH for my last test,
    and thank God it never came on.
    Thanks for the recommendation.

  5. #5
    Junior Member slp1122's Avatar
    Join Date
    Nov 2008
    Location
    oc/las vegas
    Posts
    79

    pewter
    2000 camaro ss

    Quote Originally Posted by alkaydenz-28 View Post
    I removed the hypertech power program earlier today and I drove 80+ MPH, I made 3 runs doing the same thing and the SES alarm never came on.
    Filled the tank to full, drove back home doing about 85+ MPH for my last test,
    and thank God it never came on.
    Thanks for the recommendation.
    that's interesting. hopefully it stays that way!

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    ever wash the engine down with a garden hose? That code will most likely be back at some point.

  7. #7
    Junior Member slp1122's Avatar
    Join Date
    Nov 2008
    Location
    oc/las vegas
    Posts
    79

    pewter
    2000 camaro ss

    Quote Originally Posted by 0rion View Post
    ever wash the engine down with a garden hose? That code will most likely be back at some point.
    i agree. i think your best bet will be to pop off the intake, and replace the knock sensors... if the code comes up again

  8. #8
    Junior Member alkaydenz-28's Avatar
    Join Date
    Jun 2006
    Location
    meridian, ms
    Posts
    23

    pewter
    1999 z-28

    Smile

    Quote Originally Posted by slp1122 View Post
    that's interesting. hopefully it stays that way!
    yes, it was very interesting.

  9. #9
    Junior Member alkaydenz-28's Avatar
    Join Date
    Jun 2006
    Location
    meridian, ms
    Posts
    23

    pewter
    1999 z-28

    Smile

    Quote Originally Posted by slp1122 View Post
    i agree. i think your best bet will be to pop off the intake, and replace the knock sensors... if the code comes up again
    i just hope i dont have to.

  10. #10
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    Quote Originally Posted by alkaydenz-28 View Post
    I removed the hypertech power program earlier today and I drove 80+ MPH, I made 3 runs doing the same thing and the SES alarm never came on.
    Filled the tank to full, drove back home doing about 85+ MPH for my last test,
    and thank God it never came on.
    Thanks for the recommendation.

    that had nothing to do with the code what so ever (your programmer I mean).

    Once that code has become active, even if it's in history, you lose max KR timing whenever the car goes into PE, which is -4.0 deg. Basically, whenever you get on the car at all, it will pull max timing as a safety. You are losing some real HP like this.

  11. #11
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    -4 deg. is a nice difference in power, i think for every -1 degree you lose about 6-8rwhp. You havent notice any power loss when your gunning it? My friend had the same issue with his knock sensor but his SES light is on all the time and he has lost a noticable amount of power top end he says im sure you lose power overall but he says he felt it more up top. On my 93 Z when running nitrous i took out initially 2 deg. and the car was noticably slower, i had to take 7 out to finally get the car running properly with 150 shot and off the nitrous the car had no power above 4000rpms lol. Well im sure it did but easily noticable that it was much slower then before.

  12. #12
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    I would guess he either had an intermittent issue with the sensor or it has to go through the drive cycle again since he reflashed his stock tune back and it'll throw that code again.

  13. #13
    Junior Member slp1122's Avatar
    Join Date
    Nov 2008
    Location
    oc/las vegas
    Posts
    79

    pewter
    2000 camaro ss

    Quote Originally Posted by 0rion View Post
    I would guess he either had an intermittent issue with the sensor or it has to go through the drive cycle again since he reflashed his stock tune back and it'll throw that code again.
    yea you're right. i use to use a handheld and everytime you make a change it resets the whole drive cycle.

  14. #14
    Junior Member alkaydenz-28's Avatar
    Join Date
    Jun 2006
    Location
    meridian, ms
    Posts
    23

    pewter
    1999 z-28

    Thumbs up

    Quote Originally Posted by karpetcm View Post
    -4 deg. is a nice difference in power, i think for every -1 degree you lose about 6-8rwhp. You havent notice any power loss when your gunning it? My friend had the same issue with his knock sensor but his SES light is on all the time and he has lost a noticable amount of power top end he says im sure you lose power overall but he says he felt it more up top. On my 93 Z when running nitrous i took out initially 2 deg. and the car was noticably slower, i had to take 7 out to finally get the car running properly with 150 shot and off the nitrous the car had no power above 4000rpms lol. Well im sure it did but easily noticable that it was much slower then before.
    no i havent notice any power loss when im gunning it. I tried it yesterday against this 95-98 cobra that wont leave me alone while Im cruising. No issues whatsoever. I have to use my brakes twice to wait for him.
    Anyway, I will get it changed soon. Just to be sure. No more SES though.
    Thanks everyone.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. knock sensor code with new knock sensors?
    By zaaronz in forum General Help
    Replies: 13
    Last Post: 02-27-2011, 07:26 AM
  2. Knock Sensor ?
    By Jheath5193 in forum General Help
    Replies: 1
    Last Post: 01-20-2011, 03:31 PM
  3. Which knock sensor do I need?
    By SMWS6TA in forum General Help
    Replies: 7
    Last Post: 12-27-2010, 11:09 PM
  4. will bad knock sensor knock down hp
    By zaaronz in forum General Help
    Replies: 11
    Last Post: 10-14-2010, 05:49 PM
  5. Knock Sensor/Oil Pressure Sensor Issue
    By Slow '99 in forum External Engine
    Replies: 1
    Last Post: 04-04-2007, 09:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •