Page 4 of 4 FirstFirst 1234
Results 61 to 62 of 62

Keeps throwing P0327 code...driving me nuts!

This is a discussion on Keeps throwing P0327 code...driving me nuts! within the General Help forums, part of the LSx Technical Help Section category; Yeah...it was shocking to see the amount of rust. I have no idea why they would put an old one ...

  1. #61
    Junior Member
    Join Date
    Dec 2009
    Location
    St. Louis, MO
    Posts
    51

    Black
    2000 Camaro SS

    Yeah...it was shocking to see the amount of rust.

    I have no idea why they would put an old one in when I had already provided them with 2 new ones. I guess they would be just banking on me coming back to keep fixing the problem and getting more money out of me before they replaced the sensors again and got more money. That would have to be the thought process.

    Or maybe they did use my new sensor and they still left water in there...and operating temperatures of the engine....and the metal that makes up the sensor are just really prone to rust. Who knows.

    Either way, they didn't get the job done. And they weren't even on the right track to getting it fixed. I diagnosed it myself and told them it has to be something wrong with the sensor again...like water was under there still. They thought I was barking up the wrong tree.

    When it's all said and done....I won't ever be going back to them again. They lost whatever business they were going to get from me in the future. And I had fun realizing I could do work like that myself.

    Thanks for caring everyone.

  2. #62
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    There is so much info in here and the net about our cars that you can pretty much do it yourself if you are handy and got some tools. There is alot of people that are always willing to help. Just let ls1.com know. Take care bud.

Page 4 of 4 FirstFirst 1234

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Code p0327
    By dethinboots in forum GTO
    Replies: 4
    Last Post: 10-17-2012, 07:56 AM
  2. please help driving me nuts
    By dn1186 in forum Drivetrain
    Replies: 6
    Last Post: 05-18-2012, 10:31 PM
  3. tps issue driving me nuts
    By occamaroz in forum General Help
    Replies: 0
    Last Post: 09-04-2009, 09:16 AM
  4. weird rattle in back quarter.. driving me nuts
    By Circa307 in forum General Help
    Replies: 21
    Last Post: 08-31-2009, 01:11 PM
  5. The ashtray is driving me nuts!
    By SilverNineT9 in forum General Help
    Replies: 9
    Last Post: 11-13-2008, 09:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •