Results 1 to 9 of 9

Intake lip/box rubbing

This is a discussion on Intake lip/box rubbing within the General Help forums, part of the LSx Technical Help Section category; My SLP intake lid is rubbing on the underside of my hood. Anyone have this problem. Any tips or tricks ...

  1. #1
    COME AT ME BRO Soltakr's Avatar
    Join Date
    Aug 2005
    Location
    O.C. California
    Posts
    1,474

    Black
    2002 Camaro SS (crashed)

    Intake lip/box rubbing

    My SLP intake lid is rubbing on the underside of my hood. Anyone have this problem. Any tips or tricks to fixing this would be great, thanks

    (notice the white spot in the upper right and lower left)






    (here is the markers on the hood)

  2. #2
    Junior Member Twistingreality's Avatar
    Join Date
    Mar 2007
    Location
    Oklahoma
    Posts
    79

    White
    2001 Camaro

    Is the hood factory or is it aftermarket? If it is aftermarket it may not be adjusted right. I would look at that first. I have a MTI lid and an SS hood and dont have any problems with it.

  3. #3
    COME AT ME BRO Soltakr's Avatar
    Join Date
    Aug 2005
    Location
    O.C. California
    Posts
    1,474

    Black
    2002 Camaro SS (crashed)

    Its the stock hood. I have a K&N filter. Maybe I installed it wrong somehow. It's there something that i should of cut?

  4. #4
    Member fxgs's Avatar
    Join Date
    Mar 2007
    Location
    Camp Hill, Pa
    Posts
    719

    Onyx Black
    2002 SLP Camaro SS

    I had the same prob............took two pieces of velcro (the soft strip part) and placed it on the hood where rubbing occured.

  5. #5
    Member Sunset T/A's Avatar
    Join Date
    Oct 2005
    Location
    Spring, TX
    Age
    66
    Posts
    285

    Sunset Orange
    2002 TransAm

    Have a friend with a Z-28, same problem with stock hood. Have not heard of any problems with that on the Firebirds.

  6. #6
    COME AT ME BRO Soltakr's Avatar
    Join Date
    Aug 2005
    Location
    O.C. California
    Posts
    1,474

    Black
    2002 Camaro SS (crashed)

    Need some way to make that airbox sit lower. I really dont want to pad the hood.

  7. #7
    COME AT ME BRO Soltakr's Avatar
    Join Date
    Aug 2005
    Location
    O.C. California
    Posts
    1,474

    Black
    2002 Camaro SS (crashed)


  8. #8
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    Mine did that when I put in the FTRA...what did you do between now and when it didn't rub?

  9. #9
    COME AT ME BRO Soltakr's Avatar
    Join Date
    Aug 2005
    Location
    O.C. California
    Posts
    1,474

    Black
    2002 Camaro SS (crashed)

    I can't even remember, it been over 5 years. I bought the car new and changed the filter the same day.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. headers rubbing
    By Ramairgod84 in forum General Help
    Replies: 14
    Last Post: 07-30-2010, 08:32 AM
  2. header rubbing!
    By huggerls1 in forum External Engine
    Replies: 32
    Last Post: 02-27-2009, 12:46 PM
  3. 315's rubbing?
    By clint195 in forum Wheels and Tires
    Replies: 5
    Last Post: 01-17-2007, 01:46 PM
  4. Rubbing problem now..... Or something Else. Help Please.
    By FireBirdzx28 in forum Firebird / WS6
    Replies: 3
    Last Post: 07-16-2006, 10:37 AM
  5. Need Help with some rubbing
    By 02_WS6 in forum Suspension and Handling
    Replies: 7
    Last Post: 08-20-2005, 04:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •