Results 1 to 17 of 17
Like Tree1Likes
  • 1 Post By pajeff02

I'm puzzled

This is a discussion on I'm puzzled within the General Help forums, part of the LSx Technical Help Section category; OK so yesterday I was working on the car. I was running a wire for my amp on the back. ...

  1. #1
    Member dav-02ws6-m6's Avatar
    Join Date
    Mar 2010
    Location
    VA
    Posts
    294
    2002 trans am ws6

    I'm puzzled

    OK so yesterday I was working on the car. I was running a wire for my amp on the back. I removed the two covers that are under the steering wheel. And upon removing the second cover I found this springs. Where do they go?
    Attached Images Attached Images

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    no idea.....for the tilt maybe? Does your tilt work like it should?

  3. #3
    Member dav-02ws6-m6's Avatar
    Join Date
    Mar 2010
    Location
    VA
    Posts
    294
    2002 trans am ws6

    Yes it seem to work good.

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    if you pull the lever the wheel will pop up on it's own or do you have to lift it into place? That's the only thing that comes to mind that would require springs that heavy.

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    That's interesting. Is that the same style spring as on the latch mechanism for the hatch? I have had my underdash apart a couple of times and never spotted anything that looks like those. Like 0rion said, the tilt assembly on the steering column would have springs.

  6. #6
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Subscribed.

  7. #7
    Member dav-02ws6-m6's Avatar
    Join Date
    Mar 2010
    Location
    VA
    Posts
    294
    2002 trans am ws6

    Seems like it's working good. It goes up by it self. At first I thought that maybe it was from the clutch or the ac bents. But everything that I can think of seem ok.

  8. #8
    expensive tires az gt eater's Avatar
    Join Date
    Mar 2006
    Location
    phoenix
    Posts
    1,951

    white
    04 2500 4x4 crew cab

    I say pedal arm springs. Prob someone left/dropped them in there. For clutch,brake, IDK.

  9. #9
    Senior Member kingls1's Avatar
    Join Date
    Apr 2011
    Location
    Johnstown,PA
    Age
    48
    Posts
    1,102

    Silver
    1999 Trans-Am, 2012 Sonic

    This is your spring from your clutch pedal, this is a picture of the spring as one peice. The picture you have you can see it is broke in half. If you have a Tick MC it is removed as it is no longer needed. They are a pain to get off so it may have flew up in the dash and could not be found. One way or another someone removed the mc arm.

    99 Trans Am, SLP Lid, Blackwing filter, smooth bellow, Ported TB, LS6 intake, Ws6 lower ram air box, OBX LT's, Magna Flow cat back, LS7 clutch, Tick MC, Hurst Shifter, Frost Tune, UMI SFC,LAC, STB, PB, Torq Arm, Super Hawk hood, Torq Thrust II, Kee Audio.
    Strange S60 4:10's, D&S Rotors, S/S Brake Lines.
    Nitto NT05R Track Tire's, 12.7 @ 108 / 1.82 60'
    Wish list.
    Coil overs, Heads & Cam

  10. #10
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    And, I have again learned something. Thanks!

  11. #11
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Never knew this either.

  12. #12
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,509

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by kingls1 View Post
    This is your spring from your clutch pedal, this is a picture of the spring as one peice. The picture you have you can see it is broke in half. If you have a Tick MC it is removed as it is no longer needed. They are a pain to get off so it may have flew up in the dash and could not be found. One way or another someone removed the mc arm.

    Click for full size


    So I'm supposed to remove that spring if I have a Tick MC?

    I'm asking because I haven't yet.

  13. #13
    Senior Member kingls1's Avatar
    Join Date
    Apr 2011
    Location
    Johnstown,PA
    Age
    48
    Posts
    1,102

    Silver
    1999 Trans-Am, 2012 Sonic

    Here is the sticky install by our one and only Tatertot
    Master Cylinder Swap/Install (Tick MC)

    I can't remember but I think Ticks directions had it as well, pretty sure it's because with the adjustable rod the pedal no longer is in the factory position my pedal is closer to the floor and that would have spring pressure on the pedal returning it to the top. I have mine like this with NO issues at all

  14. #14
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,509

    Navy Blue Metallic
    98 T/A w/a little mods...

    well damn I missed that. Looks like I need to go back under....FML.

  15. #15
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    Quote Originally Posted by SMWS6TA View Post
    well damn I missed that. Looks like I need to go back under....FML.
    I haven't read the other thread recently....or seen it bumped for that matter.....did you ever get the noise figured out?
    Quote Originally Posted by Mean Green Z28 View Post
    Don't worry about understanding women. Women understand women, and they hate each other

  16. #16
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    Not one of GM's better ideas !
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

  17. #17
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,509

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by 0rion View Post
    I haven't read the other thread recently....or seen it bumped for that matter.....did you ever get the noise figured out?
    I haven't posted any updates because I was so pissed off I had to walk away for a while before I broke something. I picked up some LS7 lifters and threw them in last wk. This is my last attempt, otherwise the engine get's pulled. If it's pulled I'll be very tempted to say screw it and go all out to a 408ci build. All I need is to bore the block, get new pistons & crank. My rods are already 6.125". I also install the heads but need to tq them down. still. Sep/Oct didn't have any free time to do anything but now that it's slowing down I'm getting motivated to get back into it. That plus I picked up something from Will that is motivating me to get busy. I bought his FAST 102.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Puzzled by engine vibration
    By Thedub in forum General Help
    Replies: 1
    Last Post: 12-05-2016, 09:31 AM
  2. 80's movie has me puzzled!
    By Banshee1967 in forum Almost Anything Goes
    Replies: 1
    Last Post: 11-16-2008, 06:53 PM
  3. Help: Super Puzzled, please help if you can???
    By blackSS01 in forum General Help
    Replies: 17
    Last Post: 08-19-2008, 04:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •