View Poll Results: What Oil Do You Use

Voters
487. You may not vote on this poll
  • Synthetic

    424 87.06%
  • Dino

    40 8.21%
  • Blended dino/synthetic off the shelf

    17 3.49%
  • I mix my own

    6 1.23%
Page 54 of 70 FirstFirst ... 4142434505152535455565758 ... LastLast
Results 1,061 to 1,080 of 1384
Like Tree2Likes

I'm a Oil Junkie

This is a discussion on I'm a Oil Junkie within the General Help forums, part of the LSx Technical Help Section category; Originally Posted by Smittro Far too heavy for tight tollerance car engines.imho. Could do more damage than good.. I actually ...

  1. #1061
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    Quote Originally Posted by Smittro View Post
    Far too heavy for tight tollerance car engines.imho. Could do more damage than good.. I actually went down to 5w30... Many here even went down to 0w30... Side note: Sawdust added to a bad trany will make it not slip for a little while... Is it fixed?
    like i put in my post it needs fixed this may just help for a bit. i am one how runs 0w-30 amsoil in my ta.

  2. #1062
    Member blackcar's Avatar
    Join Date
    Oct 2005
    Location
    Arkansas
    Posts
    1,234

    2000 Camaro SS
    '02 Z28 parting-out

    Quote Originally Posted by 01 T/A View Post
    like i put in my post it needs fixed this may just help for a bit. i am one how runs 0w-30 amsoil in my ta.
    But could it cause more damage. Right now, he probably just has one problem. But could running 20w50 cause more problems???

  3. #1063
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by blackcar View Post
    But could it cause more damage. Right now, he probably just has one problem. But could running 20w50 cause more problems???
    Could.. Without knowing for sure what the problem is....

  4. #1064
    Can O' Man SiLver_PhOeNiX's Avatar
    Join Date
    Jul 2010
    Location
    SoCal
    Posts
    75

    Silver
    98 Z28

    when i put in 10-40, it stopped for about 20 minutes of freeway driving. then came back and got worse. i believe i also have a nice little leak going on down there but cant isolate exactly where. appears to be coming from the pan but could also be the head gasket. i hope not the head gasket. the gaskets are about 80 bucks each time! just for a ford escape! im going to have to save a good amount of cheese to get it fixed. i could do it myself but its my wifes main mode of trans. so i dont wanna fuck anything up on it. just need to find a good shop with honest mechs. wish me luck on that. i think ill need it!

  5. #1065
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    Quote Originally Posted by blackcar View Post
    But could it cause more damage. Right now, he probably just has one problem. But could running 20w50 cause more problems???
    depends on the car most will take it ok but there is alway a cance to hert it more. but it sounds like a good shop is what this ride is in need of.

  6. #1066
    Junior Member Gohard's Avatar
    Join Date
    May 2010
    Location
    Detroit, MI
    Posts
    67
    2002 WS6 M6

    How long should the sig series 0w30 amsoil last? I do a good mix of cruising @ 2k rpm and wot pulls to 6k rpm. I've got 3k miles on the oil now.

    Also, what's the best way to check the oil? I'm getting very low readings. I let it sit 15-20 mins after driving and checked it and it was below the "ADD" mark. I also checked it in the morning after it sat overnight and got the same thing. If I'm checking it right it could probably take a quart, I'm glad I ordered an extra one.

    I want to get a UOA too, where can I go to have it done? Are there places that do it like shops or something?

  7. #1067
    Junior Member Gohard's Avatar
    Join Date
    May 2010
    Location
    Detroit, MI
    Posts
    67
    2002 WS6 M6

    Forgot to mention that at idle (800-900 rpm) the oil pressure is at 40-45 on the stock gauge. Is that normal?

  8. #1068
    Can O' Man SiLver_PhOeNiX's Avatar
    Join Date
    Jul 2010
    Location
    SoCal
    Posts
    75

    Silver
    98 Z28

    my pressure sits at 50 at a 2000rpm cruise

  9. #1069
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    Quote Originally Posted by Gohard View Post
    How long should the sig series 0w30 amsoil last? I do a good mix of cruising @ 2k rpm and wot pulls to 6k rpm. I've got 3k miles on the oil now.

    Also, what's the best way to check the oil? I'm getting very low readings. I let it sit 15-20 mins after driving and checked it and it was below the "ADD" mark. I also checked it in the morning after it sat overnight and got the same thing. If I'm checking it right it could probably take a quart, I'm glad I ordered an extra one.

    I want to get a UOA too, where can I go to have it done? Are there places that do it like shops or something?
    Quote Originally Posted by Gohard View Post
    Forgot to mention that at idle (800-900 rpm) the oil pressure is at 40-45 on the stock gauge. Is that normal?
    the pressure is good if you still have the stock oil pump. and my car holds like 5.5 q's on a oil change so that may be the same for you. and the only way to find out if its still good is the uoa. you can find places on line or go to amsoil's site and get it from them. i would think 7 to 10k is not out of the pic for the oil you run. its the same as me and it call's for upto 15k.

  10. #1070
    Junior Member Gohard's Avatar
    Join Date
    May 2010
    Location
    Detroit, MI
    Posts
    67
    2002 WS6 M6

    Quote Originally Posted by 01 T/A View Post
    the pressure is good if you still have the stock oil pump. and my car holds like 5.5 q's on a oil change so that may be the same for you. and the only way to find out if its still good is the uoa. you can find places on line or go to amsoil's site and get it from them. i would think 7 to 10k is not out of the pic for the oil you run. its the same as me and it call's for upto 15k.
    Yes, it has stock oil pump and it took exactly 5.5 q's to get a perfect level when I changed it but it's looking dangerously low. But if the oil pressure is right then it shouldn't be low right? I haven't drove it again yet but what's the best way to check it? The manual says when the oil is hot and has sat long enough to be all in the oil pan. So, I'm thinking a good 15-20 minute drive around town, let it sit for like 10 mins, and then check it.

    Burning oil seems to be common with ls1's but mines has very low mileage, around 25k, so I'm not really expecting it from my car! Geez I hope not! Maybe it's a sign of burning oil or maybe it's normal but I wipe the inside of the exhaust tips whenever I drive it and they get a dirty black buildup on the inside quickly. They're chrome double wall tips so easy to see it after a decent trip (20-30 miles). I doubt it's the fuel trim, I've had the car dyno tuned with bolt-ons and it still gets that buildup in the tailpipes.

  11. #1071
    TerribleTed TerribleTed's Avatar
    Join Date
    Jan 2010
    Location
    California-Sacramento-Roseville
    Posts
    145

    Red
    2000 Chevy Camaro Z28

    If your concerned with oil loss..and you dont see a leak,,,do a wet compression check,.,.,else its most likely the usualy Ls1 issue,,that being us dragging the cars or cornering the cars excessively while getting on it,,causing oil to get sucked up thru the PCV system and all....

    I installed a check 2 dollar oil catch can and was amazed at how much oil in 3K of hard driving it picked up,,,that was lost and would have been burned,,,

    So if your wet compression checks out OK,,and u have no oil leaks on the car and your concerned over oil consumtion,,,then try an oil catch can to see how much oil is being sent theu PCV system,,,

    I madfe my PCV catch can out of some black PVC pipes, brass fittings and installed a drain valve (all parts from hardware store for under 5 bucks at most)...now at least the oil it traps does not get burned off into intake,,,

  12. #1072

    Thumbs up UOA labs?

    Quote Originally Posted by Gohard View Post
    I want to get a UOA too, where can I go to have it done? Are there places that do it like shops or something?
    You'll find the best value in UOA's through Oil Analyzers, Inc. (OAI). OAI uses a private label program provided by Polaris Laboratories. Polaris labs has the highest of ISO accreditation a testing lab can have ISO: 17025 A2LA.

  13. #1073
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    Quote Originally Posted by SiLver_PhOeNiX View Post
    my pressure sits at 50 at a 2000rpm cruise
    Sounds about right for me as well. Usually abour 40 if I am in OD and under 1500 rpms.

    Mine was down about 1/2 of a quart when I changed it a few days ago. Looking to see how much it goes down at the the 500, 1000, 1500, 2000, 2500, and 3000 mark.

    My 04 GTO didnt lose any oil and my 94 LT1 didnt either. This one seems to eat a little bit but nothing major.

  14. #1074
    Can O' Man SiLver_PhOeNiX's Avatar
    Join Date
    Jul 2010
    Location
    SoCal
    Posts
    75

    Silver
    98 Z28

    ^yeah i have the 6speed and i try to keep the rpms around 1500. thinking itll keep the gas mileage on the happier side

  15. #1075
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    I am an auto and with 2.73 gears its tougher to get up to speed and takes longer but on the highway these gears rock! First tank full I only got around 23 mpgs but since then I am averaging mid 24s to 26s and I am an A4....lol

  16. #1076
    We'll be back... GatorSS's Avatar
    Join Date
    Aug 2005
    Location
    THE SWAMP
    Posts
    1,446

    Light Pewter Metallic
    2000 Camaro SS M6

    Quote Originally Posted by SiLver_PhOeNiX View Post
    hey ive got a 2005 ford escape v6 that that has a pretty damn loud tappet noise. i know it has something to do with the rocker arm or valve, spring, lifter etc.. i got a mechanic buddy that says "put 20-50 in her." do you guys think thats wise or ok? i dont have the money to drop to get it fixed right now and ill prolly end up doin it myself, but dont have the time or funds for the parts. what do you guys think? oh yeah, and it burns a shit load of oil. thanks
    Run AutoRx in it following the instructions for the cleaning phase and rinsing phase. That noise might be from lack of proper lubrication to that specific area due to sludge.

  17. #1077
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    Quote Originally Posted by Gohard View Post
    Yes, it has stock oil pump and it took exactly 5.5 q's to get a perfect level when I changed it but it's looking dangerously low. But if the oil pressure is right then it shouldn't be low right? I haven't drove it again yet but what's the best way to check it? The manual says when the oil is hot and has sat long enough to be all in the oil pan. So, I'm thinking a good 15-20 minute drive around town, let it sit for like 10 mins, and then check it.

    Burning oil seems to be common with ls1's but mines has very low mileage, around 25k, so I'm not really expecting it from my car! Geez I hope not! Maybe it's a sign of burning oil or maybe it's normal but I wipe the inside of the exhaust tips whenever I drive it and they get a dirty black buildup on the inside quickly. They're chrome double wall tips so easy to see it after a decent trip (20-30 miles). I doubt it's the fuel trim, I've had the car dyno tuned with bolt-ons and it still gets that buildup in the tailpipes.
    Quote Originally Posted by TerribleTed View Post
    If your concerned with oil loss..and you dont see a leak,,,do a wet compression check,.,.,else its most likely the usualy Ls1 issue,,that being us dragging the cars or cornering the cars excessively while getting on it,,causing oil to get sucked up thru the PCV system and all....

    I installed a check 2 dollar oil catch can and was amazed at how much oil in 3K of hard driving it picked up,,,that was lost and would have been burned,,,

    So if your wet compression checks out OK,,and u have no oil leaks on the car and your concerned over oil consumtion,,,then try an oil catch can to see how much oil is being sent theu PCV system,,,

    I madfe my PCV catch can out of some black PVC pipes, brass fittings and installed a drain valve (all parts from hardware store for under 5 bucks at most)...now at least the oil it traps does not get burned off into intake,,,
    what this guy sead and compsyn is a good guy to get info from aswell.

  18. #1078
    Junior Member Gohard's Avatar
    Join Date
    May 2010
    Location
    Detroit, MI
    Posts
    67
    2002 WS6 M6

    Ok, so I added one quart and it's been at a good level since.

    Where can I get the compression test?

    The change oil light came on too. Should I just ignore it or is it accurate even with the amsoil I'm using?
    Last edited by Gohard; 08-30-2010 at 05:49 PM.

  19. #1079
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by Gohard View Post
    Ok, so I added one quart and it's been at a good level since.

    Where can I get the compression test?

    The change oil light came on too. Should I just ignore it or is it accurate even with the amsoil I'm using?
    DOn't know about the other stuff. But the Change Oil light works on the number of engine revolutions and operational conditions.. It is acurrate if you reset after changing your oil.

    Reset: turn key to the run/on possition, but do not start it.. Press and hold the trip reset button, after a short time of holding the button the oil light will go out and begin a new count for the next oil change..
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  20. #1080
    Senior Member TLS_Addict's Avatar
    Join Date
    Mar 2008
    Location
    PA
    Posts
    1,706

    Ray Charles blue
    1492

    My Corvettes system didnt work. I came on after a few hundred miles. Same thing with my GTO. The first oil change it came on after 300 miles, the next time 7k miles, then it took 13k miles for it to come on.........and in case you wonder I changed it eer 3-4k miles. It was 60 miles a day almost all highway and I used Mobile 1.

    Not sure if the Z28 will be any better....lol

Page 54 of 70 FirstFirst ... 4142434505152535455565758 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Conversion junkie
    By workingdog in forum New Member Introductions
    Replies: 1
    Last Post: 06-11-2016, 03:09 PM
  2. When do you know your a junkie
    By jakesz28 in forum Nitrous
    Replies: 5
    Last Post: 07-07-2009, 12:02 PM
  3. Southern IN Speed Junkie
    By badblazeSS in forum New Member Introductions
    Replies: 6
    Last Post: 08-24-2008, 10:25 AM
  4. hey ls1 junkie in ga
    By blackbirdpr1 in forum New Member Introductions
    Replies: 1
    Last Post: 05-08-2007, 07:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •